Bug 808356 - Unable to subscribe in firstboot
Unable to subscribe in firstboot
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: John Sefler
Entitlement Bugs
: Regression, Reopened
Depends On:
Blocks: 771481 840699 853281
  Show dependency treegraph
 
Reported: 2012-03-30 04:50 EDT by Marian Ganisin
Modified: 2015-09-27 22:12 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 853281 (view as bug list)
Environment:
Last Closed: 2013-02-21 03:54:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
'Choose Server' screen (120.03 KB, image/png)
2012-04-04 07:25 EDT, Marian Ganisin
no flags Details
'Entitlement Platform Registration' dialog (101.50 KB, image/png)
2012-04-04 07:25 EDT, Marian Ganisin
no flags Details
The newe Choose Service and SAM Server workflow in firstboot (258.50 KB, image/png)
2012-11-21 18:18 EST, John Sefler
no flags Details

  None (edit)
Description Marian Ganisin 2012-03-30 04:50:40 EDT
Description of problem:

When registering in firstboot with skipped automatic subscription (with ckeckbox marked) I don't see dialog with subscription selection. It is skipped and "Create User" form of firstboot is displayed right after clicking Forward button.

Actually this issue doesn't seem to be related to skip autosubscribe checkbox, it occurs even if checkbox isn't selected.

Version-Release number of selected component (if applicable):
subscription-manager-firstboot-0.99.12-1.el6

Impact:
Impossible to subscribe successfully via firstboot
Comment 1 Adrian Likins 2012-04-03 10:34:33 EDT
subscription selection screen has been removed from firstboot for rhel6, so
this is working as intended. (it's basically autosubscribe or nothing now).
Comment 2 Marian Ganisin 2012-04-04 07:24:01 EDT
(In reply to comment #1)
> subscription selection screen has been removed from firstboot for rhel6, so
> this is working as intended. (it's basically autosubscribe or nothing now).

Is there a bugreport for this? Work doesn't seem to be finished.

Screen labelled 'Choose Server' gives this information:

I'd like to receive updates from Red Hat Network or Subscription Asset Manager

Expected result: Clearly state what is really possible (no chance to regiter to SAM for example)

Next screen with label 'Entitlement Platform Registration' provides an option to 'Skip automatic subscription selection for this system'. This is very confusing and actually it is not in accordance with statement: "autosubscribe or nothing".

Expected result: understandable well described registration dialog with only relevant options available. Additionally, there is missing Skip-like button for a case when customer decides to skip it finally (in case of forgotten password for example).
Comment 3 Marian Ganisin 2012-04-04 07:25:01 EDT
Created attachment 575091 [details]
'Choose Server' screen
Comment 4 Marian Ganisin 2012-04-04 07:25:45 EDT
Created attachment 575092 [details]
'Entitlement Platform Registration' dialog
Comment 5 Matt Reid 2012-04-04 15:27:22 EDT
I'm unable to verify at the moment, but the design is detailed at https://engineering.redhat.com/trac/subscription-manager/attachment/wiki/GUIRedesign/Proposed_Firstboot_Wireframes.png . There should be the possibility of registering with a SAM system in the current implementation.

I don't think there's currently an interstitial screen if things fail and you must manually subscribe after booting. I think there's just a pop up dialog that should say something. Did you get any notification, or just get taken straight to the next section? This should happen in cases where the user elected to manually subscribe later, or if autosubscription can't find anything to use. If autosubscribe finds possible subscriptions to use, autosubscribe should check with the user for SLA and then take care of the rest.

Perhaps the current wording is problematic on the checkbox? Right now it says "Skip automatic subscription selection for this system". Would something along the lines of "I would like to manually subscribe (takes place after firstboot)" be more clear about what's going on?
Comment 8 Marian Ganisin 2012-05-04 06:44:34 EDT
Firstboot plugin has been changed and it now reports appropriate information on both possible cases right after registration.

There is still following option on 'Choose Server' form:

I'd like to receive updates from Red Hat Network or Subscription Asset Manager...

This isn't actually correct as there is no chance to register to the SAM at the moment.
Comment 17 John Sefler 2012-11-21 18:18:44 EST
Created attachment 649445 [details]
The newe Choose Service and SAM Server workflow in firstboot

[root@jsefler-6 ~]# rpm -q subscription-manager-firstboot
subscription-manager-firstboot-1.1.10-1.el6.x86_64

See attached screenshot demonstrating fixes for issues raised in comment 8.
Comment 19 errata-xmlrpc 2013-02-21 03:54:26 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0350.html

Note You need to log in before you can comment on or make changes to this bug.