Bug 808364 - [RFE]Add support of virt-p2v to convert machines installed on USB device
[RFE]Add support of virt-p2v to convert machines installed on USB device
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-p2v (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Richard W.M. Jones
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-30 05:22 EDT by tingting zheng
Modified: 2015-03-13 04:54 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-03-13 04:54:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tingting zheng 2012-03-30 05:22:28 EDT
Description of Problem:
As we need to test converting physical host installed on MD device using extern disk such as USB device,so it's better to add support of virt-p2v to discover USB device.

Version-Release number of selected component:
virt-v2v-0.8.7-4.el6.x86_64
rubygem-virt-p2v-0.8.6-2.el6


How reproducible:
Always

Step to Reproduce:
1.Download the virt-p2v iso from brewweb.

2.Insert USB device to the host.

3.Boot the host with virt-p2v from pxe,input the ip and password of conversion server

4.In the conversion UI,you can only find the physical storage sda listed in "Fixed Storage" tab.

Actual Results:
virt-p2v can not discover USB device

Expected Results:
virt-p2v is able to discover USB device

Additional info:
Comment 1 tingting zheng 2012-03-30 05:38:38 EDT
For some customers,they may install operating system in extern device such as USB device,then want to use virt-p2v to convert it,so it is very helpful to add support of virt-p2v to convert machines installed on USB device.
Comment 3 RHEL Product and Program Management 2012-05-03 00:48:41 EDT
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 4 Richard W.M. Jones 2015-03-12 12:53:48 EDT
Tingting is this still a requirement?  If not, I'm going to close it.
Comment 5 tingting zheng 2015-03-12 23:03:22 EDT
(In reply to Richard W.M. Jones from comment #4)
> Tingting is this still a requirement?  If not, I'm going to close it.

It's an RFE bug,not sure whether customer have such requirement,I file this bug just consider from customer's angle refer to comment 1.
Comment 6 Richard W.M. Jones 2015-03-13 04:47:27 EDT
(In reply to tingting zheng from comment #5)
> (In reply to Richard W.M. Jones from comment #4)
> > Tingting is this still a requirement?  If not, I'm going to close it.
> 
> It's an RFE bug,not sure whether customer have such requirement,I file this
> bug just consider from customer's angle refer to comment 1.

I'm just trying to bring the scope of virt-p2v down to things
we can reasonably fix or implement in RHEL 7.2.  Although I do
have machines which boot from USB, I wouldn't imagine this is
a common scenario (for one thing, it's incredibly slow).  If I
add this feature it will take time to do, and require testing.

If it's useful for your testing, then I can look into it, otherwise
I'd like to close it.  Anyway let me know what you want to do
with this BZ.
Comment 7 tingting zheng 2015-03-13 04:52:36 EDT
(In reply to Richard W.M. Jones from comment #6)
> (In reply to tingting zheng from comment #5)
> > (In reply to Richard W.M. Jones from comment #4)
> > > Tingting is this still a requirement?  If not, I'm going to close it.
> > 
> > It's an RFE bug,not sure whether customer have such requirement,I file this
> > bug just consider from customer's angle refer to comment 1.
> 
> I'm just trying to bring the scope of virt-p2v down to things
> we can reasonably fix or implement in RHEL 7.2.  Although I do
> have machines which boot from USB, I wouldn't imagine this is
> a common scenario (for one thing, it's incredibly slow).  If I
> add this feature it will take time to do, and require testing.
> 
> If it's useful for your testing, then I can look into it, otherwise
> I'd like to close it.  Anyway let me know what you want to do
> with this BZ.

For virt-p2v testing,we mainly focus on conversion os installed on different physical hardware,so pls close the bug.
Comment 8 Richard W.M. Jones 2015-03-13 04:54:29 EDT
Thanks - Closing as per comment 7.

Note You need to log in before you can comment on or make changes to this bug.