Bug 808386 - SELinux is preventing /bin/systemd-tmpfiles from 'remove_name' accesses on the directory dbus-socket.
SELinux is preventing /bin/systemd-tmpfiles from 'remove_name' accesses on th...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:3f10d3b01ce44cfe05a93721371...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-30 06:15 EDT by Peque
Modified: 2012-03-30 13:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-30 13:55:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peque 2012-03-30 06:15:25 EDT
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.0-4.fc16.x86_64
reason:         SELinux is preventing /bin/systemd-tmpfiles from 'remove_name' accesses on the directory dbus-socket.
time:           Fri 30 Mar 2012 12:15:07 PM CEST

description:
:SELinux is preventing /bin/systemd-tmpfiles from 'remove_name' accesses on the directory dbus-socket.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that systemd-tmpfiles should be allowed remove_name access on the dbus-socket directory by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep systemd-tmpfile /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:systemd_tmpfiles_t:s0
:Target Context                unconfined_u:object_r:user_home_dir_t:s0
:Target Objects                dbus-socket [ dir ]
:Source                        systemd-tmpfile
:Source Path                   /bin/systemd-tmpfiles
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           systemd-units-37-17.fc16.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-80.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.0-4.fc16.x86_64 #1 SMP Tue
:                              Mar 20 18:05:40 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Fri 30 Mar 2012 12:12:58 PM CEST
:Last Seen                     Fri 30 Mar 2012 12:12:58 PM CEST
:Local ID                      72598e66-0481-4820-8f57-e52c6eeb166d
:
:Raw Audit Messages
:type=AVC msg=audit(1333102378.627:82): avc:  denied  { remove_name } for  pid=2736 comm="systemd-tmpfile" name="dbus-socket" dev="sda1" ino=396328 scontext=system_u:system_r:systemd_tmpfiles_t:s0 tcontext=unconfined_u:object_r:user_home_dir_t:s0 tclass=dir
:
:
:type=SYSCALL msg=audit(1333102378.627:82): arch=x86_64 syscall=unlinkat success=no exit=EACCES a0=5 a1=97c0f3 a2=0 a3=636f732d73756264 items=0 ppid=1 pid=2736 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=systemd-tmpfile exe=/bin/systemd-tmpfiles subj=system_u:system_r:systemd_tmpfiles_t:s0 key=(null)
:
:Hash: systemd-tmpfile,systemd_tmpfiles_t,user_home_dir_t,dir,remove_name
:
:audit2allow
:
:#============= systemd_tmpfiles_t ==============
:allow systemd_tmpfiles_t user_home_dir_t:dir remove_name;
:
:audit2allow -R
:
:#============= systemd_tmpfiles_t ==============
:allow systemd_tmpfiles_t user_home_dir_t:dir remove_name;
:
Comment 1 Daniel Walsh 2012-03-30 13:55:48 EDT
This looks like you have a mislabeled homedir.

restorecon -R -v ~/


Should fix. or you mv'd a homedir to /tmp?

Note You need to log in before you can comment on or make changes to this bug.