Bug 808394 - libnet-1.1.6 is available
libnet-1.1.6 is available
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libnet (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Robert Scheck
Fedora Extras Quality Assurance
: FutureFeature, Triaged
: 787823 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-30 06:26 EDT by Upstream Release Monitoring
Modified: 2012-04-02 06:02 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-30 10:56:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Upstream Release Monitoring 2012-03-30 06:26:52 EDT
Latest upstream release: 1.1.6
Current version in Fedora Rawhide: 1.1.5
URL: http://sourceforge.net/api/file/index/project-name/libnet-dev/mtime/desc/limit/20/rss

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 1 Account closed by user 2012-03-30 09:40:21 EDT
# repoquery --qf "%{sourcerpm}"  --disablerepo='*' --enablerepo=rawhide --whatrequires libnet.so.1 | sort -u

ArpON-2.7-1.fc17.src.rpm
arptools-1.0.2-4.fc17.src.rpm
dhcp_probe-1.3.0-9.fc17.src.rpm
dsniff-2.4-0.11.b1.fc17.src.rpm
etherbat-1.0.1-9.fc17.src.rpm
ettercap-0.7.4.1-1.fc18.src.rpm
firewalk-5.0-7.fc17.src.rpm
gvrpcd-1.3-6.fc18.src.rpm
isic-0.07-7.fc17.src.rpm
libnids-1.24-3.fc17.src.rpm
mausezahn-0.40-2.fc17.src.rpm
resource-agents-3.9.2-2.fc17.1.src.rpm
rsyslog-5.8.7-1.fc17.src.rpm
suricata-1.2.1-2.fc18.src.rpm
syslog-ng-3.2.5-6.fc18.src.rpm
yersinia-0.7.1-8.fc17.src.rpm
Comment 2 Gwyn Ciesla 2012-03-30 09:45:13 EDT
Crud, thanks, I used --whatrequires and --alldeps and only got suricata, syslog-ng and libnids.  I'll get the rest.
Comment 3 Gwyn Ciesla 2012-03-30 10:56:04 EDT
Rebuilds of all the above complete against 1.1.6.  Let me know if any issues turn up.
Comment 4 Dave Jones 2012-03-30 11:29:03 EDT
*** Bug 787823 has been marked as a duplicate of this bug. ***
Comment 5 Ritesh Dhandha 2012-03-31 00:59:43 EDT
I am seeing this issue since long, waiting for this fix.
how can I get libnet-1.1.6 ? 
yum install libnet-1.1.6 doesn't seems to be getting it.
please let me know any workaround.
Comment 6 Ritesh Dhandha 2012-03-31 01:03:25 EDT
I am seeing this issue since long, waiting for this fix.
how can I get libnet-1.1.6 ? 
yum install libnet-1.1.6 doesn't seems to be getting it.
please let me know any workaround.
Comment 7 Gwyn Ciesla 2012-03-31 12:43:10 EDT
I only built it for rawhide(f18) because it's a soname change, which requires a rebuild of everything built against it.  If you need it for an earlier release, you'll need to rebuild it locally for that release and also rebuild anything you have installed that uses it.  You can find the SRPM here:

http://koji.fedoraproject.org/koji/buildinfo?buildID=310572

If you need assistance with this let me know.
Comment 8 Account closed by user 2012-04-02 06:02:01 EDT
API changes/compatibility report for the libnet library :

 <http://upstream-tracker.org/versions/libnet.html>

Note You need to log in before you can comment on or make changes to this bug.