Bug 808398 - Japanese: All Pop ups needs translation
Summary: Japanese: All Pop ups needs translation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: CloudForms Cloud Engine
Classification: Retired
Component: aeolus-conductor
Version: 1.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
Assignee: Imre Farkas
QA Contact: wes hayutin
URL:
Whiteboard:
Depends On:
Blocks: 826119
TreeView+ depends on / blocked
 
Reported: 2012-03-30 10:31 UTC by Aziza Karol
Modified: 2012-12-04 15:02 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Some pop up windows in Cloud Engine (Japanese) were not translated. This bug fix adds translation so that all pop-up windows display in the designated language.
Clone Of:
: 826119 (view as bug list)
Environment:
Last Closed: 2012-12-04 15:02:20 UTC


Attachments (Terms of Use)
pop ups (331.29 KB, image/png)
2012-03-30 10:32 UTC, Aziza Karol
no flags Details
popup on 1.0.1 branch (329.09 KB, image/png)
2012-05-24 09:11 UTC, Imre Farkas
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2012:1516 0 normal SHIPPED_LIVE CloudForms Cloud Engine 1.1 update 2012-12-04 19:51:45 UTC

Description Aziza Karol 2012-03-30 10:31:53 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
In All confirmation pop up, the text is displayed in English. 
For example see attached screenshot.
  



Expected results:
All text in confirmation pop ups needs to be translated to Japanese


Additional info:
rpm -qa | grep aeolus
aeolus-conductor-0.8.3-1.el6.noarch
aeolus-conductor-daemons-0.8.3-1.el6.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-configure-2.5.2-1.el6.noarch
aeolus-all-0.8.3-1.el6.noarch
rubygem-aeolus-cli-0.3.1-1.el6.noarch
aeolus-conductor-doc-0.8.3-1.el6.noarch

Comment 1 Aziza Karol 2012-03-30 10:32:36 UTC
Created attachment 573948 [details]
pop ups

Comment 3 Angus Thomas 2012-05-23 11:00:22 UTC
Imre,

Please male the necessary code changes to ensure that these strings can be sourced from the dictionaries.

Once that is done, we can request whatever new/additional translations are required

Comment 4 Imre Farkas 2012-05-24 09:11:55 UTC
Created attachment 586590 [details]
popup on 1.0.1 branch

I am not able to reproduce this issue neither on current 1.0.1 branch nor on current master

Comment 5 Aziza Karol 2012-05-25 13:29:27 UTC
All confirmation pop ups text is translated to Japanese.

verified:
rpm -qa | grep aeolus
aeolus-configure-2.5.3-1.el6.noarch
aeolus-conductor-0.8.13-1.el6_2.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.3.1-1.el6.noarch
aeolus-all-0.8.13-1.el6_2.noarch
aeolus-conductor-doc-0.8.13-1.el6_2.noarch
aeolus-conductor-daemons-0.8.13-1.el6_2.noarch

Comment 8 errata-xmlrpc 2012-12-04 15:02:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html


Note You need to log in before you can comment on or make changes to this bug.