Bug 808451 - wrong(?) label on postgresql postmaster.pid file
wrong(?) label on postgresql postmaster.pid file
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy (Show other bugs)
6.3
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Miroslav Grepl
Michal Trunecka
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-30 08:37 EDT by Milos Malik
Modified: 2014-09-30 19:33 EDT (History)
5 users (show)

See Also:
Fixed In Version: selinux-policy-3.7.19-144.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 08:32:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milos Malik 2012-03-30 08:37:33 EDT
Description of problem:


Version-Release number of selected component (if applicable):
postgresql-8.4.9-1.el6_1.1.x86_64
postgresql-server-8.4.9-1.el6_1.1.x86_64
postgresql-libs-8.4.9-1.el6_1.1.x86_64

How reproducible:
always

Steps to Reproduce:
# run_init service postgresql status
Authenticating root.
Password: 
postmaster is stopped
# restorecon -Rv /var
# run_init service postgresql start
Authenticating root.
Password: 
Starting postgresql service:                               [  OK  ]
# restorecon -Rv /var
restorecon reset /var/run/postmaster.5432.pid context system_u:object_r:initrc_var_run_t:s0->system_u:object_r:postgresql_var_run_t:s0
# 

Actual results:
* PID file is not labelled correctly

Expected results:
* PID file is labelled correctly
Comment 2 Tom Lane 2012-03-30 10:03:31 EDT
How would the script run restorecon on the PID file, when that doesn't exist beforehand?  If this is a bug, which I doubt, then it seems to me that it should be the province of the selinux policy to get this right to start with.
Comment 3 Milos Malik 2012-03-30 10:35:39 EDT
# grep pidfile= /etc/init.d/postgresql 
pidfile="/var/run/postmaster.${PGPORT}.pid"
#

The init script creates the PID file. Path to the PID file is known. Calling restorecon at the end of start() would be enough.
Comment 4 Tom Lane 2012-03-30 10:50:44 EDT
My point is that the file doesn't exist beforehand and so it is being created under the control of the current security policy.  If it's not correctly labeled, that's the fault of the security policy, not this script.

More to the point, since no AVC denial occurs, I suspect that the labeling is just fine and so the real problem is not the actual label but restorecon's opinion of what the label "should be".  I wouldn't be too surprised if adding a restorecon here created a problem instead of fixing one.

Anyway, reassigning to selinux-policy to see what they think.
Comment 5 Daniel Walsh 2012-03-30 12:54:55 EDT
Does postgresql actually write to this file?  Or is it just created by the init script?
Comment 6 Tom Lane 2012-03-30 13:35:03 EDT
(In reply to comment #5)
> Does postgresql actually write to this file?  Or is it just created by the init script?

At the moment it's created directly by the init script, via code like
  echo $pid > "$pidfile"

The whole thing is gone anyway in the systemd implementation, and if anyone complains about that we'd probably have to do something different to make it happen there.
Comment 7 Daniel Walsh 2012-03-30 13:43:44 EDT
Well then we should leave it labeled as initrc_var_run_t.
Comment 8 Miroslav Grepl 2012-04-02 06:08:43 EDT
Ok, then I will remove the labeling.
Comment 13 errata-xmlrpc 2012-06-20 08:32:48 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0780.html

Note You need to log in before you can comment on or make changes to this bug.