Bug 80857 - post-install invokes non-existant gdk-pixbuf-query-loaders
post-install invokes non-existant gdk-pixbuf-query-loaders
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: librsvg2 (Show other bugs)
phoebe
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks: 79578
  Show dependency treegraph
 
Reported: 2002-12-31 22:41 EST by Kjetil T. Homme
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-17 09:37:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kjetil T. Homme 2002-12-31 22:41:20 EST
Description of problem:
the post-install references a program which doesn't exist.

Version-Release number of selected component (if applicable):
librsvg2-2.1.2-2

How reproducible:
always

Steps to Reproduce:
1.install librsvg2
2.
3.
    
Actual results:
 130:librsvg2               ########################################### [ 28%]
/var/tmp/rpm-tmp.1043: line 3: gdk-pixbuf-query-loaders: command not found
error: %post(librsvg2-2.1.2-2) scriptlet failed, exit status 127


Expected results:
no error

Additional info:
# rpm --redhatprovides gdk-pixbuf-query-loaders
no package provides gdk-pixbuf-query-loaders
# rpm -qa | grep gdk-pixbuf
gdk-pixbuf-0.18.0-5
gdk-pixbuf-gnome-0.18.0-5
gdk-pixbuf-devel-0.18.0-5

(and a Happy New Year! :-)
Comment 1 Alexander Larsson 2003-01-16 06:18:34 EST
Very strange. gdk-pixbuf-query-loaders is from the gtk2 package, and that
package is required by librsvg2. 

I get no warning for this. Do you have gtk2 installed?

Comment 2 Kjetil T. Homme 2003-01-16 18:35:30 EST
ah, I see the problem.  at the time, I had gtk2-2.0.6-8 installed, which doesn't have gdk-pixbuf-query-loaders.  so you need to increase the version in your gtk2 dependency to at least that.  it's currently 2.0.2.
Comment 3 Alexander Larsson 2003-01-17 09:37:36 EST
librsvg2-2.1.3-3 requires gtk2 2.2.0, so it should fix this.

Note You need to log in before you can comment on or make changes to this bug.