Bug 808579 - USB-Share does not work in a Windows XP guest with Virt-viewer.
USB-Share does not work in a Windows XP guest with Virt-viewer.
Status: CLOSED DUPLICATE of bug 809953
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-gtk (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Marc-Andre Lureau
Desktop QE
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-30 14:39 EDT by Bill Sanford
Modified: 2012-04-05 10:19 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-05 10:19:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Sanford 2012-03-30 14:39:25 EDT
Description of problem:
The USB-Share does not work in a Windows XP guest with Virt-viewer.

Spice client RHEL 6.3 - 64bit
virt-viewer-0.5.2-3.el6.x86_64
spice-gtk-0.11-5.el6.x86_64
spice-client-0.8.2-13.el6.x86_64
spice-usb-share-4.9-9.el6.x86_64
spice-xpi-2.7-15.el6.x86_64
kmod-kspiceusb-rhel60-4.9-14.el6.x86_64
spice-gtk-python-0.11-5.el6.x86_64
spice-vdagent-0.8.1-3.el6.x86_64
spice-glib-0.11-5.el6.x86_64

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Edit User Portal console to allow "Enable USB Auto-Share"
2. Launch Win XP VM.
3. With the spice window full-screen or in focus, insert USB stick.
  
Actual results:
USB is not seen from the Win XP guest.

Expected results:
USB is seen from the Win XP guest.

Additional info:

spice-vdagent-0.8.1-3.el6.x86_64 
spice-server-0.10.1-4.el6.x86_64 
spice host RHEL 6.3 - 64bit 
rhevm ic155 
qemu-kvm-0.12.1.2-2.246.el6.x86_64 
qemu-kvm-tools-0.12.1.2-2.246.el6.x86_64 

Spice guest Windows 7 or XP 
qxl x.1.0.10012 
rhev-usb-msi-4.7-8
Comment 1 Bill Sanford 2012-03-30 14:42:01 EDT
I tailed the /var/log/messages file and the difference between Win7 USB that works and the WinXP USB that fails, is at:

http://pastebin.test.redhat.com/83651
Comment 2 Marc-Andre Lureau 2012-03-30 16:14:39 EDT
Is usbrdrctrl running?
Could you paste his log too?
Have you verified that it works fine when you switch the spice-xpi-client with spicec?

thanks
Comment 4 Bill Sanford 2012-04-05 10:19:46 EDT

*** This bug has been marked as a duplicate of bug 809953 ***

Note You need to log in before you can comment on or make changes to this bug.