Bug 808596 - Regression: Environments not rendered correctly when assigning default while adding new user
Regression: Environments not rendered correctly when assigning default while ...
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Jason E. Rist
Corey Welton
: Regression, Triaged
Depends On: 808576
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-30 15:30 EDT by Steve Reichard
Modified: 2013-08-16 14:21 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-15 14:59:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot (101.21 KB, image/png)
2012-03-30 15:30 EDT, Steve Reichard
no flags Details
Issue exists on Firefox and Chrome (18.32 KB, image/png)
2012-04-05 15:54 EDT, Og Maciel
no flags Details

  None (edit)
Description Steve Reichard 2012-03-30 15:30:31 EDT
Created attachment 574081 [details]
screen shot

Description of problem:

Look at attached screen shot - notice the Environment.  

This seems to be a regression. Did not see this in the 2012-03-22.3 puddle

FYI - I have the following envs

Library - common
Library - dev - test - prod



Version-Release number of selected component (if applicable):


Red Hat Enterprise Linux Server release 6.2 (Santiago)
Linux cf-se1.cloud.lab.eng.bos.redhat.com 2.6.32-220.7.1.el6.x86_64 #1 SMP Fri Feb 10 15:22:22 EST 2012 x86_64 x86_64 x86_64 GNU/Linux
PyYAML-3.09-15.el6.x86_64
facter-1.5.9-1.el6.noarch
js-1.8.5-7.el6.x86_64
mongodb-1.8.2-4.el6.x86_64
mongodb-server-1.8.2-4.el6.x86_64
puppet-2.6.14-1.el6.noarch
pymongo-1.9-10.el6.x86_64
tomcat6-6.0.24-35.el6_1.noarch
ruby-1.8.7.352-7.el6_2.x86_64
grinder-0.0.142-1.el6.noarch
postgresql-server-8.4.9-1.el6_1.1.x86_64
postgresql-8.4.9-1.el6_1.1.x86_64
candlepin-0.5.26-1.el6.noarch
pulp-1.0.2-1.el6.noarch
katello-0.1.307-1.el6.noarch
katello-all-0.1.307-1.el6.noarch
katello-cli-0.1.107-1.el6.noarch
katello-configure-0.1.107-1.el6.noarch




How reproducible:



Happened for all my users that I create, one for each env.


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jason E. Rist 2012-04-02 12:50:53 EDT
Fixed in commit 6cab6c6893f19cd08055f45746e31db5b9a4eb28
Author: Jason E. Rist <jrist@redhat.com>
Date:   Mon Apr 2 10:00:41 2012 -0600

    808576 - Regression for IE only stylesheet. Added back in.
Comment 2 Mike McCune 2012-04-04 01:27:30 EDT
Adding a Beta6 blocker on this since it is a regression caused by our earlier IE8 bugfixes we did.  very very low risk fix that cleans up a really nasty UI display issue.
Comment 4 Og Maciel 2012-04-05 15:54:40 EDT
Created attachment 575537 [details]
Issue exists on Firefox and Chrome

Still seeing it in katello-0.1.309-1.el6.noarch
Comment 5 Jason E. Rist 2012-04-05 17:35:59 EDT
Production embedded assets nested conditional issue.  Fixed (for real) in:
commit 19e3d40aae1a29d13ffe74e4612bb3306fd83f18
Author: Jason E. Rist <jrist@redhat.com>
Date:   Thu Apr 5 15:34:30 2012 -0600

    808596 - Initial fix didn't take into consideration production mode.
Comment 6 Og Maciel 2012-04-09 14:35:12 EDT
Need version higher than katello-0.1.309-1.el6.noarch to validate.
Comment 7 Mike McCune 2012-04-10 18:35:39 EDT
moving into CF 1.0 because we have todo another spin for:

https://bugzilla.redhat.com/show_bug.cgi?id=810375
Comment 9 Mike McCune 2012-04-16 15:41:18 EDT
This bug also needs an additional use case tested:

* Make sure you can select individual environments in the Promotions page and that the UI will navigate you to that selected environment.

Without the above fix clicking on the environment results in no browser action.
Comment 11 Corey Welton 2012-04-19 15:07:05 EDT
QA Verified  - 

* Environments box renders correctly in user creation
* Environments box renders correctly in promotions and the proper environment(s) can be selected to move Products through the promotion path
* Tested this in organizations which have more than one promotion path (library> dev > qa > stage > prod; library > hotfix, etc.) and in all cases, both paths allow user assignment, selection of environment, etc.

Tested in brew build for CloudForms System Engine Version: 0.1.310-1.el6_2
Comment 12 errata-xmlrpc 2012-05-15 14:59:29 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0665.html
Comment 13 Mike McCune 2013-08-16 14:21:08 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.