Bug 808632 - SELinux is preventing /bin/dbus-daemon from 'read' accesses on the file /home/gene/.local/share/icc/edid-ae516e8e21203ef1ebbaf796c5a50995.icc.
SELinux is preventing /bin/dbus-daemon from 'read' accesses on the file /home...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:d4229c33bf6fe06df2040d97dea...
:
: 808633 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-30 18:37 EDT by Gene Snider
Modified: 2015-05-05 19:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-02 06:24:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
genes1122: needinfo-


Attachments (Terms of Use)

  None (edit)
Description Gene Snider 2012-03-30 18:37:54 EDT
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.0-8.fc16.x86_64
reason:         SELinux is preventing /bin/dbus-daemon from 'read' accesses on the file /home/gene/.local/share/icc/edid-ae516e8e21203ef1ebbaf796c5a50995.icc.
time:           Fri 30 Mar 2012 03:37:15 PM PDT

description:
:SELinux is preventing /bin/dbus-daemon from 'read' accesses on the file /home/gene/.local/share/icc/edid-ae516e8e21203ef1ebbaf796c5a50995.icc.
:
:*****  Plugin restorecon (99.5 confidence) suggests  *************************
:
:If you want to fix the label. 
:/home/gene/.local/share/icc/edid-ae516e8e21203ef1ebbaf796c5a50995.icc default label should be icc_data_home_t.
:Then you can run restorecon.
:Do
:# /sbin/restorecon -v /home/gene/.local/share/icc/edid-ae516e8e21203ef1ebbaf796c5a50995.icc
:
:*****  Plugin catchall (1.49 confidence) suggests  ***************************
:
:If you believe that dbus-daemon should be allowed read access on the edid-ae516e8e21203ef1ebbaf796c5a50995.icc file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep dbus-daemon /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:system_dbusd_t:s0-s0:c0.c1023
:Target Context                unconfined_u:object_r:var_run_t:s0
:Target Objects                /home/gene/.local/share/icc/edid-
:                              ae516e8e21203ef1ebbaf796c5a50995.icc [ file ]
:Source                        dbus-daemon
:Source Path                   /bin/dbus-daemon
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           dbus-1.4.10-3.fc16.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-81.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.0-8.fc16.x86_64 #1 SMP Thu Mar
:                              29 18:37:19 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Fri 30 Mar 2012 03:33:06 PM PDT
:Last Seen                     Fri 30 Mar 2012 03:33:06 PM PDT
:Local ID                      4518198c-fbf8-454f-8397-ce3fff204495
:
:Raw Audit Messages
:type=AVC msg=audit(1333146786.506:74): avc:  denied  { read } for  pid=918 comm="dbus-daemon" path="/home/gene/.local/share/icc/edid-ae516e8e21203ef1ebbaf796c5a50995.icc" dev="sda9" ino=130906 scontext=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:var_run_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1333146786.506:74): arch=x86_64 syscall=recvmsg success=yes exit=402 a0=1a a1=7fff22b6d8e0 a2=40000000 a3=0 items=0 ppid=1 pid=918 auid=4294967295 uid=81 gid=81 euid=81 suid=81 fsuid=81 egid=81 sgid=81 fsgid=81 tty=(none) ses=4294967295 comm=dbus-daemon exe=/bin/dbus-daemon subj=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 key=(null)
:
:Hash: dbus-daemon,system_dbusd_t,var_run_t,file,read
:
:audit2allow
:
:#============= system_dbusd_t ==============
:allow system_dbusd_t var_run_t:file read;
:
:audit2allow -R
:
:#============= system_dbusd_t ==============
:allow system_dbusd_t var_run_t:file read;
:
Comment 1 Miroslav Grepl 2012-04-02 06:20:14 EDT
*** Bug 808633 has been marked as a duplicate of this bug. ***
Comment 2 Miroslav Grepl 2012-04-02 06:24:10 EDT
Did you move this profile to the /home/gene/.local/share/icc directory?

$ restorecon -R -v /home/gene/.local

will fix it.

Note You need to log in before you can comment on or make changes to this bug.