Bug 808667 - Cannot type at all at GDM login screen.
Cannot type at all at GDM login screen.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-31 01:57 EDT by Stef Walter
Modified: 2013-08-01 06:07 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-01 06:07:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log from when the problem is happening (97.46 KB, text/plain)
2012-05-13 00:50 EDT, Stef Walter
no flags Details
Xorg.0.log (41.37 KB, text/plain)
2012-09-06 13:51 EDT, Salvatore Filippone
no flags Details

  None (edit)
Description Stef Walter 2012-03-31 01:57:19 EDT
Description of problem:

No keystrokes work at all at the GDM login screen. Mouse clicks respond, but the keyboard doesn't work at all. For example typing the password in the password field just doesn't respond. Pressing keys has absolutely no response, no beep no nothing.

Work around is to suspend (using the menu in the top right corner) and then resume. After this the keyboard works.

This is a desktop computer. Would be happy to provide further info.

Version-Release number of selected component (if applicable):

Linux stef-desktop.thewalter.lan 3.3.0-5.fc17.x86_64 #1 SMP Fri Mar 23 20:10:36 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Name        : gdm
Arch        : x86_64
Epoch       : 1
Version     : 3.3.92.1
Release     : 1.fc17

How reproducible:

Used to be intermittent. With recent F17 updates, this seems to now happen on every boot.

Steps to Reproduce:
1. Turn on computer.
2. Try to log in.
  
Actual results:

Cannot log in.

Expected results:

Can use keyboard to log in.
Comment 1 Stef Walter 2012-03-31 01:59:16 EDT
Different from bug #803907 in that there's no beep when I type.
Comment 2 Stef Walter 2012-05-02 01:59:15 EDT
Seeing this again for the last few days.
Comment 3 Ray Strode [halfline] 2012-05-03 13:46:33 EDT
Can you switch VTs ?
Comment 4 Ray Strode [halfline] 2012-05-03 13:49:46 EDT
Seemingly an X issue.  Peter, any ideas?
Comment 5 Stef Walter 2012-05-08 03:22:46 EDT
Happened again today. Cannot switch VTs. The keyboard seems completely locked. For example pressing numlock does not change the numlock indicator state.

GDM is otherwise responsive to the mouse. I usually use the mouse to suspend the machine. After resuming the machine (using the power button) I'm returned to the GDM login screen and the keyboard is responsive. It seems that this workaround always works.
Comment 6 Ray Strode [halfline] 2012-05-08 10:45:02 EDT
if you ssh in from another machine and run the chvt command twice (switch to a different VT, then switch back) does the keyboard start working again?

Can you post /var/log/Xorg.0.log when the problem happens ?
Comment 7 Peter Hutterer 2012-05-08 17:55:48 EDT
can I get the Xorg.log please?
Comment 8 Peter Hutterer 2012-05-09 17:57:09 EDT
also, do you see the same behaviour when starting in to the multi-user.target and then start X manually with startx?
Comment 9 Stef Walter 2012-05-10 00:51:48 EDT
This happens in batches (for the last six months or so), and for the last few days it hasn't manifested itself. Will get this info when it happens again.
Comment 10 Stef Walter 2012-05-13 00:50:45 EDT
Created attachment 584093 [details]
Xorg.0.log from when the problem is happening

This was scp'd from the machine while GDM was unresponsive to the keyboard.
Comment 11 Stef Walter 2012-05-13 00:52:53 EDT
(In reply to comment #6)
> if you ssh in from another machine and run the chvt command twice (switch to a
> different VT, then switch back) does the keyboard start working again?

If I change VT (via chvt while ssh'd in) I still cannot type at the keyboard whether at the text VT or at GDM.
Comment 12 Peter Hutterer 2012-05-13 20:40:23 EDT
stab in the dark: same issue if you use qwerty instead of dvorak?
Comment 13 Stef Walter 2012-06-29 10:48:44 EDT
I updated to a partial rawhide and this no longer happens. Although gnome-shell is no longer being used at the gdm login screen, so it may be that my system is atypical.

I also tried using qwerty in xorg.conf instead of dvorak, and for a couple weeks the problem didn't occur. However I've had similar blocks of time when using the keyboard at the GDM login screen worked.

I'll let you know if this happens again.
Comment 14 Stef Walter 2012-08-03 05:47:03 EDT
Confirming that with qwerty in xorg.conf this problem has not happened again.
Comment 15 Salvatore Filippone 2012-09-05 04:32:23 EDT
I am seeing same symptoms on an FC16 desktop install at home. I sure never enabled explicitly dvorak; ssh works fine, will try the other suggestions tonight and send all info I can find
Comment 16 Salvatore Filippone 2012-09-05 13:41:13 EDT
Ok, so I tried chvt and I issued telinit 3; then I issued startx from a user account, and everything works properly. It looks like it is a problem with gdm.
I am trying to update to FC17 to see if it makes a difference; at least I shall report against the latest version available.
Comment 17 Salvatore Filippone 2012-09-06 13:51:42 EDT
Created attachment 610444 [details]
Xorg.0.log
Comment 18 Salvatore Filippone 2012-09-06 13:54:12 EDT
Ok, so this is from an upgrade to FC17 from the same machine. 
This is really really annoying; none of the other suggestions work, except maybe for going to initlevel 3 and doing startx from the command line (something I can do, but not the rest of my family). 
Any ideas? (Short of reinstalling?)

Any further info needed? 
Thanks
Salvatore
Comment 19 Salvatore Filippone 2012-09-06 13:57:30 EDT
Just in case...

[root@localhost ~]# uname -a
Linux localhost.localdomain 3.5.3-1.fc17.x86_64 #1 SMP Wed Aug 29 18:46:34 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
Comment 20 Fedora End Of Life 2013-07-03 23:05:06 EDT
This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter:  Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 17 is end of life. If you 
would still like  to see this bug fixed and are able to reproduce it 
against a later version  of Fedora, you are encouraged  change the 
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 21 Fedora End Of Life 2013-08-01 06:07:44 EDT
Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.