Bug 808688 - RHEL6.3 guest will lost vcpu after resume from S4
RHEL6.3 guest will lost vcpu after resume from S4
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.3
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Virtualization Maintenance
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-31 04:29 EDT by FuXiangChun
Modified: 2012-03-31 05:05 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-31 05:05:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description FuXiangChun 2012-03-31 04:29:44 EDT
Description of problem:
The first hotplug a vcpu to rhel6.3 guest. after then do S4 inside guest. 
the last check guest vcpu number after resume from S4.  guest will lose vcpu of hotplugging.  Since S4 cause different behaviors of windows and rhel guests . So I open this bug. Another bug 808680 is about windows2008r2 guest.  

Version-Release number of selected component (if applicable):
# rpm -qa|grep qemu
qemu-kvm-0.12.1.2-2.267.el6.x86_64

# uname -r
2.6.32-259.el6.x86_64

guest kernel version:
2.6.32-251.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.CLI
/usr/libexec/qemu-kvm -M rhel6.3.0 -cpu Opteron_G3,-kvmclock --enable-kvm -m 4G -smp 1,cores=4,sockets=40,threads=1,maxcpus=161 -name rhel6.3 -uuid ddcbfb49-3411-1701-3c36-6bdbc00bedbb -rtc base=utc,clock=host,driftfix=slew -boot c -drive file=/home/rhel6.3-64.qcow2.bak,if=none,id=ide,format=qcow2,cache=none,werror=stop,rerror=stop,boot=on -device ide-drive,drive=ide,id=drive-ide0-0-0,bootindex=1 -netdev tap,id=hostnet1 -device virtio-net-pci,netdev=hostnet1,id=net1,mac=32:12:50:a4:32:74 -spice port=5914,disable-ticketing -vga qxl -device sga -chardev socket,id=serial0,path=/var/test3,server,nowait -device isa-serial,chardev=serial0 -monitor unix:/tmp/monitor4,server,nowait -monitor stdio -qmp tcp:0:6667,server,nowait

2.hot plug a vcpu to guest
cpu_set 1 online

3.do S4 
echo disk >/sys/power/state

4. resume guest 
  
Actual results:
vcpu lost

Expected results:
vcpu don't lose

Additional info:
Comment 2 FuXiangChun 2012-03-31 05:02:56 EDT
I found that rhel6.3 guest don't lose vcpus after resume from S4. so I close this bug.

Note You need to log in before you can comment on or make changes to this bug.