Bug 808715 - unexpected error message appears when trying to create app without an existing domain
unexpected error message appears when trying to create app without an existin...
Status: CLOSED DUPLICATE of bug 808318
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
1.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-31 06:37 EDT by Meng Bo
Modified: 2012-03-31 06:50 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-31 06:50:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Meng Bo 2012-03-31 06:37:05 EDT
Description of problem:
create app without an existing domain will get the following error info:
/usr/lib/ruby/gems/1.8/gems/rhc-0.89.10/lib/rhc-common.rb:384:in `create_app': undefined method `[]' for nil:NilClass (NoMethodError)
	from /usr/lib/ruby/gems/1.8/gems/rhc-0.89.10/bin/rhc-app:231:in `create_app'
	from /usr/lib/ruby/gems/1.8/gems/rhc-0.89.10/bin/rhc-app:565
	from /usr/bin/rhc-app:19:in `load'
	from /usr/bin/rhc-app:19


Version-Release number of selected component (if applicable):
rhc-0.89.10

How reproducible:
always

Steps to Reproduce:
1.register an new user 
2.try to create app without create domain
3.
  
Actual results:
unexpected error message appears

Expected results:
should have meaningful warning message tell user that domain is required.

Additional info:
Comment 1 Meng Bo 2012-03-31 06:50:52 EDT

*** This bug has been marked as a duplicate of bug 808318 ***

Note You need to log in before you can comment on or make changes to this bug.