Bug 808779 - SELinux is preventing /usr/bin/evince from 'create' accesses on the file LARGA_2011.pdf.
SELinux is preventing /usr/bin/evince from 'create' accesses on the file LARG...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:053682799f76a236b0b592dcfa6...
:
: 808932 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-31 16:07 EDT by Boricua
Modified: 2012-04-02 06:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-02 06:46:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Boricua 2012-03-31 16:07:52 EDT
libreport version: 2.0.10
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.0-8.fc17.x86_64
time:           Sat 31 Mar 2012 04:06:11 PM AST

description:
:SELinux is preventing /usr/bin/evince from 'create' accesses on the file LARGA_2011.pdf.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that evince should be allowed create access on the LARGA_2011.pdf file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep EvJobScheduler /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
:                              0.c1023
:Target Context                unconfined_u:object_r:user_home_t:s0
:Target Objects                LARGA_2011.pdf [ file ]
:Source                        EvJobScheduler
:Source Path                   /usr/bin/evince
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           evince-3.4.0-1.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-106.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.0-8.fc17.x86_64 #1 SMP Thu Mar 29
:                              18:18:26 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Sat 31 Mar 2012 04:04:53 PM AST
:Last Seen                     Sat 31 Mar 2012 04:04:53 PM AST
:Local ID                      f8295205-e573-40b9-8232-2ed15579b1b3
:
:Raw Audit Messages
:type=AVC msg=audit(1333224293.880:609): avc:  denied  { create } for  pid=24997 comm="EvJobScheduler" name="LARGA_2011.pdf" scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1333224293.880:609): arch=x86_64 syscall=open success=no exit=EACCES a0=7f6bc4117480 a1=c1 a2=1b6 a3=aaaaaaaaaaaaaaab items=0 ppid=1 pid=24997 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=2 comm=EvJobScheduler exe=/usr/bin/evince subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)
:
:Hash: EvJobScheduler,mozilla_plugin_t,user_home_t,file,create
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Miroslav Grepl 2012-04-02 06:41:34 EDT
*** Bug 808932 has been marked as a duplicate of this bug. ***
Comment 2 Miroslav Grepl 2012-04-02 06:46:56 EDT
You will need to turn off this protection

either using

$ setsebool unconfined_mozilla_plugin_transition off

or to make this permanent

$ setsebool -P unconfined_mozilla_plugin_transition 0


Or you can remove mozplugger

yum remove mozplugger

Note You need to log in before you can comment on or make changes to this bug.