Bug 808793 - Segmentation fault in child process every time server tries to serve via SSL
Segmentation fault in child process every time server tries to serve via SSL
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
17
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Joe Orton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-31 20:22 EDT by Adam Williamson
Modified: 2012-05-08 00:21 EDT (History)
4 users (show)

See Also:
Fixed In Version: httpd-2.2.22-4.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-08 00:21:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace from the crash (12.05 KB, text/plain)
2012-03-31 20:23 EDT, Adam Williamson
no flags Details

  None (edit)
Description Adam Williamson 2012-03-31 20:22:23 EDT
After updating my production server to Fedora 17 (I know, I know. I'm QA. I'm *supposed* to do silly things), httpd child processes are segfaulting every time I try to access anything via https.

I've tried with openssl 1.0.0g-4 and 1.0.0h-1, same result. I'll attach the backtrace. I think I tracked down all .rpmnew files, so that shouldn't a problem. Little help? :)
Comment 1 Adam Williamson 2012-03-31 20:23:02 EDT
Created attachment 574249 [details]
backtrace from the crash
Comment 2 Adam Williamson 2012-03-31 20:23:24 EDT
CCing tmraz as this seems to have something to do with openssl.
Comment 3 Adam Williamson 2012-03-31 20:40:44 EDT
Many thanks to 'Sling' from #httpd IRC, figured out this was because httpd was built against openssl 1.0.1 during the brief time it was in F17 and never rebuilt when we bumped back down to 1.0.0. I tested and confirmed that a rebuild against 1.0.0 fixes this. I'm sending through a rebuild of httpd as an update.
Comment 4 Fedora Update System 2012-03-31 20:50:30 EDT
httpd-2.2.22-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/httpd-2.2.22-3.fc17
Comment 5 Fedora Update System 2012-04-01 13:35:34 EDT
Package httpd-2.2.22-3.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing httpd-2.2.22-3.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-5174/httpd-2.2.22-3.fc17
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-05-01 11:17:27 EDT
httpd-2.2.22-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/httpd-2.2.22-4.fc17
Comment 7 Fedora Update System 2012-05-08 00:21:26 EDT
httpd-2.2.22-4.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.