Bug 808843 - When using virt-v2v to convert rhel5 guest with both PV and non-PV kernels on kvm or esx,error:Couldn't guess kernel version number
Summary: When using virt-v2v to convert rhel5 guest with both PV and non-PV kernels on...
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-v2v
Version: 6.3
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Matthew Booth
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-01 09:43 UTC by tingting zheng
Modified: 2014-11-18 11:27 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-18 11:27:33 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description tingting zheng 2012-04-01 09:43:45 UTC
Description of Problem:
When using virt-v2v to convert rhel5 guest with both PV and non-PV kernels on kvm or esx,error:Couldn't guess kernel version number

Version-Release number of selected component (if applicable):
virt-v2v-0.8.7-4.el6.x86_64
libvirt-0.9.10-9.el6.x86_64
llibguestfs-1.16.12-1.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1.Install rhel5.8 guest on kvm or esx,both regular kernel and xen kernel installed.
# uname -r
2.6.18-305.el5xen

# cat /etc/grub.conf
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,0)
#          kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00
#          initrd /initrd-version.img
#boot=/dev/hda
default=0
timeout=5
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title Red Hat Enterprise Linux Server (2.6.18-305.el5xen)
	root (hd0,0)
	kernel /xen.gz-2.6.18-305.el5 
	module /vmlinuz-2.6.18-305.el5xen ro root=/dev/VolGroup00/LogVol00 console=tty0 console=ttyS0,115200n8 rhgb quiet
	module /initrd-2.6.18-305.el5xen.img
title Red Hat Enterprise Linux Server-base (2.6.18-305.el5)
	root (hd0,0)
	kernel /vmlinuz-2.6.18-305.el5 ro root=/dev/VolGroup00/LogVol00 console=tty0 console=ttyS0,115200n8 rhgb quiet
	initrd /initrd-2.6.18-305.el5.img

2.Use virt-v2v to convert the guest.
# virt-v2v -o rhev -os 10.66.90.115:/vol/v2v_auto/auto_export -n rhevm rhel5.8
rhel5.8.img: 100% [====================================================================================]D 0h04m02s
Couldn't guess kernel version number from path for kernel /boot/xen.gz-2.6.18-305.el5 at /usr/share/perl5/vendor_perl/Sys/VirtConvert/Converter/RedHat.pm line 698.
Couldn't guess kernel version number from path for kernel /boot/xen.gz-2.6.18-305.el5 at /usr/share/perl5/vendor_perl/Sys/VirtConvert/Converter/RedHat.pm line 698.
Use of uninitialized value $version in concatenation (.) or string at /usr/share/perl5/vendor_perl/Sys/VirtConvert/Converter/RedHat.pm line 837.
virt-v2v: rhel5.8 configured with virtio drivers.

Actual results:
The error messages printed as step2 descripted.

Expected results:
There should no error messages.
 
Additional info:

Comment 2 RHEL Program Management 2012-05-03 04:37:15 UTC
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 3 Richard W.M. Jones 2014-11-18 11:27:33 UTC
Virt-v2v needs to run on the latest Red Hat Enterprise Linux release
to ensure it can correctly read and modify new guest filesystem
features.  A new version of virt-v2v is now available for RHEL 7.1.

Before RHEL 7.1 is released, follow the instructions here to
install unsupported preview packages on top of RHEL 7.0:
https://www.redhat.com/archives/libguestfs/2014-May/msg00090.html

After RHEL 7.1 is released, virt-v2v will be available in
Technical Preview.

You can run virt-v2v in a single virtual machine.  Other
requirements are covered here:
http://libguestfs.org/virt-v2v.1.html#resource-requirements

If you find a missing feature or bug in the new version of virt-v2v
please file a bug using the following link:
https://bugzilla.redhat.com/enter_bug.cgi?product=Red%20Hat%20Enterprise%20Linux%207&component=libguestfs


Note You need to log in before you can comment on or make changes to this bug.