Bug 808889 - named disabled after yum update from F16 to F17
named disabled after yum update from F16 to F17
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-01 10:41 EDT by Jonathan Kamens
Modified: 2013-04-30 19:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-19 09:08:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2012-04-01 10:41:13 EDT
The named service, which was enabled prior to the upgrade, was disabled after upgrading from F16 to F17 as per https://fedoraproject.org/wiki/Upgrading_Fedora_using_yum.

I suspect this is because it was converted from initscripts to systemd.

The instructions at the URL referenced above say to check which services are enabled before upgrading to F16 and re-enable them afterward, but it doesn't say the same thing about upgrading to F17.

If there are services being converted from initscripts to systemd in F17, then either (a) they need to automatically save and restore their status during the upgrade, or (b) the instructions at the URL mentioned above need to explain how to preserve the status of those services when upgrading.
Comment 1 Adam Tkac 2012-04-19 09:08:41 EDT
Per http://lists.fedoraproject.org/pipermail/devel/2012-April/165917.html this kind of changes isn't documented, closing.

If you disagree and think that this should be documented somewhere, please reopen this bug.

Note You need to log in before you can comment on or make changes to this bug.