Bug 808917 - webkitgtk-devel and webkitgtk3-devel have a file conflict in f17 and f18
webkitgtk-devel and webkitgtk3-devel have a file conflict in f17 and f18
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: webkitgtk (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-01 13:42 EDT by Bruno Wolff III
Modified: 2012-04-14 00:32 EDT (History)
6 users (show)

See Also:
Fixed In Version: webkitgtk-1.8.0-2.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-14 00:32:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2012-04-01 13:42:15 EDT
Description of problem:
Transaction Check Error:
  file /usr/share/gtk-doc/html/webkitgtk/WebKitFaviconDatabase.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/WebKitGeolocationPolicyDecision.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/WebKitHitTestResult.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/WebKitIconDatabase.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/WebKitNetworkRequest.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/WebKitNetworkResponse.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/WebKitSecurityOrigin.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/WebKitSoupAuthDialog.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/WebKitSpellChecker.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/WebKitViewportAttributes.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/WebKitWebBackForwardList.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/WebKitWebDataSource.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/WebKitWebDatabase.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/WebKitWebFrame.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/WebKitWebHistoryItem.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/WebKitWebInspector.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/WebKitWebNavigationAction.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/WebKitWebPlugin.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/WebKitWebPluginDatabase.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/WebKitWebPolicyDecision.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/WebKitWebResource.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/WebKitWebSettings.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/WebKitWebWindowFeatures.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/annotation-glossary.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/ch01.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/ch02.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/ch03.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/index-1.0.1.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/index-1.0.2.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/index-1.0.3.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/index-1.1.1.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/index-1.1.10.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/index-1.1.11.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/index-1.1.13.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/index-1.1.14.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/index-1.1.15.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/index-1.1.16.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/index-1.1.17.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/index-1.1.18.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/index-1.1.2.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/index-1.1.20.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/index-1.1.23.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/index-1.1.3.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/index-1.1.4.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/index-1.1.5.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/index-1.1.6.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/index-1.1.7.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/index-1.1.8.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/index-1.3.1.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/index-1.3.2.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/index-1.3.3.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/index-1.3.4.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/index-1.3.8.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/index-all.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/index-deprecated.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/index.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/webkit-environment.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/webkitgtk-Global-functions.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/webkitgtk-webkitdownload.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/webkitgtk-webkitwebview.html from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
  file /usr/share/gtk-doc/html/webkitgtk/webkitgtk.devhelp2 from install of webkitgtk-devel-1.8.0-1.fc18.i686 conflicts with file from package webkitgtk3-devel-1.8.0-1.fc18.i686
Comment 1 Kevin Fenzi 2012-04-01 13:53:32 EDT
Adding webkitgtk3 maintainer. 

I think it would make more sense for webkitgtk3 to move to /usr/share/gtk-doc/html/webkitgtk3/ 
but open to other ideas for fixing it.
Comment 2 Kalev Lember 2012-04-09 06:08:50 EDT
Summary
=======
This is going to be a long rant, but the short story is that we can fix this for webkitgtk 1.8.x in Fedora 17 without renaming the documentation, but for later releases it would be best to contact upstream about the conflict. Could someone open a ticket at https://bugs.webkit.org/ ?


Same Tarball, Two Builds
========================
Upstream is shipping only one tarball with both gtk2 and gtk3 support. The gtk-doc documentation that is installed for the gtk2 and gtk3 builds is supposed to be identical and is built from the same source. Because of this, I would assume that upstream has little interest in duplicating the identical documentation between two directories, as long as both gtk2 and gtk3 builds continue to be supported. However, I guess it would be best to open a ticket with webkit bugzilla and ask upstream. At some point they are going to remove gtk2 support and the docs will start diverging.


Why do the docs from the same tarball differ?
=============================================
If gtk2 and gtk3 docs aren't supposed to differ, why is RPM reporting conflicts in the files?

The reason is that webkitgtk3 passes --enable-gtk-doc to configure, which causes the docs to be rebuilt. Without this option, 'make install' would just install prebuilt documentation that is shipped in the upstream tarball, but with it, the docs are rebuilt and differ from the ones in upstream tarball.

An easy way to fix the file conflict would be removing --enable-gtk-doc from webkitgtk3 build, but that would only help as long as both webkitgtk and webkitgtk3 are built from the same source tarball -- likely to be true for stable Fedora releases, but not for rawhide. Once the files are identical for the two builds, RPM can handle sharing identical files between two packages just fine.

https://fedoraproject.org/wiki/Packaging:Guidelines#File_and_Directory_Ownership


Split out -doc subpackage
=========================
Another thing we could do to paper over this issue is split out a -doc subpackage from both webkitgtk and webkitgtk3. The change would be useful on its own and would also prevent from the -devel subpackages from conflicting.

http://pkgs.fedoraproject.org/gitweb/?p=webkitgtk3.git;a=commit;h=687ce397 already added most of the changes for building a -doc subpackage, but missed a needed change to %files, so the subpackage isn't actually being built. But that would be easy to fix up.


The solution for Fedora 17
==========================
I would stop with the changes here and contact upstream to see if they could solve the issue of identical files in webkitgtk-1.9 timeframe. What we have at this point should be enough for webkitgtk 1.8.x that is in Fedora 17: -devel packages won't conflict because there are no docs in them, and -doc packages won't conflict either because they'd have identical files and RPM can handle this fine.


More ideas
==========
Other hacks we _could_ do, but I wouldn't before contacting upstream:

 - remove webkitgtk documentation and only keep webkitgtk3-doc
 - do a downstream patch to move the gtk3 docs to /usr/share/gtk-doc/html/webkitgtk3/ (as suggested by Kevin Fenzi)
 - do a downstream patch to move the gtk2 docs to /usr/share/gtk-doc/html/webkitgtk2/
Comment 3 Fedora Update System 2012-04-09 13:35:44 EDT
webkitgtk-1.8.0-2.fc17,webkitgtk3-1.8.0-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/webkitgtk-1.8.0-2.fc17,webkitgtk3-1.8.0-2.fc17
Comment 4 Fedora Update System 2012-04-10 16:16:46 EDT
Package webkitgtk-1.8.0-2.fc17, webkitgtk3-1.8.0-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing webkitgtk-1.8.0-2.fc17 webkitgtk3-1.8.0-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-5579/webkitgtk-1.8.0-2.fc17,webkitgtk3-1.8.0-2.fc17
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-04-14 00:32:20 EDT
webkitgtk-1.8.0-2.fc17, webkitgtk3-1.8.0-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.