Bug 808932 - SELinux is preventing /usr/bin/evince from 'create' accesses on the file Comprobantes federal Beba.pdf.
SELinux is preventing /usr/bin/evince from 'create' accesses on the file Comp...
Status: CLOSED DUPLICATE of bug 808779
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:3abd07c0bf4ac8f41f2a2acb54b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-01 16:29 EDT by Boricua
Modified: 2012-04-02 06:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-02 06:41:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Boricua 2012-04-01 16:29:53 EDT
libreport version: 2.0.10
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.0-8.fc17.x86_64
time:           Sun 01 Apr 2012 04:29:12 PM AST

description:
:SELinux is preventing /usr/bin/evince from 'create' accesses on the file Comprobantes federal Beba.pdf.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that evince should be allowed create access on the Comprobantes federal Beba.pdf file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep evince /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
:                              0.c1023
:Target Context                unconfined_u:object_r:user_home_dir_t:s0
:Target Objects                Comprobantes federal Beba.pdf [ file ]
:Source                        evince
:Source Path                   /usr/bin/evince
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           evince-3.4.0-1.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-106.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.0-8.fc17.x86_64 #1 SMP Thu Mar 29
:                              18:18:26 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Sun 01 Apr 2012 04:27:42 PM AST
:Last Seen                     Sun 01 Apr 2012 04:27:42 PM AST
:Local ID                      b35646ce-88e0-4100-a0d6-9f8aa82b782d
:
:Raw Audit Messages
:type=AVC msg=audit(1333312062.110:412): avc:  denied  { create } for  pid=8515 comm="evince" name=436F6D70726F62616E746573206665646572616C20426562612E706466 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_dir_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1333312062.110:412): arch=x86_64 syscall=open success=no exit=EACCES a0=22b2cc0 a1=c1 a2=1b6 a3=aaaaaaaaaaaaaaab items=0 ppid=1 pid=8515 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=2 comm=evince exe=/usr/bin/evince subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)
:
:Hash: evince,mozilla_plugin_t,user_home_dir_t,file,create
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Miroslav Grepl 2012-04-02 06:41:34 EDT

*** This bug has been marked as a duplicate of bug 808779 ***

Note You need to log in before you can comment on or make changes to this bug.