Bug 80898 - can't install grub on boot disk hdc
can't install grub on boot disk hdc
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
phoebe
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks: 79579
  Show dependency treegraph
 
Reported: 2003-01-01 16:52 EST by Alexandre Oliva
Modified: 2007-04-18 12:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-17 12:03:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2003-01-01 16:52:06 EST
Even if I choose advanced boot loader options and tell the installer that hdc
comes before hda in the boot sequence, it doesn't offer me an option to install
the boot sector on /dec/hdc (only /dev/hda).  Even though I thought it might end
up installing the boot sector on /dev/hdc anyway, it did not, so I ended up with
a system that couldn't be booted, and /etc/grub/devices.map had (hd0) for hda
and (hd1) for hdc, which is exactly the converse of what I specified in the
configuration screen, and grub.conf was full of references to hd1 for partitions
that should be in hd0.

If I change the boot order, this should be relected in devices.map, grub.conf
and also in the options offered for where to install the boot sector.
Comment 1 Jeremy Katz 2003-02-06 19:10:30 EST
This works for me here.  I go to advanced boot loader options and move hdb up by
clicking the up arrow and things change to reflect that.  
Comment 3 Alexandre Oliva 2003-02-17 12:03:58 EST
I must have done something stupid such as selecting the disk but not moving it
up.  It does work, indeed.

Note You need to log in before you can comment on or make changes to this bug.