Bug 809000 - Removing the "screen name" field from a address book does not really remove it
Removing the "screen name" field from a address book does not really remove it
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Horak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-02 04:03 EDT by Joachim Backes
Modified: 2012-08-15 10:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-15 09:02:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
demonstration (797.39 KB, application/octet-stream)
2012-04-03 03:03 EDT, Jan Horak
no flags Details

  None (edit)
Description Joachim Backes 2012-04-02 04:03:51 EDT
Description of problem:

Having some address bokk antries in thunderbird with a screen name field. If I remove such a screen name, pressing then OK does not close this dialog window, and I have additionally to press CANCEL. After stopping thunderbird and starting again, I still see these removed screen name enttries.

Version-Release number of selected component (if applicable):
thunderbird-11.0.1-1.fc17.x86_64

How reproducible:
Alwyas

Steps to Reproduce:
1.See description
2.
3.
  
Actual results:
See description

Expected results:
Screen names remain removed.

Additional info:

1. There is the same behaviour if I start thunderbird with the -save-mode option
2. I checked this in Ubuntu 10.04.4 LTS, but there the entries remain removed as
   expected.
Comment 1 Jan Horak 2012-04-03 03:03:41 EDT
Created attachment 574748 [details]
demonstration

I'm not sure if I get it right. See attached video for demonstration. This doesn't work for you? What kind of address book do you use (local, ldap)?
Comment 2 Joachim Backes 2012-04-08 04:14:37 EDT
Local and ldap. The problem appears with the local address book!
Comment 3 Jan Horak 2012-05-03 10:05:34 EDT
Run thunderbird by:
thunderbird -jsconsole
This opens debugging javascript console. See if there show up any errors or warnings in console while clicking on OK button.
Comment 4 Joachim Backes 2012-05-03 10:37:16 EDT
Nothing appears in the jconsole if I press OK or cancel after having removed the screen name for some entry in the local address book.
Comment 5 Jan Horak 2012-08-15 05:41:48 EDT
Do you still see this issue? If you do try test with fresh profile. I'm unable to reproduce it.
Comment 6 Joachim Backes 2012-08-15 05:58:22 EDT
(In reply to comment #5)
> Do you still see this issue? If you do try test with fresh profile. I'm
> unable to reproduce it.

If I try a new fresh profile, I cannot reproduce the reported issue too.
Comment 7 Jan Horak 2012-08-15 09:02:19 EDT
Looks like some mess in profile, closing as WFM.
Comment 8 Joachim Backes 2012-08-15 10:38:22 EDT
I could solve my issues in a more simple way: export the concerned address book and import it's contents to another one. There I could remove the "Screen name" entries without problems.

Note You need to log in before you can comment on or make changes to this bug.