Bug 809015 - SELinux is preventing /usr/sbin/xl2tpd from 'name_bind' accesses on the udp_socket port 1701.
SELinux is preventing /usr/sbin/xl2tpd from 'name_bind' accesses on the udp_s...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:1c426d69418fc3e2f39ed889f61...
: Reopened
: 809020 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-02 04:54 EDT by ManFree
Modified: 2012-05-18 06:27 EDT (History)
3 users (show)

See Also:
Fixed In Version: selinux-policy-3.10.0-86.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-25 11:20:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ManFree 2012-04-02 04:54:37 EDT
libreport version: 2.0.6
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.1.0-7.fc16.i686
reason:         SELinux is preventing /usr/sbin/xl2tpd from 'name_bind' accesses on the udp_socket port 1701.
time:           Mon Apr  2 16:54:25 2012

description:
:SELinux is preventing /usr/sbin/xl2tpd from 'name_bind' accesses on the udp_socket port 1701.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that xl2tpd should be allowed name_bind access on the port 1701 udp_socket by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep xl2tpd /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:l2tpd_t:s0
:Target Context                system_u:object_r:unreserved_port_t:s0
:Target Objects                port 1701 [ udp_socket ]
:Source                        xl2tpd
:Source Path                   /usr/sbin/xl2tpd
:Port                          1701
:Host                          (removed)
:Source RPM Packages           xl2tpd-1.3.0-1.fc16.R
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-46.fc16
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux localhost.localdomain 3.1.0-7.fc16.i686 #1
:                              SMP Tue Nov 1 21:00:16 UTC 2011 i686 i686
:Alert Count                   2
:First Seen                    Пн. 02 апр. 2012 16:50:34
:Last Seen                     Пн. 02 апр. 2012 16:50:45
:Local ID                      9c9de3ab-423f-482f-8d74-43a05914a2dd
:
:Raw Audit Messages
:type=AVC msg=audit(1333371045.95:88): avc:  denied  { name_bind } for  pid=3066 comm="xl2tpd" src=1701 scontext=system_u:system_r:l2tpd_t:s0 tcontext=system_u:object_r:unreserved_port_t:s0 tclass=udp_socket
:
:
:type=SYSCALL msg=audit(1333371045.95:88): arch=i386 syscall=socketcall success=no exit=EACCES a0=2 a1=bfb75ee0 a2=4d2aaff4 a3=0 items=0 ppid=3065 pid=3066 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=xl2tpd exe=/usr/sbin/xl2tpd subj=system_u:system_r:l2tpd_t:s0 key=(null)
:
:Hash: xl2tpd,l2tpd_t,unreserved_port_t,udp_socket,name_bind
:
:audit2allow
:
:#============= l2tpd_t ==============
:allow l2tpd_t unreserved_port_t:udp_socket name_bind;
:
:audit2allow -R
:
:#============= l2tpd_t ==============
:allow l2tpd_t unreserved_port_t:udp_socket name_bind;
:
Comment 1 Miroslav Grepl 2012-04-02 07:39:34 EDT
*** Bug 809020 has been marked as a duplicate of this bug. ***
Comment 2 Miroslav Grepl 2012-04-02 08:43:55 EDT
l2tp            1701/tcp        l2f
l2tp            1701/udp        l2f

I am adding these ports. We have this in F17.
Comment 3 Fedora Update System 2012-04-18 08:55:52 EDT
selinux-policy-3.10.0-84.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/selinux-policy-3.10.0-84.fc16
Comment 4 Fedora Update System 2012-04-21 23:38:14 EDT
selinux-policy-3.10.0-84.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 ManFree 2012-04-22 14:37:59 EDT
xl2tpd don't work - bug https://bugzilla.redhat.com/show_bug.cgi?id=815131
Comment 6 Miroslav Grepl 2012-04-22 15:49:41 EDT
Fixed in selinux-policy-3.10.0-86.fc16
Comment 7 ManFree 2012-04-23 02:11:57 EDT
Where is testing repository?
Comment 8 Miroslav Grepl 2012-04-23 08:54:16 EDT
I will build it today. -85.fc16 is now going to be in testing repo.
Comment 9 ManFree 2012-04-23 09:01:01 EDT
I don't know where is your testing repo.
There is nothing: ftp://ftp.yandex.ru/fedora/linux/updates/testing/
Comment 10 Miroslav Grepl 2012-04-23 09:07:18 EDT
I apologize, I was wrong. This is F16 not F17.

I am going to submit a new update which will contain -86.fc16 release today.
Comment 11 Fedora Update System 2012-04-24 07:50:33 EDT
selinux-policy-3.10.0-86.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/selinux-policy-3.10.0-86.fc16
Comment 12 ManFree 2012-04-25 11:20:24 EDT
No problem in selinux-policy-3.10.0-87.fc16.
Fixed.
Comment 13 Fedora Update System 2012-05-18 06:27:18 EDT
selinux-policy-3.10.0-86.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.