Bug 809026 - v7 trivial formatting fix
v7 trivial formatting fix
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
1.5
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Greg Nichols
Petr Beňas
:
Depends On:
Blocks: 767775
  Show dependency treegraph
 
Reported: 2012-04-02 05:35 EDT by Petr Beňas
Modified: 2015-01-04 18:02 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
no tech note needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-05 17:37:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Beňas 2012-04-02 05:35:06 EDT
Description of problem:
Please enter one of the following: newexistingnone

Version-Release number of selected component (if applicable):
v7-1.5-13.el5

How reproducible:
100% 

Steps to Reproduce:
v7 plan
  
Actual results:
found interface for udisks
Introspect error: The name org.freedesktop.UDisks was not provided by any .service files
Could not get devices from UDisks:
The name org.freedesktop.UDisks was not provided by any .service files
Please verify the vendor, make, and model:
Vendor: Lenovo
Make: 401118U
Model: 401118U
Hardware: Lenovo 401118U 401118U
OS: Tikanga 5.8
What certification is this system being tested for? (new|existing|none) 
Please enter one of the following: newexistingnone                            <= doesn't look pretty
What certification is this system being tested for? (new|existing|none) none

Expected results:
What certification is this system being tested for? (new|existing|none) 
Please enter one of the following: new | existing | none

Additional info:
Proposed patch:
--- /usr/share/v7/lib/v7/catalog.py     2012-04-02 05:29:57.000000000 -0400
+++ /usr/share/v7/lib/v7/catalog.py_old 2012-04-02 05:20:26.000000000 -0400
@@ -67,7 +67,7 @@
                     pass
                     
                 if answer not in answers:
-                    print "Please enter one of the following: %s" % " | ".join(answers)
+                    print "Please enter one of the following: %s" % "".join(answers)
                 else:
                     break
Comment 5 Petr Beňas 2012-05-02 02:42:44 EDT
Reproduced in v7-1.5-20.el6.noarch and verified in v7-1.5-21.el6.noarch.
Comment 6 Caspar Zhang 2012-06-04 04:00:17 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
no tech note needed.
Comment 8 errata-xmlrpc 2012-06-05 17:37:23 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0711.html

Note You need to log in before you can comment on or make changes to this bug.