Bug 809028 - alternatives symlinks are not updated when going from f16 to f17
alternatives symlinks are not updated when going from f16 to f17
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: vala (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-02 05:39 EDT by Christophe Fergeau
Modified: 2012-04-21 23:45 EDT (History)
1 user (show)

See Also:
Fixed In Version: vala-0.14.2-3.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-14 00:37:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christophe Fergeau 2012-04-02 05:39:50 EDT
I upgraded from f16 to f17 last week, and realized today that valac couldn't be found by the various source tarballs I'm trying to compile. After a bit of investigation, I found that the various vala symlinks in /etc/alternatives/ were still pointing to vala-0.14, which has been replaced by vala-0.16 during the upgrades, leading to broken symlinks.
Comment 1 Michel Alexandre Salim 2012-04-05 13:48:43 EDT
Ah, yes, the alternatives scriptlets are buggy. I'm testing an update now.
Comment 2 Fedora Update System 2012-04-05 22:02:44 EDT
vala-0.16.0-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/FEDORA-2012-5390/vala-0.16.0-2.fc17
Comment 3 Fedora Update System 2012-04-05 22:05:14 EDT
vala-0.14.2-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/vala-0.14.2-2.fc16
Comment 4 Michel Alexandre Salim 2012-04-05 22:13:44 EDT
The updated Vala packages have fixed handling of alternatives; people who have 0.14.2-2.fc16 installed before dist-upgrading to fc17 should be fine.

Also, I've introduced a workaround that clean up broken symlinks, but for simplicity it'll only clean up one API level (e.g. 0.14 -> 0.16). Since we have not introduced alternatives prior to Fedora 16 (Vala 0.14) that should suffice (I've tested going from 0.14.2-1.fc16 to 0.16.0-2 as well as to 0.16.0-1 -- without the workaround -- and then to -2)
Comment 5 Fedora Update System 2012-04-06 19:23:27 EDT
Package vala-0.16.0-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing vala-0.16.0-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-5390/vala-0.16.0-2.fc17
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-04-14 00:37:03 EDT
vala-0.16.0-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2012-04-21 23:45:23 EDT
vala-0.14.2-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.