Bug 809047 - Unable to push Images On my Amazon -ec2 account
Unable to push Images On my Amazon -ec2 account
Status: CLOSED WORKSFORME
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: imagefactory (Show other bugs)
1.0.0
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: jrd
Martin Kočí
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-02 06:44 EDT by pushpesh sharma
Modified: 2014-08-04 18:30 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-02 07:25:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description pushpesh sharma 2012-04-02 06:44:14 EDT
Description of problem:


Version-Release number of selected component (if applicable):

[root@ibm-hs22-03 ~]# rpm -qa|grep aeolus
aeolus-conductor-doc-0.8.7-1.el6.noarch
aeolus-all-0.8.7-1.el6.noarch
rubygem-aeolus-cli-0.3.1-1.el6.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-0.8.7-1.el6.noarch
aeolus-configure-2.5.2-1.el6.noarch
aeolus-conductor-daemons-0.8.7-1.el6.noarch


How reproducible:
From CLI

1.
[root@ibm-hs22-03 ~]# aeolus-image build --target ec2 --template /opt/fedora15_temp.xml -E My_Cloud
Image                                    Build                                    Target Image                             Target     Status       
------------------------------------     ------------------------------------     ------------------------------------     ------     --------     
b184845c-7cac-11e1-8e1e-001a64ae4282     0ffd5714-2574-4c4e-8cf9-6314a5f1493d     f3a1a1db-ba84-4ede-ab2b-61c36964d73d     ec2        BUILDING     

2. 
[root@ibm-hs22-03 ~]# aeolus-image push -A psharma@redhat.com -t f3a1a1db-ba84-4ede-ab2b-61c36964d73d

ERROR:  Service Temporarily Unavailable => Please check that Conductor is running.

Steps to Reproduce:(From Web UI)

1.Created a image by uploading a TDL(well tested with the previous build) 
2.Build the image for amazon account
3.Push The image from UI.

  
Actual results:
Error Msg:- Unable to Upload Provider Image

Expected results:
Imahe should be pushed correctly 

Additional info:

Steps for pushing the images are same as mentioned in the User Guide
Comment 1 pushpesh sharma 2012-04-02 06:46:18 EDT
Image Factory Relevant logs:-

2012-04-02 06:39:45,431 DEBUG imgfac.BuildDispatcher.BuildDispatcher thread(worker 5) Message: Testing provider for XML: syntax error: line 1, column 0
2012-04-02 06:39:45,432 DEBUG imgfac.BuildDispatcher.BuildDispatcher thread(worker 5) Message: Testing provider for JSON: No JSON object could be decoded
2012-04-02 06:39:45,432 WARNING imgfac.BuildDispatcher.BuildDispatcher thread(worker 5) Message: No matching provider found for ec2, using "condorcloud" by default.
2012-04-02 06:39:45,432 DEBUG imgfac.ImageWarehouse.ImageWarehouse thread(worker 5) Message: Querying (http://localhost:9090/target_images/_query) with expression ($build == "0ffd5714-2574-4c4e-8cf9-6314a5f1493d" && $target == "condorcloud")
2012-04-02 06:39:45,439 DEBUG imgfac.ImageWarehouse.ImageWarehouse thread(worker 5) Message: Image Warehouse returned status (404) with message: 
2012-04-02 06:39:45,439 DEBUG imgfac.ImageWarehouse.ImageWarehouse thread(worker 5) Message: Getting metadata (['template']) from http://localhost:9090/target_images/None
2012-04-02 06:39:45,441 DEBUG imgfac.ImageWarehouse.ImageWarehouse thread(worker 5) Message: Image Warehouse returned status (404) with message: 
2012-04-02 06:39:45,442 DEBUG imgfac.ImageWarehouse.ImageWarehouse thread(worker 5) Message: Created Image Warehouse instance http://localhost:9090 - buckets(target_images, templates, icicles, provider_images)
2012-04-02 06:39:45,442 ERROR imgfac.rest.imagefactory thread(worker 5) Message: 'template' must be a UUID, URL, XML string or XML document path...
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/imgfac/rest/imagefactory.py", line 191, in push_image
    job = BuildDispatcher().push_image_to_providers(image_id, build_id, (provider, ), credentials)[0]
  File "/usr/lib/python2.6/site-packages/imgfac/BuildDispatcher.py", line 83, in push_image_to_providers
    job = job_cls(template, target, image_id, build_id, *args, **kwargs)
  File "/usr/lib/python2.6/site-packages/imgfac/BuildJob.py", line 49, in __init__
    self.template = template if isinstance(template, Template) else Template(template)
  File "/usr/lib/python2.6/site-packages/imgfac/Template.py", line 79, in __init__
    raise ValueError("'template' must be a UUID, URL, XML string or XML document path...")
ValueError: 'template' must be a UUID, URL, XML string or XML document path...
2012-04-02 06:39:45,442 ERROR imgfac.rest.imagefactory thread(worker 5) Message: HTTP Response 500
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/imgfac/rest/imagefactory.py", line 212, in create_provider_image
    return push_image(image_id, build_id, target_image_id)
  File "/usr/lib/python2.6/site-packages/imgfac/rest/imagefactory.py", line 60, in decorated_function
    return f(*args, **kwargs)
  File "/usr/lib/python2.6/site-packages/imgfac/rest/imagefactory.py", line 202, in push_image
    raise HTTPResponse(status=500, output=e)
HTTPResponse: HTTP Response 500
2012-04-02 06:39:46,319 DEBUG paste.httpserver.ThreadPool thread(MainThread) Message: Added task (0 tasks queued)
Comment 2 Shveta 2012-04-02 07:25:58 EDT
rpm -qa|grep aeolus
aeolus-conductor-doc-0.8.7-1.el6.noarch
aeolus-conductor-0.8.7-1.el6.noarch
rubygem-aeolus-cli-0.3.1-1.el6.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-daemons-0.8.7-1.el6.noarch
aeolus-configure-2.5.2-1.el6.noarch
aeolus-all-0.8.7-1.el6.noarch


Works for me

Note You need to log in before you can comment on or make changes to this bug.