Bug 809082 - RFE: beaker allow to use cc list of users. It should be nice to see the these jobs in mine jobs
RFE: beaker allow to use cc list of users. It should be nice to see the these...
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: web UI (Show other bugs)
0.6
Unspecified Unspecified
unspecified Severity high (vote)
: ---
: ---
Assigned To: beaker-dev-list
tools-bugs
GroupModel
: FutureFeature, Reopened, TestBlocker
Depends On:
Blocks: 593663 798713
  Show dependency treegraph
 
Reported: 2012-04-02 08:45 EDT by Jan Ščotka
Modified: 2013-09-23 23:08 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 23:08:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Ščotka 2012-04-02 08:45:36 EDT
Description of problem:
Hi,
problem is that beaker allow us to add email adresses to cc
$ bkr workflow-simple --help |grep cc
  --cc=CC                                    Specify additional email addresses to notify

what is very useful, when you schedule some job for another user.
It is possible to see these jobs where  I'm cc'ed at page:
https://beaker.engineering.redhat.com/jobs/mine

I think that it is senseful, and propably very useful feature to see the CCed jobs.
Now propably it works, that it sends email, after job end,
but it is unable to see job state (for example if it end in short time until you know job ID)

So my question is, it is possible to add cced job ids into mine jobs?
or to do it somehow searchable to be able see these jobs (second option is to be able search via CC option 
for example add option cc for search query
https://beaker.engineering.redhat.com/jobs/?jobsearch-0.table=Cc&jobsearch-0.operation=contains&jobsearch-0.value=jscotka&Search=Search

   Thanks&Regards
   Honza
Comment 1 Ales Zelinka 2012-04-02 08:53:37 EDT
Having all the jobs I'm CCed to on my "My Jobs" list would be very nice feature. 

use-case: automation scripts that schedules various jobs on behalf of other people, currently owners of these jobs are not aware of them because they don't appear on their "My jobs" pages.
Comment 2 Zbysek MRAZ 2012-04-16 07:16:51 EDT
Hello, any updated on this one?
Comment 3 Jan Ščotka 2012-04-16 07:23:32 EDT
There should be also feature, that when I'm CCed, it means I able to work with job (cancel, ACK/NACK recipes)

I can fill another bug for the second request (but implementation seems to be very close, same as previous request)
   Thanks
   Honza

The bug is need to deal with automated job scheduling for various people.
Comment 4 Raymond Mancy 2012-04-16 20:21:45 EDT
I am loathe to use the the CC list for anything other than emailing people, certainly not as a conduit for permissions.
Comment 5 Raymond Mancy 2012-04-16 20:28:25 EDT
As for showing jobs you are CC'ed on within a single page, this seems like a good idea.

Perhaps on the 'My Jobs' page, but with a toggle that can hide/show the CC'ed jobs.
Comment 6 Dan Callaghan 2012-04-17 00:54:08 EDT
I would note that the job cc list contains only e-mail addresses, not Beaker users, specifically so that non-user e-mail addresses can be cc'ed (mailing lists etc).

Maybe a better way to address people's needs here would be some combination of:

* proxy authentication, so that a service can submit jobs on behalf of users (and the user becomes the actual owner of the job)

* some way to list the jobs submitted by a specific user, e.g. /jobs/<username> (bug 694061)
Comment 7 Jan Ščotka 2012-04-17 03:19:05 EDT
But I thing that solution with CC means also permission (no matter that there are mailing lists or another users, because havent login abilities to beaker) seems to me easy to implement and also give you nice features.

Another option is to add new field of users/ groups what are allowed to deal with job. It is nice and universal solution, but need propably bigger changes in beaker.
(vice versa CC-list as permisson list is straightforward and propably it is only one added line which check if I'm able to deal with job.

At least mentioned filtering or show CCed jobs in mine (hideable) is also enought

   Thanks
   Honza
Comment 8 Bill Peck 2012-04-17 08:56:51 EDT
I suppose we could attempt to look up the user via the email address,  If we can look them up then add them to a user_cc list otherwise add them to email_cc list.

But we would not bring in ACL's until the group re-work has been done.
Comment 9 Nick Coghlan 2013-02-06 01:49:56 EST
We will not be implementing this concept in this form. Instead, Beaker 1.0 will allow jobs to be submitted explicitly on behalf of a group, in which case all members of that group will see those jobs appear in their "My Jobs" list (see BZ#908185). Filtering options will be available to exclude group jobs from the list when so desired.
Comment 10 Ales Zelinka 2013-02-06 14:59:52 EST
Please see my use-case in comment#1 - to make it work using the group model I'd have to create 40 groups for 40 people (each including 1 QE person and the automation user). I'd also have to create and maintain a service that would create/delete groups based on orgchart changes. That's plain ugly, please don't make me do it :)
Comment 13 Nick Coghlan 2013-09-23 23:08:22 EDT
The combination of group jobs (with all members of a group seeing shared jobs in their My Group Jobs page) and submission delegates (with users seeing jobs submitted on their behalf in their My Jobs page) should cover the different use cases discussed in this RFE.

Any requests for further refinements to those features can be filed as new BZ entries :)

Note You need to log in before you can comment on or make changes to this bug.