Bug 809110 - ConcurrentModificationException in BasicConnectionTable.retainAll
ConcurrentModificationException in BasicConnectionTable.retainAll
Status: CLOSED DUPLICATE of bug 808127
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: EAP (Show other bugs)
5.3.0 GA
Unspecified Unspecified
unspecified Severity urgent
: ER1
: ---
Assigned To: Default User
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-02 10:04 EDT by Julian Coleman
Modified: 2012-05-09 14:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 809112 (view as bug list)
Environment:
Last Closed: 2012-04-05 09:30:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Julian Coleman 2012-04-02 10:04:14 EDT
JBPAPP-7722

A race condition in JGroups can cause a ConcurrentModificationException in org.jgroups.blocks.BasicConnectionTable#retainAll, which skips notifying any view listeners of a new cluster view.
Comment 1 Julian Coleman 2012-04-05 09:30:31 EDT

*** This bug has been marked as a duplicate of bug 808127 ***

Note You need to log in before you can comment on or make changes to this bug.