Bug 809130 - VM fails to run in RHEVM Power User Portal due to I/O error in libvirt
VM fails to run in RHEVM Power User Portal due to I/O error in libvirt
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.3
Unspecified Linux
unspecified Severity urgent
: rc
: ---
Assigned To: Martin Kletzander
Virtualization Bugs
: Regression
Depends On: 806377
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-02 10:43 EDT by Pavel Novotny
Modified: 2012-04-05 05:02 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 806377
Environment:
Last Closed: 2012-04-05 05:02:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Novotny 2012-04-02 10:43:39 EDT
+++ This bug was initially created as a clone of Bug #806377 +++

Created attachment 572302 [details]
libvirt I/O error

Description of problem:
When trying to run VM via Red Hat Enterprise Virtualization Manager (RHEVM) - Power User Portal, the VM fails to start due to an I/O error in libvirt, which cannot access VM disk image header, stored on NFS data storage.

Version-Release number of selected component (if applicable):
libvirt-0.9.10-5.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. In RHEVM, create a Desktop or Server VM (use 'Blank' template) on NFS data storage.
2. Add an empty disk to it (sub-tab Virtual Disks -> New). Use Disk type = System, Interface = VirtIO.
3. Wait until the disk is initialized and run VM.
  
Actual results:
In RHEVM, VM state changes from "Down" -> "Waiting to Launch" and after few seconds back to "Down". 
On host machine - libvirt returns "Input/output error", see Additional info, full log is in attachment.

Expected results:
VM should start properly.


Additional info:

/var/log/libvirt/libvirtd.log:
==============================
2012-03-19 15:24:40.244+0000: 17151: error : virNetClientProgramDispatchError:174 : cannot read header '/rhev/data-center/afdbdbce-74ae-40ee-bb1d-fd0721ecd502/f5353edf-097d-4400-bfdf-ffb853b0be5f/images/3df29012-8cac-4b3e-83c3-935042e699e9/304af6dd-959d-404a-8dd2-2b7f5904f1b3': Input/output error
==============================

*Regression* against libvirt-0.9.4-23.el6_2.4.
Comment 3 Martin Kletzander 2012-04-03 09:37:29 EDT
Hello,

it seems that this is not error in libvirt. What libvirtd is trying to do is just read the file specified as a disk source. The NFS storage is most probably managed by VDSM and according to the log, for libvirt it is the same as any other file, so it looks to me like a NFS problem.

Are you able to read from the file on host machine in the middle of the step 3 (after the disk is initialized)?
Comment 4 Pavel Novotny 2012-04-05 04:53:21 EDT
When accessing the file on NFS share manually, I got "Permission denied" error, so the file is really not readable.
After trying to reproduce it, using different NFS storage, the I/O error doesn't appeared in the log, so it seems, that the issue is related to the NFS share itself, maybe by incorrectly set permissions (I don't have access to the original NFS host, so I cannot check it). 

Anyway, after upgrading to libvirt-0.9.10-9.el6.x86_64 (and vdsm from 4.9.6-5 to 4.9.6-6), the problem with running VM has disappeared. Instead, new similar issue with shutting down VM appeared, but I am starting to be convinced, that it is related to vdsm and not to libvirt. 

So from my point of view, we can close this bug as it is no longer valid.
Comment 5 Martin Kletzander 2012-04-05 05:02:22 EDT
As this is not a bug in libvirt and it seems to be resolved now, I'm closing this as NOTABUG as agreed with the reporter.

Note You need to log in before you can comment on or make changes to this bug.