Bug 809137 - [abrt] evolution-3.4.0.1-1.fc17: Process /usr/bin/evolution was killed by signal 11 (SIGSEGV)
[abrt] evolution-3.4.0.1-1.fc17: Process /usr/bin/evolution was killed by sig...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: dconf (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
abrt_hash:e21403ef26c5baae0841c957f6c...
:
: 832001 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-02 11:02 EDT by Peter Robinson
Modified: 2012-06-15 05:43 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-04 12:32:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (34.12 KB, text/plain)
2012-04-02 11:02 EDT, Peter Robinson
no flags Details
File: gconf_subtree (18.33 KB, text/plain)
2012-04-02 11:02 EDT, Peter Robinson
no flags Details
File: maps (68.32 KB, text/plain)
2012-04-02 11:02 EDT, Peter Robinson
no flags Details
File: dso_list (15.99 KB, text/plain)
2012-04-02 11:02 EDT, Peter Robinson
no flags Details
File: build_ids (6.09 KB, text/plain)
2012-04-02 11:02 EDT, Peter Robinson
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 673519 None None None Never

  None (edit)
Description Peter Robinson 2012-04-02 11:02:10 EDT
libreport version: 2.0.10
abrt_version:   2.0.9
backtrace_rating: 4
cmdline:        evolution
comment:        Started evolution 3.4.0 after an upgrade from Fedora 16 / 3.2.x to Fedora 17. Two accounts configured: evw connecting to Exchange and google for calendar (via gnome-online-accounts).
crash_function: g_settings_backend_dispatch_signal
executable:     /usr/bin/evolution
kernel:         3.3.0-8.fc17.x86_64
pid:            1920
pwd:            /home/perobinson
remote_result:  NOTFOUND
time:           Mon 02 Apr 2012 15:40:18 BST
uid:            501
username:       perobinson

backtrace:      Text file, 34941 bytes
build_ids:      Text file, 6232 bytes
dso_list:       Text file, 16372 bytes
gconf_subtree:  Text file, 18772 bytes
maps:           Text file, 69963 bytes

core_backtrace:
:ae74f1bdcd89bba7375a344fac1a8ffb3152a26b 0xa4cba - libgio-2.0.so.0 -
:ae74f1bdcd89bba7375a344fac1a8ffb3152a26b 0xa522d g_settings_backend_path_changed libgio-2.0.so.0 -
:03a3531257193c88ade30f23f9dc93545fa5397d 0x579a - libdconfsettings.so -
:ae74f1bdcd89bba7375a344fac1a8ffb3152a26b 0x6ce17 g_simple_async_result_complete libgio-2.0.so.0 -
:ae74f1bdcd89bba7375a344fac1a8ffb3152a26b 0xbb552 - libgio-2.0.so.0 -
:ae74f1bdcd89bba7375a344fac1a8ffb3152a26b 0x6ce17 g_simple_async_result_complete libgio-2.0.so.0 -
:ae74f1bdcd89bba7375a344fac1a8ffb3152a26b 0x6cf19 - libgio-2.0.so.0 -
:fa109822e1dfe3c97963318f0a110695ed11430d 0x475bc g_main_context_dispatch libglib-2.0.so.0 -
:fa109822e1dfe3c97963318f0a110695ed11430d 0x479d8 - libglib-2.0.so.0 -
:fa109822e1dfe3c97963318f0a110695ed11430d 0x47dd2 g_main_loop_run libglib-2.0.so.0 -
:03a3531257193c88ade30f23f9dc93545fa5397d 0x4b0b - libdconfsettings.so -
:fa109822e1dfe3c97963318f0a110695ed11430d 0x6a315 - libglib-2.0.so.0 -
:9af33edde528c64869abfcce919051d5b15848d9 0x7d14 start_thread libpthread.so.0 -
:14e8f7d39bb684e00c591625ee64905ceb4ab8c9 0xf18fd clone libc.so.6 -

environ:
:GIT_PS1_SHOWDIRTYSTATE=true
:XDG_VTNR=1
:XDG_SESSION_ID=2
:HOSTNAME=neo.roving-it.com
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:SHELL=/bin/bash
:TERM=dumb
:HISTSIZE=1000
:XDG_SESSION_COOKIE=5a3d0f051d91f77357c1162e00000021-1333377544.998650-338717969
:GNOME_KEYRING_CONTROL=/home/perobinson/.cache/keyring-f3SAxk
:IMSETTINGS_MODULE=none
:MAIL=/var/spool/mail/perobinson
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/perobinson/bin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/perobinson
:XMODIFIERS=@im=none
:GNOME_KEYRING_PID=1392
:LANG=en_GB.utf8
:GDM_LANG=en_GB.utf8
:'PS1=[\\[\\e[0;32m\\]\\u\\[\\e[0m\\]@\\[\\e[0;35m\\]\\h\\[\\e[0m\\] \\W\\[\\e[0;33m\\]$(__git_ps1 \" (%s)\")\\[\\e[0m\\]]\\[\\e[0;32m\\]\\$ \\[\\e[0m\\]'
:GIT_PS1_SHOWUNTRACKEDFILES=true
:GDMSESSION=gnome
:SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
:HISTCONTROL=ignoredups
:XDG_SEAT=seat0
:HOME=/home/perobinson
:SHLVL=1
:LOGNAME=perobinson
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-lQdJkUGuuJ,guid=06174726371c5affbe5cf54500000053
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/perobinson
:DISPLAY=:0
:XAUTHORITY=/var/run/gdm/auth-for-perobinson-syT70q/database
:_=/usr/bin/gnome-session
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1401,unix/unix:/tmp/.ICE-unix/1401
:GPG_AGENT_INFO=/home/perobinson/.cache/keyring-f3SAxk/gpg:0:1
:SSH_AUTH_SOCK=/home/perobinson/.cache/keyring-f3SAxk/ssh
:GJS_DEBUG_OUTPUT=stderr
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/evolution.desktop
:GIO_LAUNCHED_DESKTOP_FILE_PID=1920
:DESKTOP_STARTUP_ID=gnome-shell-1640-neo.roving-it.com-evolution-1_TIME148396

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 29855                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       29855                29855                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100000
:1:/home/perobinson/.xsession-errors
:pos:	5378
:flags:	0102002
:2:/home/perobinson/.xsession-errors
:pos:	5378
:flags:	0102002
:3:socket:[28174]
:pos:	0
:flags:	02004002
:4:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:5:socket:[27425]
:pos:	0
:flags:	02004002
:6:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:7:socket:[25583]
:pos:	0
:flags:	02004002
:8:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:9:socket:[25584]
:pos:	0
:flags:	02004002
:10:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:11:/home/perobinson/.pki/nssdb/cert9.db
:pos:	14336
:flags:	02100002
:12:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:13:/var/tmp/etilqs_EbOQPEnfzdJAgo8 (deleted)
:pos:	28
:flags:	02100002
:14:/var/tmp/etilqs_Hqlt2M4rXEfrnnv (deleted)
:pos:	2056
:flags:	02500002
:15:/var/tmp/etilqs_zYa6iVCdeufbnkB (deleted)
:pos:	2048
:flags:	02500002
:16:/home/perobinson/.pki/nssdb/key4.db
:pos:	40
:flags:	02100002
:17:/var/tmp/etilqs_Bcq4M7kv6sCe73k (deleted)
:pos:	28
:flags:	02100002
:18:/var/tmp/etilqs_RKvNc3efsKTC7za (deleted)
:pos:	2056
:flags:	02500002
:19:/var/tmp/etilqs_YtODh82hOPH011D (deleted)
:pos:	2048
:flags:	02500002
:20:/etc/pki/nssdb/cert9.db
:pos:	2048
:flags:	02100000
:21:/var/tmp/etilqs_K9NPYGcvFul6Wfh (deleted)
:pos:	28
:flags:	02100002
:22:/var/tmp/etilqs_YsJkcm7fV9TxlX9 (deleted)
:pos:	2048
:flags:	02500002
:23:/etc/pki/nssdb/key4.db
:pos:	40
:flags:	02100000
:24:/var/tmp/etilqs_KM5WyahgscmniYk (deleted)
:pos:	28
:flags:	02100002
:25:/var/tmp/etilqs_6toyArgqgCf2GyE (deleted)
:pos:	2048
:flags:	02500002
:26:socket:[28188]
:pos:	0
:flags:	02004002
:27:/home/perobinson/.local/share/evolution/mail/local/folders.db
:pos:	40
:flags:	02100002
:28:/home/perobinson/.local/share/evolution/mail/local/.Drafts.ibex.index
:pos:	5120
:flags:	0100002
:29:/home/perobinson/.local/share/evolution/mail/local/.Drafts.ibex.index.data
:pos:	8
:flags:	0102002
:30:/home/perobinson/.local/share/evolution/mail/local/.Outbox.ibex.index
:pos:	5120
:flags:	0100002
:31:/home/perobinson/.local/share/evolution/mail/local/.Outbox.ibex.index.data
:pos:	8
:flags:	0102002
:32:/home/perobinson/.local/share/evolution/mail/local/.Sent.ibex.index
:pos:	5120
:flags:	0100002
:33:/home/perobinson/.local/share/evolution/mail/local/.Sent.ibex.index.data
:pos:	81992
:flags:	0102002
:34:/home/perobinson/.local/share/evolution/mail/local/.Templates.ibex.index
:pos:	5120
:flags:	0100002
:35:/home/perobinson/.local/share/evolution/mail/local/.Templates.ibex.index.data
:pos:	8
:flags:	0102002
:36:/home/perobinson/.local/share/evolution/mail/vfolder/folders.db
:pos:	40
:flags:	02100002

var_log_messages:
:Apr  2 15:13:51 neo kernel: [ 8117.484095] evolution[21609] trap int3 ip:7ff09ada7811 sp:7fff58c3fb50 error:0
:Apr  2 15:40:19 neo abrt[1935]: Saved core dump of pid 1920 (/usr/bin/evolution) to /var/spool/abrt/ccpp-2012-04-02-15:40:18-1920 (36126720 bytes)
Comment 1 Peter Robinson 2012-04-02 11:02:15 EDT
Created attachment 574528 [details]
File: backtrace
Comment 2 Peter Robinson 2012-04-02 11:02:17 EDT
Created attachment 574529 [details]
File: gconf_subtree
Comment 3 Peter Robinson 2012-04-02 11:02:19 EDT
Created attachment 574530 [details]
File: maps
Comment 4 Peter Robinson 2012-04-02 11:02:21 EDT
Created attachment 574531 [details]
File: dso_list
Comment 5 Peter Robinson 2012-04-02 11:02:23 EDT
Created attachment 574532 [details]
File: build_ids
Comment 6 Milan Crha 2012-04-03 02:25:53 EDT
Thanks for a bug report. It sounds like DConf/glib2 issue, because evolution only creates new GSettings object with
> g_settings_new ("org.gnome.evolution.mail")
in one thread, while the DConf's thread crashes with:

Thread 1 (Thread 0x7f95b1bc2700 (LWP 1923)):
#0  0x00007f95c14a1cba in g_settings_backend_dispatch_signal (backend=backend@entry=0x223a9c0, function_offset=function_offset@entry=8, name=name@entry=0x27f1bf0 "/org/gnome/evolution/mail/", data1=data1@entry=0x0, data1_copy=0x7f95c14a17a0 <pointer_id>, data1_copy@entry=0, data1_free=0x7f95c14a17b0 <pointer_ignore>, data1_free@entry=0, data2=data2@entry=0x0) at gsettingsbackend.c:340
#1  0x00007f95c14a222d in g_settings_backend_path_changed (backend=0x223a9c0, path=path@entry=0x27f1bf0 "/org/gnome/evolution/mail/", origin_tag=origin_tag@entry=0x0) at gsettingsbackend.c:496
#2  0x00007f95b1bd279a in add_match_done (source=<optimized out>, result=0x7f95a0007a50, user_data=0x26f5580) at dconfsettingsbackend.c:597
#3  0x00007f95c1469e17 in g_simple_async_result_complete (simple=0x7f95a0007a50) at gsimpleasyncresult.c:767
#4  0x00007f95c14b8552 in g_dbus_connection_call_done (source=<optimized out>, result=<optimized out>, user_data=0x7f95a4022a30) at gdbusconnection.c:5289
#5  0x00007f95c1469e17 in g_simple_async_result_complete (simple=0x7f95a407f250) at gsimpleasyncresult.c:767
#6  0x00007f95c1469f19 in complete_in_idle_cb (data=<optimized out>) at gsimpleasyncresult.c:779
#7  0x00007f95bfb1b5bc in g_main_dispatch (context=0x222a0b0)
#8  g_main_context_dispatch (context=context@entry=0x222a0b0)
#9  0x00007f95bfb1b9d8 in g_main_context_iterate (context=0x222a0b0, block=block@entry=1, dispatch=dispatch@entry=1, self=<error reading variable: Unhandled dwarf expression opcode 0xfa>) at gmain.c:3123
#10 0x00007f95bfb1bdd2 in g_main_loop_run (loop=0x7f95a40010c0)
#11 0x00007f95b1bd1b0b in dconf_context_thread (data=0x222a0b0)
#12 0x00007f95bfb3e315 in g_thread_proxy (data=0x226eca0) at gthread.c:801
#13 0x00007f95c0250d14 in start_thread ()
#14 0x00007f95bf80e8fd in clone ()
Comment 7 Milan Crha 2012-04-04 12:32:46 EDT
I had a little chat with Mathias and we think this belongs to DConf. If they realize it is not, then it can be moved to the appropriate module. We also decided to upstream this, for better visibility, thus I'm doing so. Please see [1] for any further updates. If possible, please CC yourself there, in case upstream developers will have additional questions.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=673519
Comment 8 Milan Crha 2012-06-15 05:43:11 EDT
*** Bug 832001 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.