Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 809186 - ruby/config.h is not in the /usr/include directory
Summary: ruby/config.h is not in the /usr/include directory
Keywords:
Status: CLOSED DUPLICATE of bug 789376
Alias: None
Product: Fedora
Classification: Fedora
Component: ruby
Version: 17
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jeroen van Meeuwen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-02 17:21 UTC by Darryl L. Pierce
Modified: 2015-06-22 00:07 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-03 04:54:47 UTC
Type: ---


Attachments (Terms of Use)

Description Darryl L. Pierce 2012-04-02 17:21:17 UTC
Description of problem:
When building Ruby extensions and bindings, the ruby/config.h file is requiring an extra -I argument when it should be available as /usr/include/ruby/config.h


Version-Release number of selected component (if applicable):
[mcpierce@mcp-f17-i386 ruby]$ rpm -q ruby-devel
ruby-devel-1.9.3.0-9.fc17.i686


How reproducible:
100%


Steps to Reproduce:
1. Install the RPM.

  
Actual results:
config.h is separate from the other headers.


Expected results:
config.h to be with the other headers.


Additional info:
This is verified as also the case in the x86_64 package as well.

Comment 1 Vít Ondruch 2012-04-03 04:54:47 UTC

*** This bug has been marked as a duplicate of bug 789376 ***


Note You need to log in before you can comment on or make changes to this bug.