Bug 809194 - 404 Response Codes from Internally Linked URLs
404 Response Codes from Internally Linked URLs
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified All
low Severity low
: ---
: ---
Assigned To: Fabiano Franz
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-02 13:41 EDT by Shawn Purtell
Modified: 2015-05-14 21:07 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-27 16:45:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
List of URLs responding with a 404 code (3.86 KB, text/csv)
2012-04-02 13:41 EDT, Shawn Purtell
no flags Details

  None (edit)
Description Shawn Purtell 2012-04-02 13:41:47 EDT
Created attachment 574576 [details]
List of URLs responding with a 404 code

Description of problem:
Several (currently 33) internal links on the OS community site are returning 404 (file not found) response codes when accessed.

Version-Release number of selected component (if applicable):
N/A

How reproducible:
Visit any of the 33 URLs in the attached .csv file.

Steps to Reproduce:
1. Visit any page on the list of URLs (e.g. https://www.redhat.com/openshift/community/documents)
  
Actual results:
404 response code

Expected results:
Active page on https://www.redhat.com/openshift/community/

Additional info:
This data was accessed via a Google Webmaster Tools crawl report.
Issues affect both SEO and user experience (broken links).
Comment 1 David O'Brien 2012-04-11 22:20:06 EDT
Any links to (e.g.), "OpenShift_Express-*" need to be replaced with the latest versions, already published on the Community site, that no longer use "Express" as part of the name.
Comment 2 Fabiano Franz 2012-04-12 13:45:04 EDT
Lowering the severity since this is not related to source code so this don't block stg build. Drupal content changes right in production.
Comment 3 Fabiano Franz 2012-04-12 13:51:33 EDT
This is only a bug if the related URLs are linked *from* any of our pages. Please note that GWT reports every 404 *including* the URLs linked only from external sites that links to us. 

For some of the most important ones we can create redirects in order to keep important external articles or blog posts working. But for most of them, it would be nice to know which of our own pages links to those that are returning 404. Is that kind of information available?

Thanks!
Comment 4 Shawn Purtell 2012-04-12 14:20:17 EDT
Internal link information is available within the GWT UI for each of these URLs, but is not easily exported. I can give you direct access to the data via a Google account if that works.
Comment 5 Fabiano Franz 2012-04-12 14:23:18 EDT
(In reply to comment #4)
> Internal link information is available within the GWT UI for each of these
> URLs, but is not easily exported. I can give you direct access to the data via
> a Google account if that works.

It does, my google account is: fabianofranz@gmail.com.
Comment 6 Shawn Purtell 2012-04-12 14:36:25 EDT
(In reply to comment #5)
> (In reply to comment #4)
> > Internal link information is available within the GWT UI for each of these
> > URLs, but is not easily exported. I can give you direct access to the data via
> > a Google account if that works.
> 
> It does, my google account is: fabianofranz@gmail.com.

Great - you now have access via http://www.google.com/webmastertools.

Information is under Diagnostics >> Crawl Errors. Click on a specific URL to access internal link information on the 'Linked From' tab.
Comment 7 Fabiano Franz 2012-04-12 15:17:11 EDT
The most important 404s has been fixed with URL redirects right in production. Examples:

 * /documents to /documentation
 * /forums/express to /forums/openshift
 * all guides and documents
 * broken FAQs
 * broken feature requests
 * many others

We can expect them to be removed from GWT Crawl Errors in some time. The ones related to forums threads has not been fixed when we understand the threads has been closed (not Express to OpenShift renaming problems), in that case a 404 is actually expected.

Thanks!
Comment 8 Yujie Zhang 2012-04-16 06:11:22 EDT
(In reply to comment #7)
According to your comments, tested this bug on product, it has been fixed now, thanks.

Note You need to log in before you can comment on or make changes to this bug.