Bug 809208 - SPICE: Video compression of HTML5 viewer in FF12 is tearing and jumping
SPICE: Video compression of HTML5 viewer in FF12 is tearing and jumping
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-server (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Uri Lublin
Desktop QE
:
Depends On: 813834
Blocks: 840699
  Show dependency treegraph
 
Reported: 2012-04-02 14:26 EDT by Bill Sanford
Modified: 2014-07-07 16:07 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-04 16:44:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
HTML5 menu from right-click on HTML5 video (509.10 KB, image/png)
2012-04-02 14:28 EDT, Bill Sanford
no flags Details

  None (edit)
Description Bill Sanford 2012-04-02 14:26:47 EDT
Description of problem:
Using the HTML5 (Without Flash Player) viewer in FF12, you'll see tearing and jumping of about 10% of the bottom of the viewing area during a video.

In youtube.com, search for "HTML5 Youtube video." The video will play if it is not dependent on flash. To ensure you are using HTML5, right click the viewer area and you should see an HTML5 menu like in the attachment (html5.png).

You will notice this issue if the video is panning instead of a stable shot. Once you look at the "New Google+ Commercial" on the Google channel, this whole video is jumping because the picture is changing.

Version-Release number of selected component (if applicable):

Firefox 12.0.3

spice-vdagent-0.8.1-3.el6.x86_64 
spice-server-0.10.1-4.el6.x86_64 
spice host RHEL 6.3 - 64bit 
rhevm ic155 
qemu-kvm-0.12.1.2-2.246.el6.x86_64 
qemu-kvm-tools-0.12.1.2-2.246.el6.x86_64 

How reproducible:
100%

Steps to Reproduce:
1. yum remove flash flash-plugin
2. install the 12.0.3 beta from Mozilla
3. play an HTML5 video.
  
Actual results:
The video is jumping and tearing in the lowest 10% of the viewer.

Expected results:
The video plays without issue.

Additional info:


Spice client RHEL 6.3 - 64bit 
spice-gtk-0.11-5.el6.x86_64 
spice-client-0.8.2-13.el6.x86_64 
spice-usb-share-4.9-9.el6.x86_64 
spice-xpi-2.7-15.el6.x86_64 
kmod-kspiceusb-rhel60-4.9-14.el6.x86_64 
spice-gtk-python-0.11-5.el6.x86_64 
spice-vdagent-0.8.1-3.el6.x86_64 
spice-glib-0.11-5.el6.x86_64 

Spice guest RHEL 5.8 64-bit 
xorg-x11-drv-qxl-0.0.14-13.el6_2.x86_64
Comment 1 Bill Sanford 2012-04-02 14:28:34 EDT
Created attachment 574584 [details]
HTML5 menu from right-click on HTML5 video
Comment 2 Andrew Cathrow 2012-04-03 06:06:25 EDT
This is under vdagent, are we sure this isn't in qxl
Comment 3 Bill Sanford 2012-04-03 11:46:01 EDT
No we aren't sure. I will put in it QXL.
Comment 4 Bill Sanford 2012-04-05 14:55:05 EDT
I also observed the same behavior in a Win7x86_64 guest without Flash. You need to have IE9 installed since that is the only IE that supports HTML5.
Comment 5 Marian Krcmarik 2012-04-18 13:26:01 EDT
I am entering dependency on #813834 We should retest once this is fixed.
Comment 6 Bill Sanford 2012-04-23 09:52:47 EDT
Per David B's request of Etherpad comments:

I uninstall any kind of flash, if it is present. I then would install an HTML5 compatible browser (link below). I then go to youtube and in the search box type "html5 video." If it can play (some won't because they depend on flash), it will invoke an identical flash player type of viewer with the H.264 codec embedded so that an enabled bowser can view it http://www.youtube.com/html5 All guests RHEL and Windows have performance issues but I think the Windows guests issues are more pronounced. Specifically, the HTML5 video "jumps" as a whole screen and is exacerbated more if the video is being "panned."

To check to see if you have an HTML5 browser, just right-click in the video area and you will see the HTML5 menu and not a typical flash menu.
Comment 7 David Blechter 2012-04-27 09:48:24 EDT
Late for 6.3, should be addressed in 6.4
Comment 9 David Blechter 2012-10-11 09:23:55 EDT
still working on 813834, not upstream yet, so moving this one to 6.5 as well
Comment 11 RHEL Product and Program Management 2013-10-14 01:03:50 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 12 Marc-Andre Lureau 2014-02-21 19:26:52 EST
bug 813834 is about windows guest, is that the reason there are those 2 bugs open?

I don't really understand what bug we are talking about here. Can someone record a video of the artifact we want a fix? (Imho, this is a pipe dream to just keep this bug open without more details and more understanding of the design pros and cons)

Fwiw, I have tested with RHEL6.5, and streaming-video=all, I get good streaming results, as long as there is no UI interaction (both with flash and html5 youtube).
Comment 13 Bill Sanford 2014-06-09 08:53:54 EDT
This is the original bug for HTML5. I was using a RHEV-M environment with a RHEL guest and host. I am not sure why she didn't update this bug to add the environment she had also seen this in. I plan to setup an environment or two to see if this still happens.
Comment 14 Marc-Andre Lureau 2014-06-18 14:21:00 EDT
it works pretty ok with rhel6 or win7 guests on rhevm3.4 hosts.

I propose to close that bug if no further comments.
Comment 15 Bill Sanford 2014-07-07 16:07:41 EDT
I installed RHEV-M 3.4 (http://bob.eng.lab.tlv.redhat.com/builds/av10/el6/) in a RHEL 6.5 environment. I accessed the RHEV-M server from a Windows 8.1 client to a Windows 7x64 guest, and the HTML5 player seems to be fixed and working.

Note You need to log in before you can comment on or make changes to this bug.