Bug 809260 - missing newline when running openstack-config-set
missing newline when running openstack-config-set
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openstack-keystone (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alan Pevec
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-02 17:39 EDT by Jan van Eldik
Modified: 2012-04-23 09:29 EDT (History)
9 users (show)

See Also:
Fixed In Version: openstack-keystone-2012.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-23 09:29:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
command line output demonstrating missing newline (915 bytes, text/plain)
2012-04-02 17:39 EDT, Jan van Eldik
no flags Details
add newline when a new section is created (321 bytes, patch)
2012-04-02 18:42 EDT, Jan van Eldik
no flags Details | Diff

  None (edit)
Description Jan van Eldik 2012-04-02 17:39:08 EDT
Created attachment 574641 [details]
command line output demonstrating missing newline

Description of problem:

When running 
  openstack-config-set /etc/glance/glance-api.conf paste_deploy flavor keystone
the new entry in /etc/glance/glance-api.conf misses a newline

Version-Release number of selected component (if applicable):

openstack-keystone-2012.1-0.11.rc1.fc16.noarch

How reproducible:

100%
Comment 1 Alan Pevec 2012-04-02 18:14:26 EDT
> the new entry in /etc/glance/glance-api.conf misses a newline

Might not be aesthetically pleasing, but it's a valid config :)
It's what iniparse produces, did you see any issues due to missing newline?
Comment 2 Jan van Eldik 2012-04-02 18:42:04 EDT
No, I did not see any issues because of this. I noticed it when trying
to understand why "glance index" throws a "500 Internal Server Error" at me...

The attached patch adds the missing newline, and makes the result more
easy on the eye.
Comment 3 Jan van Eldik 2012-04-02 18:42:51 EDT
Created attachment 574668 [details]
add newline when a new section is created
Comment 4 Alan Pevec 2012-04-02 19:20:27 EDT
(In reply to comment #3)
> Created attachment 574668 [details]
> add newline when a new section is created

Thanks!
 http://pkgs.fedoraproject.org/gitweb/?p=openstack-keystone.git;a=commitdiff;h=4f532e4ebf03a19923326f4d6c3e1827891f7d89
Comment 5 Alan Pevec 2012-04-23 09:29:19 EDT
openstack-keystone-2012.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/FEDORA-2012-4690/openstack-keystone-2012.1-1.fc17

Note You need to log in before you can comment on or make changes to this bug.