Bug 809293 - [abrt] kazehakase-base-0.5.8-11.svn3873_trunk.fc17: __strlen_sse2_pminub: Process /usr/bin/kazehakase was killed by signal 11 (SIGSEGV)
[abrt] kazehakase-base-0.5.8-11.svn3873_trunk.fc17: __strlen_sse2_pminub: Pro...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: at-spi2-atk (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
abrt_hash:927be0f77f16db607f9ded2869b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-02 21:12 EDT by Adam Williamson
Modified: 2012-04-04 06:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-04 06:56:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (21.22 KB, text/plain)
2012-04-02 21:12 EDT, Adam Williamson
no flags Details
File: maps (28.53 KB, text/plain)
2012-04-02 21:12 EDT, Adam Williamson
no flags Details
File: dso_list (6.06 KB, text/plain)
2012-04-02 21:12 EDT, Adam Williamson
no flags Details

  None (edit)
Description Adam Williamson 2012-04-02 21:12:16 EDT
libreport version: 2.0.10
abrt_version:   2.0.9
backtrace_rating: 4
cmdline:        kazehakase
comment:        Just tried to run it. I am doing super important xkcd testing, damnit! Fix this immediately!
core_backtrace: 
crash_function: __strlen_sse2_pminub
executable:     /usr/bin/kazehakase
kernel:         3.3.0-8.fc17.x86_64
pid:            26702
pwd:            /home/adamw/build/libconcord
remote_result:  NOTFOUND
time:           Mon 02 Apr 2012 06:05:42 PM PDT
uid:            1001
username:       adamw
xsession_errors: 

backtrace:      Text file, 21725 bytes
dso_list:       Text file, 6203 bytes
maps:           Text file, 29213 bytes

environ:
:GIT_PS1_SHOWDIRTYSTATE=true
:XDG_VTNR=1
:XDG_SESSION_ID=2
:HOSTNAME=adam.localdomain
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GPG_AGENT_INFO=/home/adamw/.cache/keyring-eKqySq/gpg:0:1
:TERM=xterm
:SHELL=/bin/bash
:HISTSIZE=1000
:WINDOWID=48234502
:GNOME_KEYRING_CONTROL=/home/adamw/.cache/keyring-eKqySq
:QTDIR=/usr/lib64/qt-3.3
:QTINC=/usr/lib64/qt-3.3/include
:IMSETTINGS_MODULE=none
:USER=adamw
:LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:mi=01;05;37;41:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lz=01;31:*.xz=01;31:*.bz2=01;31:*.tbz=01;31:*.tbz2=01;31:*.bz=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.war=01;31:*.ear=01;31:*.sar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=01;36:*.au=01;36:*.flac=01;36:*.mid=01;36:*.midi=01;36:*.mka=01;36:*.mp3=01;36:*.mpc=01;36:*.ogg=01;36:*.ra=01;36:*.wav=01;36:*.axa=01;36:*.oga=01;36:*.spx=01;36:*.xspf=01;36:*.pdf=00;33:*.ps=00;33:*.ps.gz=00;33:*.txt=00;33:*.patch=00;33:*.diff=00;33:*.log=00;33:*.tex=00;33:*.xls=00;33:*.xlsx=00;33:*.ppt=00;33:*.pptx=00;33:*.rtf=00;33:*.doc=00;33:*.docx=00;33:*.odt=00;33:*.ods=00;33:*.odp=00;33:*.xml=00;33:*.epub=00;33:*.abw=00;33:*.html=00;33:*.wpd=00;33:
:SSH_AUTH_SOCK=/home/adamw/.cache/keyring-eKqySq/ssh
:USERNAME=adamw
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1664,unix/unix:/tmp/.ICE-unix/1664
:PATH=/usr/lib64/qt-3.3/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/adamw/bin
:MAIL=/var/spool/mail/adamw
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/adamw/build/libconcord
:XMODIFIERS=@im=none
:GNOME_KEYRING_PID=1639
:LANG=en_US.utf8
:KDE_IS_PRELINKED=1
:GDM_LANG=en_US.utf8
:KDEDIRS=/usr
:'PS1=[\\[\\e[0;32m\\]\\u\\[\\e[0m\\]@\\[\\e[0;34m\\]\\h\\[\\e[0m\\] \\W\\[\\e[0;33m\\]$(__git_ps1 \" (%s)\")\\[\\e[0m\\]]\\[\\e[0;32m\\]\\$ \\[\\e[0m\\]'
:GIT_PS1_SHOWUNTRACKEDFILES=true
:GDMSESSION=gnome
:SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
:HISTCONTROL=ignoredups
:HOME=/home/adamw
:XDG_SEAT=seat0
:SHLVL=2
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:LOGNAME=adamw
:QTLIB=/usr/lib64/qt-3.3/lib
:CVS_RSH=ssh
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-ARd5wjyNk6,guid=bca29c1d22b1c4c56aa6d51e00000028
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/adamw
:DISPLAY=:0
:COLORTERM=gnome-terminal
:XAUTHORITY=/var/run/gdm/auth-for-adamw-8FVIKG/database
:_=/usr/bin/kazehakase

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 128043               processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       128043               128043               signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/pts/3
:pos:	0
:flags:	0102002
:1:/dev/pts/3
:pos:	0
:flags:	0102002
:2:/dev/pts/3
:pos:	0
:flags:	0102002
:3:socket:[2321167]
:pos:	0
:flags:	02004002
:4:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:5:socket:[2358623]
:pos:	0
:flags:	02004002
:6:anon_inode:[eventfd]
:pos:	0
:flags:	02004002

var_log_messages:
:Apr  2 18:05:01 adam yum[26609]: Installed: kazehakase-base-0.5.8-11.svn3873_trunk.fc17.x86_64
:Apr  2 18:05:02 adam yum[26609]: Installed: kazehakase-webkit-0.5.8-11.svn3873_trunk.fc17.x86_64
:Apr  2 18:05:02 adam yum[26609]: Installed: kazehakase-0.5.8-11.svn3873_trunk.fc17.x86_64
:Apr  2 18:05:42 adam kernel: [ 9832.046049] kazehakase[26702]: segfault at 2 ip 00000038bd35f671 sp 00007fff2616f198 error 4 in libc-2.15.so[38bd200000+1ac000]
:Apr  2 18:05:42 adam abrt[26703]: Saved core dump of pid 26702 (/usr/bin/kazehakase) to /var/spool/abrt/ccpp-2012-04-02-18:05:42-26702 (2048000 bytes)
Comment 1 Adam Williamson 2012-04-02 21:12:19 EDT
Created attachment 574708 [details]
File: backtrace
Comment 2 Adam Williamson 2012-04-02 21:12:22 EDT
Created attachment 574709 [details]
File: maps
Comment 3 Adam Williamson 2012-04-02 21:12:23 EDT
Created attachment 574710 [details]
File: dso_list
Comment 4 Mamoru TASAKA 2012-04-04 00:03:13 EDT
Looks like no kazehakase specific functions are executed at this stage, so currently I doubt this is kazehakase's fault.

By the way PLEASE DON'T USE WORDS LIKE DAMNIT OR SO.
Comment 5 Mamoru TASAKA 2012-04-04 06:56:41 EDT
Currently I suspect this is at-spi2-gtk side bug + gcc optimization issue and/or so on, which may already be fixed. Please first try GNOME mass update. Once closing.
Comment 6 Mamoru TASAKA 2012-04-04 06:58:18 EDT
(In reply to comment #5)
> Currently I suspect this is at-spi2-gtk side bug + gcc optimization issue
> and/or so on, which may already be fixed. Please first try GNOME mass update.
> Once closing.

s|at-spi2-gtk|at-spi2-atk|

Note You need to log in before you can comment on or make changes to this bug.