Bug 809349 - aeolus-configure cli should display Usage info if no option is supplied
aeolus-configure cli should display Usage info if no option is supplied
Status: CLOSED DUPLICATE of bug 799814
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-configure (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Maros Zatko
pushpesh sharma
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-03 03:20 EDT by pushpesh sharma
Modified: 2014-08-04 18:30 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-08 11:51:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description pushpesh sharma 2012-04-03 03:20:13 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.From cli issue the following cmd:-
 aeolus-configure mock,ec2(i.e. didt use any option)

2.No error message is  displayed for correct options,even it display same output if this configuration is successful.

  
Actual results:
no error msg or usage info is displayed 

Expected results:
Usage info should be displayed as specified 

Additional info:
[root@dhcp201-169 ~]# aeolus-configure -h

USAGE:
aeolus-configure [-d|--debug] [-h|--help] [-v|--verbose] [-p|--profile]

OPTIONS:
   -h | --help       Show this message.
   -d | --debug      Debug logging mode.
   -v | --verbose    Verbose logging mode.
                     Note that you can only set one of the previous two options per run. If both are set,
                     the last one passed in will be honored.
   -p | --profile    Name of profile to use. A comma separated list can be used to specify multiple profiles.
Comment 2 Maros Zatko 2012-05-08 11:51:03 EDT

*** This bug has been marked as a duplicate of bug 799814 ***

Note You need to log in before you can comment on or make changes to this bug.