Bug 809483 - RuntimeError: get_sysfs_path_by_name: Could not find sysfs path for '/dev/mmcblk0p2' (it is not at '/sys/class/block/mmcblk0p2')
RuntimeError: get_sysfs_path_by_name: Could not find sysfs path for '/dev/mmc...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:b49b0a948b23a5963acdf37e3d5...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-03 09:34 EDT by David Filiatrault
Modified: 2012-04-03 11:08 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-03 11:08:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb-Nq7Y0A (885.07 KB, text/plain)
2012-04-03 09:35 EDT, David Filiatrault
no flags Details

  None (edit)
Description David Filiatrault 2012-04-03 09:34:26 EDT
libreport version: 2.0.8
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/loop3 --lang en_US.UTF-8
executable:     /sbin/anaconda
exnFileName:    /tmp/anaconda-tb-Nq7Y0A
hashmarkername: anaconda
kernel:         3.3.0-0.rc3.git7.2.fc17.x86_64
other involved packages: 
product:        Fedora
reason:         RuntimeError: get_sysfs_path_by_name: Could not find sysfs path for '/dev/mmcblk0p2' (it is not at '/sys/class/block/mmcblk0p2')
release:        Fedora release 17 (Beefy Miracle)
time:           Tue 03 Apr 2012 05:31:36 AM EDT
version:        17

anaconda-tb-Nq7Y0A: Binary file, 906307 bytes

description:
:The following was filed automatically by anaconda:
:anaconda 17.11 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/iutil.py", line 835, in get_sysfs_path_by_name
:    "for '%s' (it is not at '%s')" % (dev_node, dev_path))
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/formats/__init__.py", line 261, in notifyKernel
:    path = get_sysfs_path_by_name(name)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/formats/fs.py", line 380, in doFormat
:    self.notifyKernel()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/formats/fs.py", line 970, in doFormat
:    FS.doFormat(self, *args, **kwargs)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/formats/fs.py", line 877, in create
:    return self.doFormat(*args, **kwargs)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/deviceaction.py", line 433, in execute
:    options=self.device.formatArgs)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 319, in processActions
:    action.execute(intf=self.intf)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 375, in doIt
:    self.devicetree.processActions()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/packages.py", line 122, in turnOnFilesystems
:    anaconda.storage.doIt()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 383, in dispatch
:    self.dir = self.steps[self.step].target(self.anaconda)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 247, in go_forward
:    self.dispatch()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1200, in nextClicked
:    self.anaconda.dispatch.go_forward()
:RuntimeError: get_sysfs_path_by_name: Could not find sysfs path for '/dev/mmcblk0p2' (it is not at '/sys/class/block/mmcblk0p2')

environ:
:LC_NUMERIC=C
:LIBUSER_CONF=/tmp/libuser.FKDML_
:LVM_SUPPRESS_FD_WARNINGS=1
:LOGNAME=root
:USER=root
:GCONF_GLOBAL_LOCKS=1
:PATH=/sbin:/usr/sbin:/usr/sbin:/usr/bin:/sbin:/bin:/root/bin:/sbin:/usr/sbin
:PIXMAPPATH=/tmp/updates/pixmaps/:/tmp/updates/:/tmp/product/pixmaps/:/tmp/product/:pixmaps/:/usr/share/anaconda/pixmaps/:/usr/share/pixmaps/:/usr/share/anaconda/:/usr/share/python-meh/:/usr/share/icons/Fedora/48x48/apps/
:HOME=/tmp
:DISPLAY=:0
:ANACONDA_PRODUCTNAME=Fedora
:LANG=en_US.UTF-8
:ANACONDA_ISFINAL=false
:SHELL=/bin/bash
:TZ=America/New_York
:XAUTHORITY=/root/.xauthawu1CV
:GLADEPATH=/tmp/updates/:/tmp/updates/data/ui/:ui/:/usr/share/anaconda/ui/:/usr/share/python-meh/
:SHLVL=1
:GNOME_DISABLE_CRASH_DIALOG=1
:ANACONDA_PRODUCTVERSION=17
:ANACONDA_BUGURL=https://bugzilla.redhat.com/bugzilla/
:USERHELPER_UID=1000
:_=/usr/bin/udisks
:PWD=/home/liveuser/Documents
:DESKTOP_STARTUP_ID=userhelper/Starting Install to Hard Drive/1487-0-localhost.localdomain_TIME0
Comment 1 David Filiatrault 2012-04-03 09:35:06 EDT
Created attachment 574870 [details]
File: anaconda-tb-Nq7Y0A
Comment 2 David Lehman 2012-04-03 11:08:52 EDT
It looks like hardware failure or fairly severe driver issues. Here is just a small sampling of the hardware-related errors from the system log:

Apr  3 05:31:25 localhost kernel: [ 1188.645295] end_request: I/O error, dev mmcblk0, sector 1028064
Apr  3 05:31:25 localhost kernel: [ 1188.645339] end_request: I/O error, dev mmcblk0, sector 1028072
Apr  3 05:31:25 localhost kernel: [ 1188.645372] end_request: I/O error, dev mmcblk0, sector 1028080
Apr  3 05:31:25 localhost kernel: [ 1188.645409] end_request: I/O error, dev mmcblk0, sector 1028088
Apr  3 05:31:25 localhost kernel: [ 1188.645680] mmcblk0: error -123 sending status command, retrying
Apr  3 05:31:25 localhost kernel: [ 1188.645699] mmcblk0: error -123 sending status command, retrying
Apr  3 05:31:25 localhost kernel: [ 1188.645709] mmcblk0: error -123 sending status command, aborting
Apr  3 05:31:25 localhost kernel: [ 1188.645714] end_request: I/O error, dev mmcblk0, sector 4096
Apr  3 05:31:25 localhost udevd[2303]: inotify_add_watch(6, /dev/mmcblk0p2, 10) failed: No such file or directory
Apr  3 05:31:25 localhost kernel: [ 1188.859206] tifm_core: MMC/SD card detected in socket 0:1
Apr  3 05:31:25 localhost kernel: [ 1189.018361] mmc1: new SDHC card at address e624

Note You need to log in before you can comment on or make changes to this bug.