Bug 809512 - Network interfaces drop and restart
Network interfaces drop and restart
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
Unspecified Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-03 10:52 EDT by bpk678
Modified: 2012-09-06 10:11 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-06 10:11:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Makefile for standalone module build (135 bytes, application/octet-stream)
2012-04-12 17:28 EDT, Francois Romieu
no flags Details

  None (edit)
Description bpk678 2012-04-03 10:52:17 EDT
Description of problem:
network interfaces drop and restart constantly.  Link is shown to drop and the interface cycles, regardless of static config or DHCP assignment

Version-Release number of selected component (if applicable):
3.3.x and above.  Issue not found in 3.2.10 and below

How reproducible:
Can be reproduced at will, when using 3.3.x and above

Steps to Reproduce:
1. Upgrade to, and boot into 3.3.x kernel version
2. Watch interface indicator LEDs
3. Tail /var/log/messages
  
Actual results:
Network interfaces drop and restart/re-init

Expected results:
Network interfaces should not be dropping and restarting/re-initing

Additional info:

Hardware Unit 1 (i386, DHCP assignment) -
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 74)
	Subsystem: VIA Technologies, Inc. VT6102 [Rhine II] Embeded Ethernet Controller on VT8235
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 64 (750ns min, 2000ns max), Cache Line Size: 64 bytes
	Interrupt: pin A routed to IRQ 23
	Region 0: I/O ports at 1800 [size=256]
	Region 1: Memory at d0002c00 (32-bit, non-prefetchable) [size=256]
	Capabilities: [40] Power Management version 2
		Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0+,D1+,D2+,D3hot+,D3cold+)
		Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
	Kernel driver in use: via-rhine
	Kernel modules: via-rhine

/var/log/messages info for Hardware Unit 1 (i386) -
Mar  4 12:35:28 laptop kernel: [242421.605723] via-rhine 0000:00:12.0: em2: link up, 100Mbps, full-duplex, lpa 0x45E1
Mar  4 12:35:28 laptop NetworkManager[845]: <info> (em2): carrier now ON (device state 20)
Mar  4 12:35:28 laptop NetworkManager[845]: <info> (em2): device state change: unavailable -> disconnected (reason 'carrier-changed') [20 30 40]
Mar  4 12:35:28 laptop NetworkManager[845]: <info> Auto-activating connection 'em2 dhcp'.
Mar  4 12:35:28 laptop NetworkManager[845]: <info> Activation (em2) starting connection 'em2 dhcp'
Mar  4 12:35:28 laptop NetworkManager[845]: <info> (em2): device state change: disconnected -> prepare (reason 'none') [30 40 0]
Mar  4 12:35:28 laptop NetworkManager[845]: NetworkManager[845]: <info> (em2): carrier now ON (device state 20)
Mar  4 12:35:28 laptop NetworkManager[845]: NetworkManager[845]: <info> (em2): device state change: unavailable -> disconnected (reason 'carrier-changed') [20 30 40]
Mar  4 12:35:28 laptop NetworkManager[845]: NetworkManager[845]: <info> Auto-activating connection 'em2 dhcp'.
Mar  4 12:35:28 laptop NetworkManager[845]: NetworkManager[845]: <info> Activation (em2) starting connection 'em2 dhcp'
Mar  4 12:35:28 laptop NetworkManager[845]: NetworkManager[845]: <info> (em2): device state change: disconnected -> prepare (reason 'none') [30 40 0]
Mar  4 12:35:28 laptop NetworkManager[845]: NetworkManager[845]: <info> Activation (em2) Stage 1 of 5 (Device Prepare) scheduled...
Mar  4 12:35:28 laptop NetworkManager[845]: <info> Activation (em2) Stage 1 of 5 (Device Prepare) scheduled...
Mar  4 12:35:28 laptop NetworkManager[845]: NetworkManager[845]: <info> Activation (em2) Stage 1 of 5 (Device Prepare) started...
Mar  4 12:35:28 laptop NetworkManager[845]: <info> Activation (em2) Stage 1 of 5 (Device Prepare) started...
Mar  4 12:35:28 laptop NetworkManager[845]: NetworkManager[845]: <info> Activation (em2) Stage 2 of 5 (Device Configure) scheduled...
Mar  4 12:35:28 laptop NetworkManager[845]: <info> Activation (em2) Stage 2 of 5 (Device Configure) scheduled...
Mar  4 12:35:28 laptop NetworkManager[845]: NetworkManager[845]: <info> Activation (em2) Stage 1 of 5 (Device Prepare) complete.
Mar  4 12:35:28 laptop NetworkManager[845]: <info> Activation (em2) Stage 1 of 5 (Device Prepare) complete.
Mar  4 12:35:28 laptop NetworkManager[845]: NetworkManager[845]: <info> Activation (em2) Stage 2 of 5 (Device Configure) starting...
Mar  4 12:35:28 laptop NetworkManager[845]: <info> Activation (em2) Stage 2 of 5 (Device Configure) starting...
Mar  4 12:35:28 laptop NetworkManager[845]: NetworkManager[845]: <info> (em2): device state change: prepare -> config (reason 'none') [40 50 0]
Mar  4 12:35:28 laptop NetworkManager[845]: <info> (em2): device state change: prepare -> config (reason 'none') [40 50 0]
Mar  4 12:35:28 laptop NetworkManager[845]: NetworkManager[845]: <info> Activation (em2) Stage 2 of 5 (Device Configure) successful.
Mar  4 12:35:28 laptop NetworkManager[845]: <info> Activation (em2) Stage 2 of 5 (Device Configure) successful.
Mar  4 12:35:28 laptop NetworkManager[845]: NetworkManager[845]: <info> Activation (em2) Stage 3 of 5 (IP Configure Start) scheduled.
Mar  4 12:35:28 laptop NetworkManager[845]: <info> Activation (em2) Stage 3 of 5 (IP Configure Start) scheduled.
Mar  4 12:35:28 laptop NetworkManager[845]: NetworkManager[845]: <info> Activation (em2) Stage 2 of 5 (Device Configure) complete.
Mar  4 12:35:28 laptop NetworkManager[845]: <info> Activation (em2) Stage 2 of 5 (Device Configure) complete.
Mar  4 12:35:28 laptop NetworkManager[845]: NetworkManager[845]: <info> Activation (em2) Stage 3 of 5 (IP Configure Start) started...
Mar  4 12:35:28 laptop NetworkManager[845]: <info> Activation (em2) Stage 3 of 5 (IP Configure Start) started...
Mar  4 12:35:28 laptop NetworkManager[845]: NetworkManager[845]: <info> (em2): device state change: config -> ip-config (reason 'none') [50 70 0]
Mar  4 12:35:28 laptop NetworkManager[845]: <info> (em2): device state change: config -> ip-config (reason 'none') [50 70 0]
Mar  4 12:35:28 laptop NetworkManager[845]: NetworkManager[845]: <info> Activation (em2) Beginning DHCPv4 transaction (timeout in 45 seconds)
Mar  4 12:35:28 laptop NetworkManager[845]: <info> Activation (em2) Beginning DHCPv4 transaction (timeout in 45 seconds)
Mar  4 12:35:28 laptop NetworkManager[845]: <info> dhclient started with pid 7987
Mar  4 12:35:28 laptop NetworkManager[845]: <info> Activation (em2) Stage 3 of 5 (IP Configure Start) complete.
Mar  4 12:35:28 laptop NetworkManager[845]: NetworkManager[845]: <info> dhclient started with pid 7987
Mar  4 12:35:28 laptop NetworkManager[845]: NetworkManager[845]: <info> Activation (em2) Stage 3 of 5 (IP Configure Start) complete.
Mar  4 12:35:29 laptop dhclient[7987]: Internet Systems Consortium DHCP Client 4.2.3-P2
Mar  4 12:35:29 laptop NetworkManager[845]: Internet Systems Consortium DHCP Client 4.2.3-P2
Mar  4 12:35:29 laptop dhclient[7987]: Copyright 2004-2012 Internet Systems Consortium.
Mar  4 12:35:29 laptop NetworkManager[845]: Copyright 2004-2012 Internet Systems Consortium.
Mar  4 12:35:29 laptop dhclient[7987]: All rights reserved.
Mar  4 12:35:29 laptop NetworkManager[845]: All rights reserved.
Mar  4 12:35:29 laptop dhclient[7987]: For info, please visit https://www.isc.org/software/dhcp/
Mar  4 12:35:29 laptop NetworkManager[845]: For info, please visit https://www.isc.org/software/dhcp/
Mar  4 12:35:29 laptop dhclient[7987]: 
Mar  4 12:35:29 laptop dhclient[7987]: Listening on LPF/em2/00:03:25:14:85:3c
Mar  4 12:35:29 laptop NetworkManager[845]: Listening on LPF/em2/00:03:25:14:85:3c
Mar  4 12:35:29 laptop dhclient[7987]: Sending on   LPF/em2/00:03:25:14:85:3c
Mar  4 12:35:29 laptop NetworkManager[845]: Sending on   LPF/em2/00:03:25:14:85:3c
Mar  4 12:35:29 laptop dhclient[7987]: Sending on   Socket/fallback
Mar  4 12:35:29 laptop NetworkManager[845]: Sending on   Socket/fallback
Mar  4 12:35:29 laptop dhclient[7987]: DHCPREQUEST on em2 to 255.255.255.255 port 67
Mar  4 12:35:29 laptop NetworkManager[845]: DHCPREQUEST on em2 to 255.255.255.255 port 67
Mar  4 12:35:29 laptop NetworkManager[845]: NetworkManager[845]: <info> (em2): DHCPv4 state changed nbi -> preinit
Mar  4 12:35:29 laptop NetworkManager[845]: <info> (em2): DHCPv4 state changed nbi -> preinit
Mar  4 12:35:30 laptop pulseaudio[2414]: sap.c: sendmsg() failed: Invalid argument
Mar  4 12:35:35 laptop pulseaudio[2414]: sap.c: sendmsg() failed: Invalid argument
Mar  4 12:35:36 laptop dhclient[7987]: DHCPREQUEST on em2 to 255.255.255.255 port 67
Mar  4 12:35:36 laptop NetworkManager[845]: DHCPREQUEST on em2 to 255.255.255.255 port 67
Mar  4 12:35:36 laptop dhclient[7987]: DHCPNAK from 192.168.11.1
Mar  4 12:35:36 laptop NetworkManager[845]: DHCPNAK from 192.168.11.1
Mar  4 12:35:37 laptop NetworkManager[845]: NetworkManager[845]: <info> (em2): DHCPv4 state changed preinit -> expire
Mar  4 12:35:37 laptop NetworkManager[845]: <info> (em2): DHCPv4 state changed preinit -> expire
Mar  4 12:35:37 laptop dhclient[7987]: DHCPDISCOVER on em2 to 255.255.255.255 port 67 interval 4
Mar  4 12:35:37 laptop NetworkManager[845]: DHCPDISCOVER on em2 to 255.255.255.255 port 67 interval 4
Mar  4 12:35:37 laptop NetworkManager[845]: <info> (em2): DHCPv4 state changed expire -> preinit
Mar  4 12:35:37 laptop NetworkManager[845]: NetworkManager[845]: <info> (em2): DHCPv4 state changed expire -> preinit
Mar  4 12:35:39 laptop dhclient[7987]: DHCPREQUEST on em2 to 255.255.255.255 port 67
Mar  4 12:35:39 laptop dhclient[7987]: DHCPOFFER from 192.168.11.1
Mar  4 12:35:39 laptop NetworkManager[845]: DHCPREQUEST on em2 to 255.255.255.255 port 67
Mar  4 12:35:39 laptop NetworkManager[845]: DHCPOFFER from 192.168.11.1
Mar  4 12:35:39 laptop dhclient[7987]: DHCPACK from 192.168.11.1
Mar  4 12:35:39 laptop NetworkManager[845]: DHCPACK from 192.168.11.1
Mar  4 12:35:39 laptop dhclient[7987]: bound to 192.168.11.2 -- renewal in 71374 seconds.
Mar  4 12:35:39 laptop NetworkManager[845]: bound to 192.168.11.2 -- renewal in 71374 seconds.
Mar  4 12:35:39 laptop NetworkManager[845]: <info> (em2): DHCPv4 state changed preinit -> bound
Mar  4 12:35:39 laptop NetworkManager[845]: <info> Activation (em2) Stage 4 of 5 (IP4 Configure Get) scheduled...
Mar  4 12:35:39 laptop NetworkManager[845]: <info> Activation (em2) Stage 4 of 5 (IP4 Configure Get) started...
Mar  4 12:35:39 laptop NetworkManager[845]: <info>   address 192.168.11.2
Mar  4 12:35:39 laptop NetworkManager[845]: <info>   prefix 24 (255.255.255.0)
Mar  4 12:35:39 laptop NetworkManager[845]: <info>   gateway 192.168.11.1
Mar  4 12:35:39 laptop NetworkManager[845]: <info>   nameserver '192.168.11.1'
Mar  4 12:35:39 laptop NetworkManager[845]: <info> Activation (em2) Stage 5 of 5 (IP Configure Commit) scheduled...
Mar  4 12:35:39 laptop NetworkManager[845]: <info> Activation (em2) Stage 4 of 5 (IP4 Configure Get) complete.
Mar  4 12:35:39 laptop NetworkManager[845]: NetworkManager[845]: <info> (em2): DHCPv4 state changed preinit -> bound
Mar  4 12:35:39 laptop NetworkManager[845]: NetworkManager[845]: <info> Activation (em2) Stage 4 of 5 (IP4 Configure Get) scheduled...
Mar  4 12:35:39 laptop NetworkManager[845]: NetworkManager[845]: <info> Activation (em2) Stage 4 of 5 (IP4 Configure Get) started...
Mar  4 12:35:39 laptop NetworkManager[845]: NetworkManager[845]: <info>   address 192.168.11.2
Mar  4 12:35:39 laptop NetworkManager[845]: NetworkManager[845]: <info>   prefix 24 (255.255.255.0)
Mar  4 12:35:39 laptop NetworkManager[845]: NetworkManager[845]: <info>   gateway 192.168.11.1
Mar  4 12:35:39 laptop NetworkManager[845]: NetworkManager[845]: <info>   nameserver '192.168.11.1'
Mar  4 12:35:39 laptop NetworkManager[845]: NetworkManager[845]: <info> Activation (em2) Stage 5 of 5 (IP Configure Commit) scheduled...
Mar  4 12:35:39 laptop NetworkManager[845]: NetworkManager[845]: <info> Activation (em2) Stage 4 of 5 (IP4 Configure Get) complete.
Mar  4 12:35:39 laptop NetworkManager[845]: NetworkManager[845]: <info> Activation (em2) Stage 5 of 5 (IP Configure Commit) started...
Mar  4 12:35:39 laptop NetworkManager[845]: <info> Activation (em2) Stage 5 of 5 (IP Configure Commit) started...
Mar  4 12:35:39 laptop avahi-daemon[840]: Joining mDNS multicast group on interface em2.IPv4 with address 192.168.11.2.
Mar  4 12:35:39 laptop avahi-daemon[840]: New relevant interface em2.IPv4 for mDNS.
Mar  4 12:35:39 laptop avahi-daemon[840]: Registering new address record for 192.168.11.2 on em2.IPv4.
Mar  4 12:35:40 laptop NetworkManager[845]: NetworkManager[845]: <info> (em2): device state change: ip-config -> activated (reason 'none') [70 100 0]
Mar  4 12:35:40 laptop NetworkManager[845]: <info> (em2): device state change: ip-config -> activated (reason 'none') [70 100 0]
Mar  4 12:35:40 laptop NetworkManager[845]: NetworkManager[845]: <info> Policy set 'em2 dhcp' (em2) as default for IPv4 routing and DNS.
Mar  4 12:35:40 laptop NetworkManager[845]: <info> Policy set 'em2 dhcp' (em2) as default for IPv4 routing and DNS.
Mar  4 12:35:40 laptop NetworkManager[845]: NetworkManager[845]: <info> Activation (em2) successful, device activated.
Mar  4 12:35:40 laptop NetworkManager[845]: <info> Activation (em2) successful, device activated.
Mar  4 12:35:40 laptop NetworkManager[845]: NetworkManager[845]: <info> Activation (em2) Stage 5 of 5 (IP Configure Commit) complete.
Mar  4 12:35:40 laptop dbus-daemon[865]: dbus[865]: [system] Activating service name='org.freedesktop.nm_dispatcher' (using servicehelper)
Mar  4 12:35:40 laptop dbus[865]: [system] Activating service name='org.freedesktop.nm_dispatcher' (using servicehelper)
Mar  4 12:35:40 laptop NetworkManager[845]: <info> Activation (em2) Stage 5 of 5 (IP Configure Commit) complete.
(messages repeat over and over in logs)

Hardware Unit 2 (x86_64, static IP config) -
04:00.0 Ethernet controller: Intel Corporation 82571EB Gigabit Ethernet Controller (Copper) (rev 06)
	Subsystem: Hewlett-Packard Company NC364T PCI Express Quad Port Gigabit Server Adapter
	Flags: bus master, fast devsel, latency 0, IRQ 48
	Memory at fdfe0000 (32-bit, non-prefetchable) [size=128K]
	Memory at fdfc0000 (32-bit, non-prefetchable) [size=128K]
	I/O ports at d800 [size=32]
	Capabilities: [c8] Power Management version 2
	Capabilities: [d0] MSI: Enable+ Count=1/1 Maskable- 64bit+
	Capabilities: [e0] Express Endpoint, MSI 00
	Capabilities: [100] Advanced Error Reporting
	Capabilities: [140] Device Serial Number 00-1c-c4-ff-ff-48-35-b6
	Kernel driver in use: e1000e
	Kernel modules: e1000e

/var/log/messages info for Hardware Unit 2 (x86_64) -
2012-04-03T10:07:51.644345-04:00 router kernel: [   53.712194] e1000e 0000:04:00.0: p1p3: Reset adapter
2012-04-03T10:07:51.689844-04:00 router kernel: [   53.758169] bonding: bond0: link status definitely down for interface p1p3, disabling it
2012-04-03T10:07:54.869784-04:00 router kernel: [   56.938099] e1000e: p1p3 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: Rx/Tx
2012-04-03T10:07:54.889854-04:00 router kernel: [   56.958201] bonding: bond0: link status definitely up for interface p1p3, 1000 Mbps full duplex.
(messages repeat over and over in logs)
Comment 1 Francois Romieu 2012-04-10 17:23:24 EDT
It looks like a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=805801

Can you try the (post 3.3) via-rhine driver it references ?

Thanks.

-- 
Ueimor
Comment 2 bpk678 2012-04-12 17:07:09 EDT
i am onboard with helping out and testing, but there are a couple caveats.

first, i dont know what to do with the code shown at the URL (http://git.kernel.org/?p=linux/kernel/git/torvalds/linux.git;a=blob_plain;f=drivers/net/ethernet/via/via-rhine.c;hb=3f8c91a7398b9266fbe7abcbe4bd5dffef907643).  i dont have compilers installed, nor am i any good at using them ;).

second, it seems to me that the issue is not related entirely to the via-rhine driver, as i have an Intel/HP rebranded NIC using the e1000e driver showing nearly identical symptoms as the via-rhine driver.

the two driver issues being the same or different, i can lend a hand but, again, dont have the means or proficiency to compile code.  can a binary or rpm be made available?  if not, i would need some (verbose) directions to go off of.
Comment 3 Francois Romieu 2012-04-12 17:28:04 EDT
Created attachment 577172 [details]
Makefile for standalone module build
Comment 4 Francois Romieu 2012-04-12 17:38:46 EDT
(In reply to comment #2)
> i am onboard with helping out and testing, but there are a couple caveats.
> 
> first, i dont know what to do with the code shown at the URL
> (http://git.kernel.org/?p=linux/kernel/git/torvalds/linux.git;a=blob_plain;f=drivers/net/ethernet/via/via-rhine.c;hb=3f8c91a7398b9266fbe7abcbe4bd5dffef907643).
>  i dont have compilers installed, nor am i any good at using them ;).

$ wget -O Makefile "https://bugzilla.redhat.com/attachment.cgi?id=577172"
$ wget -O via-rhine.c "http://git.kernel.org/?p=linux/kernel/git/torvalds/linux.git;a=blob_plain;f=drivers/net/ethernet/via/via-rhine.c;hb=3f8c91a7398b9266fbe7abcbe4bd5dffef907643"
$ yum install kernel-devel gcc make
$ make

You have got a shiny new via-rhine.ko module.

[...]
> second, it seems to me that the issue is not related entirely to the via-rhine
> driver, as i have an Intel/HP rebranded NIC using the e1000e driver showing
> nearly identical symptoms as the via-rhine driver.

There is a known 3.3 via-rhine regression. You do not want to try and fix anything
via-rhine related while it's there.

> the two driver issues being the same or different, i can lend a hand but,
> again, dont have the means or proficiency to compile code.  Can a binary or rpm
> be made available?  if not, i would need some (verbose) directions to go off
> of.

Please copy paste the commands above (don't include the "$") and follow the stream.

Thanks.

-- 
Ueimor
Comment 5 Josh Boyer 2012-09-06 10:11:49 EDT
F16 is on 3.4 now.  This issue should be resolved.  If you can recreate it with the latest F16 3.4 or F17 3.5 kernel, please let us know.

Note You need to log in before you can comment on or make changes to this bug.