Bug 809520 - v7 1.5 R14 traceback on server start
v7 1.5 R14 traceback on server start
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
1.5
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Greg Nichols
Petr Beňas
:
Depends On:
Blocks: 767775
  Show dependency treegraph
 
Reported: 2012-04-03 11:02 EDT by Greg Nichols
Modified: 2015-01-04 18:02 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
no tech note needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-05 17:37:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Nichols 2012-04-03 11:02:43 EDT
Description of problem:

v7 1.5 R14 server has a traceback on server startup:

Traceback (most recent call last):
  File "/usr/bin/v7", line 45, in ?
    success = v7.do(args)
  File "/usr/share/v7/lib/v7/hardwaretest.py", line 185, in do
    return self.doServer(args)
  File "/usr/share/v7/lib/v7/hardwaretest.py", line 501, in doServer
    planner = Planner(self.options, virtualization=None)
TypeError: __init__() takes exactly 4 non-keyword arguments (3 given)
Comment 4 Petr Beňas 2012-04-05 10:25:58 EDT
Reproduced in R14 and verified in R15.
Comment 5 Caspar Zhang 2012-06-04 04:00:52 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
no tech note needed.
Comment 7 errata-xmlrpc 2012-06-05 17:37:26 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0711.html

Note You need to log in before you can comment on or make changes to this bug.