Bug 809548 - Root user is unable to update extensions for all users.
Root user is unable to update extensions for all users.
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
17
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Stephan Bergmann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-03 11:53 EDT by Brandon
Modified: 2012-06-15 11:28 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-15 11:28:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Brandon 2012-04-03 11:53:19 EDT
I am able to install extensions for all users as the root; HOWEVER, I am unable to update the extension for all users.

Expected behavior:
Root user has the ability to update extension for all users.
Comment 1 David Tardon 2012-04-04 01:26:12 EDT
Could you be a bit more specific? How did you install the extension originally (extension manager, unopkg,...)? How did you try to update it? What behaviour did you expect? Have you tried it with another extension? Maybe the one you are trying to update (it would not be bad to know the extension's name and version) contains incorrect registration data or something like that...

AFAIK there has been hardly any change in that area since 3.3...
Comment 2 Brandon 2012-04-05 12:58:19 EDT
The package is LanguageTool it was installed by downloading it as a .oxt  Then it was installed through the extension toolbar as a root user.  It asked if I wanted to install the plugin for all users I selected yes.

Later on I check the extension.  LibreOffice informed me an update was available.  I let it fetch the update automatically. It did not update the plugin for users.  

Language tool 1.6 -> 1.7

Ubuntu has the same exact problem.  However, there was one difference the guest account's version did update.
Comment 3 Brandon 2012-04-05 12:59:21 EDT
All updates were applied as the ROOT.
Comment 4 Caolan McNamara 2012-05-09 16:08:47 EDT
caolanm->sbergman: This is more in the nature of a RFE isn't it. I mean, we don't currently have the smarts to, when run as root, to stick a "update for all users" toggle up in the gui like we do for when installing an extension as root.

With a RHEL/Fedora hat on, updating extensions for all users from inside a single app as root is a bit orthogonal to our usual "just package them as rpms and let that take care of it" perspective, e.g. the openoffice.org-voikko approach, i.e. this is probably more suitable as a generic upstream RFE

caolanm->brandon: Are the command line tools sufficient for you, e.g. 
unopkg --shared list
to get the shared extensions and their ids
unopkg --shared remove the-extension-id 
and
unopkg --shared add the-extension-url
Comment 5 Stephan Bergmann 2012-06-11 12:30:19 EDT
(In reply to comment #2)
> Later on I check the extension.  LibreOffice informed me an update was
> available.  I let it fetch the update automatically. It did not update the
> plugin for users.  

I cannot reproduce this with current LibreOffice master.  Just to be clear, checking and updating the extension was again done as the root user?
Comment 6 Stephan Bergmann 2012-06-15 11:28:40 EDT
Closing as WORKSFORME for now (see comment 5).  Feel free to reopen when you still run into this.

Note You need to log in before you can comment on or make changes to this bug.