Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 809568 - SELinux is preventing WorkerPool/1493 from using the 'ptrace' accesses on a process.
Summary: SELinux is preventing WorkerPool/1493 from using the 'ptrace' accesses on a p...
Keywords:
Status: CLOSED DUPLICATE of bug 809455
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 17
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:28d390b5f614369a1310c4cb6ff...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-03 16:35 UTC by Mikhail
Modified: 2012-04-04 08:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-04 08:57:32 UTC
Type: ---


Attachments (Terms of Use)

Description Mikhail 2012-04-03 16:35:58 UTC
libreport version: 2.0.10
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.0-8.fc17.i686.PAE
time:           Tue 03 Apr 2012 10:35:47 PM YEKT

description:
:SELinux is preventing WorkerPool/1493 from using the 'ptrace' accesses on a process.
:
:*****  Plugin catchall_boolean (89.3 confidence) suggests  *******************
:
:If you want to allow sysadm to debug or ptrace all processes.
:Then you must tell SELinux about this by enabling the 'deny_ptrace'boolean.
:Do
:setsebool -P deny_ptrace 0
:
:*****  Plugin catchall (11.6 confidence) suggests  ***************************
:
:If you believe that 1493 should be allowed ptrace access on processes labeled unconfined_t by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep WorkerPool/1493 /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
:                              023
:Target Context                unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
:                              023
:Target Objects                 [ process ]
:Source                        WorkerPool/1493
:Source Path                   WorkerPool/1493
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-106.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.0-8.fc17.i686.PAE #1 SMP Thu Mar 29
:                              18:26:56 UTC 2012 i686 i686
:Alert Count                   9
:First Seen                    Mon 02 Apr 2012 08:26:10 AM YEKT
:Last Seen                     Tue 03 Apr 2012 02:05:14 AM YEKT
:Local ID                      b7c4fd82-20f2-46ae-8924-8eafa41b977e
:
:Raw Audit Messages
:type=AVC msg=audit(1333397114.438:928): avc:  denied  { ptrace } for  pid=5096 comm="chrome" scontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tclass=process
:
:
:Hash: WorkerPool/1493,unconfined_t,unconfined_t,process,ptrace
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:

Comment 1 Miroslav Grepl 2012-04-04 08:57:32 UTC

*** This bug has been marked as a duplicate of bug 809455 ***


Note You need to log in before you can comment on or make changes to this bug.