Bug 809585 - libguestfs-tools-c wants to pull in both i686 and x86_64 deps in Fedora 16
libguestfs-tools-c wants to pull in both i686 and x86_64 deps in Fedora 16
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
16
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-03 13:21 EDT by John Dulaney
Modified: 2014-06-18 05:06 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-13 15:49:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Dulaney 2012-04-03 13:21:02 EDT
Description of problem:
Specifically, it wants to pull in both x86_64 and i686 versions of libguestfs when the x86_64 version is already installed, causing Yum to bork due to protected shared library conflict

Version-Release number of selected component (if applicable):
1.16.5-1

How reproducible:
Always

Steps to Reproduce:
1. Yum groupinstall 'virtualization'
2. Realize libguestfs-tools is needed and not installed
3. yum install libguestfs-tools
4. yum complains
Comment 1 Richard W.M. Jones 2012-04-03 13:36:54 EDT
I'm sure this is some multilib brokenness, but what's the full
output of yum?
Comment 2 John Dulaney 2012-04-03 13:50:12 EDT
 yum install libguestfs-tools-c
Loaded plugins: langpacks, presto, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package libguestfs-tools-c.x86_64 1:1.16.5-1.fc16 will be installed
--> Processing Dependency: libguestfs = 1:1.16.5-1.fc16 for package: 1:libguestfs-tools-c-1.16.5-1.fc16.x86_64
--> Running transaction check
---> Package libguestfs.i686 1:1.16.5-1.fc16 will be installed
google-chrome/filelists                                                                                                | 1.1 kB     00:00     
rpmfusion-free-updates/filelists_db                                                                                    | 166 kB     00:00     
rpmfusion-nonfree-updates/filelists_db                                                                                 | 162 kB     00:00     
updates/filelists_db                                                                                                   | 9.3 MB     00:10     
--> Processing Dependency: libvirt.so.0 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: libpcre.so.0 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: libmagic.so.1 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: libhivex.so.0 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: libaugeas.so.0 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /usr/lib/sse2/libmp.so.3 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /usr/lib/sse2/libgmpxx.so.4 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /usr/lib/sse2/libgmp.so.3 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /usr/lib/libutempter.so.0 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /usr/lib/libustr-1.0.so.1 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /usr/lib/libssl.so.10 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /usr/lib/libslang.so.2 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /usr/lib/libsemanage.so.1 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /usr/lib/libpcreposix.so.0 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /usr/lib/libpcrecpp.so.0 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /usr/lib/libmp.so.3 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /usr/lib/libmagic.so.1 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /usr/lib/liblzo2.so.2 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /usr/lib/liblzma.so.5 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /usr/lib/libgmpxx.so.4 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /usr/lib/libgmp.so.3 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /usr/lib/libgdbm_compat.so.3 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /usr/lib/libgdbm.so.3 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /usr/lib/libfa.so.1 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /usr/lib/libcrack.so.2 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /usr/lib/libaugeas.so.0 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /usr/lib/libatm.so.1 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /lib/libxtables.so.7 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /lib/libulockmgr.so.1 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /lib/libudev.so.0 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /lib/libsystemd-login.so.0 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /lib/libsystemd-daemon.so.0 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /lib/libss.so.2 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /lib/libsepol.so.1 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /lib/libpopt.so.0 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /lib/libpcre.so.0 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /lib/libparted.so.1 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /lib/libpamc.so.0 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /lib/libpam_misc.so.0 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /lib/libpam.so.0 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /lib/libnss_myhostname.so.2 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /lib/libnilfs.so.0 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /lib/libmount.so.1 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /lib/libiptc.so.0 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /lib/libipq.so.0 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /lib/libip6tc.so.0 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /lib/libip4tc.so.0 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /lib/libidn.so.11 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /lib/libhandle.so.1 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /lib/libfuse.so.2 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /lib/libext2fs.so.2 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /lib/libe2p.so.2 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /lib/libcryptsetup.so.1 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /lib/libcrypto.so.10 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /lib/libcap.so.2 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /lib/libcap-ng.so.0 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /lib/libbz2.so.1 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /lib/libblkid.so.1 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /lib/libattr.so.1 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /lib/libaio.so.1 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Processing Dependency: /lib/libacl.so.1 for package: 1:libguestfs-1.16.5-1.fc16.i686
--> Running transaction check
---> Package augeas-libs.i686 0:0.10.0-3.fc16 will be installed
---> Package bzip2-libs.i686 0:1.0.6-3.fc15 will be installed
---> Package cracklib.i686 0:2.8.18-2.fc15 will be installed
---> Package cryptsetup-luks-libs.i686 0:1.3.1-3.fc16 will be installed
--> Processing Dependency: libdevmapper.so.1.02(Base) for package: cryptsetup-luks-libs-1.3.1-3.fc16.i686
--> Processing Dependency: libdevmapper.so.1.02 for package: cryptsetup-luks-libs-1.3.1-3.fc16.i686
---> Package e2fsprogs-libs.i686 0:1.41.14-2.fc15 will be installed
---> Package file-libs.i686 0:5.07-6.fc16 will be installed
---> Package fuse-libs.i686 0:2.8.6-1.fc16 will be installed
---> Package gdbm.i686 0:1.8.3-9.fc15 will be installed
---> Package gmp.i686 1:4.3.2-4.fc16 will be installed
---> Package hivex.i686 0:1.3.3-1.fc16 will be installed
---> Package iptables.i686 0:1.4.12-2.fc16 will be installed
---> Package libacl.i686 0:2.2.51-2.fc16 will be installed
---> Package libaio.i686 0:0.3.109-4.fc16 will be installed
---> Package libattr.i686 0:2.4.46-2.fc16 will be installed
---> Package libblkid.i686 0:2.20.1-2.2.fc16 will be installed
---> Package libcap.i686 0:2.22-1.fc15 will be installed
---> Package libcap-ng.i686 0:0.6.6-1.fc16 will be installed
---> Package libidn.i686 0:1.22-3.fc16 will be installed
---> Package libmount.i686 0:2.20.1-2.2.fc16 will be installed
---> Package libsemanage.i686 0:2.1.2-1.fc16 will be installed
---> Package libsepol.i686 0:2.1.3-2.fc16 will be installed
---> Package libss.i686 0:1.41.14-2.fc15 will be installed
---> Package libudev.i686 0:173-3.fc16 will be installed
---> Package libutempter.i686 0:1.1.5-5.fc15 will be installed
---> Package libvirt-client.i686 0:0.9.6-5.fc16 will be installed
--> Processing Dependency: libyajl.so.1 for package: libvirt-client-0.9.6-5.fc16.i686
--> Processing Dependency: libxenstore.so.3.0 for package: libvirt-client-0.9.6-5.fc16.i686
--> Processing Dependency: libwsman_curl_client_transport.so.1 for package: libvirt-client-0.9.6-5.fc16.i686
--> Processing Dependency: libwsman_client.so.1 for package: libvirt-client-0.9.6-5.fc16.i686
--> Processing Dependency: libwsman.so.1 for package: libvirt-client-0.9.6-5.fc16.i686
--> Processing Dependency: libssh2.so.1 for package: libvirt-client-0.9.6-5.fc16.i686
--> Processing Dependency: libpcap.so.1 for package: libvirt-client-0.9.6-5.fc16.i686
--> Processing Dependency: libnuma.so.1(libnuma_1.2) for package: libvirt-client-0.9.6-5.fc16.i686
--> Processing Dependency: libnuma.so.1(libnuma_1.1) for package: libvirt-client-0.9.6-5.fc16.i686
--> Processing Dependency: libnuma.so.1 for package: libvirt-client-0.9.6-5.fc16.i686
--> Processing Dependency: libnl.so.1 for package: libvirt-client-0.9.6-5.fc16.i686
--> Processing Dependency: libnetcf.so.1(NETCF_1.4.0) for package: libvirt-client-0.9.6-5.fc16.i686
--> Processing Dependency: libnetcf.so.1(NETCF_1.3.0) for package: libvirt-client-0.9.6-5.fc16.i686
--> Processing Dependency: libnetcf.so.1(NETCF_1.2.0) for package: libvirt-client-0.9.6-5.fc16.i686
--> Processing Dependency: libnetcf.so.1(NETCF_1.0.0) for package: libvirt-client-0.9.6-5.fc16.i686
--> Processing Dependency: libnetcf.so.1 for package: libvirt-client-0.9.6-5.fc16.i686
--> Processing Dependency: libcurl.so.4 for package: libvirt-client-0.9.6-5.fc16.i686
---> Package linux-atm-libs.i686 0:2.5.1-3.fc15 will be installed
---> Package lzo.i686 0:2.06-1.fc16 will be installed
---> Package nilfs-utils.i686 0:2.0.23-1.fc16 will be installed
---> Package nss-myhostname.i686 0:0.3-1.fc16 will be installed
---> Package openssl.i686 0:1.0.0g-1.fc16 will be installed
---> Package pam.i686 0:1.1.5-5.fc16 will be installed
--> Processing Dependency: libdb-4.8.so for package: pam-1.1.5-5.fc16.i686
---> Package parted.i686 0:3.0-4.fc16 will be installed
---> Package pcre.i686 0:8.12-7.fc16 will be installed
---> Package popt.i686 0:1.13-9.fc16 will be installed
---> Package slang.i686 0:2.2.4-1.fc16 will be installed
---> Package systemd.i686 0:37-17.fc16 will be installed
---> Package ustr.i686 0:1.0.4-9.fc12 will be installed
---> Package xfsprogs.i686 0:3.1.5-1.fc16 will be installed
---> Package xz-libs.i686 0:5.1.1-1alpha.fc16 will be installed
--> Running transaction check
---> Package db4.i686 0:4.8.30-3.fc15 will be installed
---> Package device-mapper-libs.i686 0:1.02.65-6.fc16 will be installed
---> Package libcurl.i686 0:7.21.7-7.fc16 will be installed
---> Package libnl.i686 0:1.1-14.fc16 will be installed
---> Package libpcap.i686 14:1.1.1-4.fc16 will be installed
---> Package libssh2.i686 0:1.2.7-4.fc16 will be installed
---> Package libwsman1.i686 0:2.2.5-3.fc16 will be installed
---> Package netcf-libs.i686 0:0.1.9-1.fc16 will be installed
--> Processing Dependency: libxslt.so.1(LIBXML2_1.0.22) for package: netcf-libs-0.1.9-1.fc16.i686
--> Processing Dependency: libxslt.so.1 for package: netcf-libs-0.1.9-1.fc16.i686
--> Processing Dependency: libxslt.so.1(LIBXML2_1.0.13) for package: netcf-libs-0.1.9-1.fc16.i686
--> Processing Dependency: libxslt.so.1(LIBXML2_1.1.18) for package: netcf-libs-0.1.9-1.fc16.i686
--> Processing Dependency: libexslt.so.0 for package: netcf-libs-0.1.9-1.fc16.i686
--> Processing Dependency: libxslt.so.1(LIBXML2_1.0.18) for package: netcf-libs-0.1.9-1.fc16.i686
--> Processing Dependency: libxslt.so.1(LIBXML2_1.0.11) for package: netcf-libs-0.1.9-1.fc16.i686
---> Package numactl.i686 0:2.0.7-2.fc16 will be installed
---> Package xen-libs.i686 0:4.1.2-6.fc16 will be installed
---> Package yajl.i686 0:1.0.12-1.fc16 will be installed
--> Running transaction check
---> Package libxslt.i686 0:1.1.26-8.fc16 will be installed
--> Finished Dependency Resolution
Error: Protected multilib versions: 1:libguestfs-1.16.5-1.fc16.i686 != 1:libguestfs-1.16.12-1.fc16.x86_64
Error: Protected multilib versions: openssl-1.0.0g-1.fc16.i686 != openssl-1.0.0h-1.fc16.x86_64
Comment 3 Richard W.M. Jones 2012-04-03 15:42:17 EDT
Can you just remove the .i686 package?

I'm going to put this down to multilib being useless and
broken and reassign to yum.
Comment 4 John Dulaney 2012-04-03 17:34:19 EDT
(In reply to comment #3)
> Can you just remove the .i686 package?
> 
> I'm going to put this down to multilib being useless and
> broken and reassign to yum.

I never installed the i686 packages; I did manually install all the x86_64 deps and then did rpm --force install of libguestfs-tools-c and libguestfs-tools.  I have been using libguestfs-tools since with no problems.  I don't know why it wants to list the i686 packages as deps.
Comment 5 Fedora Admin XMLRPC Client 2012-04-27 11:27:39 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 6 Fedora End Of Life 2013-01-16 11:48:34 EST
This message is a reminder that Fedora 16 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 16. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '16'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 16's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 16 is end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" and open it against that version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Fedora End Of Life 2013-02-13 15:49:51 EST
Fedora 16 changed to end-of-life (EOL) status on 2013-02-12. Fedora 16 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.