Bug 809620 - NetworkManager marks connection without any routes as completed
NetworkManager marks connection without any routes as completed
Status: CLOSED DUPLICATE of bug 806486
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: NetworkManager (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: rc
: 6.3
Assigned To: Dan Williams
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-03 16:12 EDT by David Jaša
Modified: 2012-04-13 10:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-12 04:08:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Jaša 2012-04-03 16:12:56 EDT
Description of problem:
NetworkManager marks connection without any routes as completed. See also bug #806486

Version-Release number of selected component (if applicable):
NetworkManager-0.8.1-28.el6.x86_64
NetworkManager-openvpn-0.8.1-0.1.git20100609.el6.x86_64

How reproducible:
always with versions specified below

Steps to Reproduce:
1. (connect to openvpn network)
2. adding default routes fails:
Apr  3 21:34:18 dhcp-29-7 NetworkManager[10201]: <error> [1333481658.589502]
[nm-system.c:187] nm_system_device_set_ip4_route(): (tun0): failed to set IPv4
route: Netlink Error (errno = No such process)
Apr  3 21:34:18 dhcp-29-7 NetworkManager[10201]: <error> [1333481658.589619]
[nm-system.c:187] nm_system_device_set_ip4_route(): (tun0): failed to set IPv4
route: Netlink Error (errno = No such process)
3.
  
Actual results:
connection is marked as completed:
Apr  3 21:34:18 dhcp-29-7 NetworkManager[10201]: <info> VPN connection 'Red Hat
AMS2 OVPN' (IP Config Get) complete.

Expected results:
connection is marked as failed, an error with short description is presented to the user

Additional info:
rpm -q --whatprovides $(rpm -qR NetworkManager{,-openvpn}) \
| grep -v 'i[3-6]86$\|neposkytuje' | sort | uniq 
atk-1.28.0-2.el6.x86_64
avahi-autoipd-0.6.25-11.el6.x86_64
bash-4.1.2-8.el6.x86_64
cairo-1.8.8-3.1.el6.x86_64
dbus-glib-0.86-5.el6.x86_64
dbus-libs-1.2.24-6.el6.x86_64
dbus-1.2.24-6.el6.x86_64
desktop-file-utils-0.15-9.el6.x86_64
dhclient-4.1.1-30.P1.el6.x86_64
dnsmasq-2.48-6.el6.x86_64
fontconfig-2.8.0-3.el6.x86_64
freetype-2.3.11-6.el6_1.8.x86_64
GConf2-2.28.0-6.el6.x86_64
glibc-2.12-1.77.el6.x86_64
glib2-2.22.5-7.el6.x86_64
gnome-keyring-2.28.2-7.el6.x86_64
gtk2-2.18.9-10.el6.x86_64
chkconfig-1.3.49.3-2.el6.x86_64
iproute-2.6.32-19.el6.x86_64
libglade2-2.6.4-3.1.el6.x86_64
libgudev1-147-2.41.el6.x86_64
libnl-1.1-14.el6.x86_64
libuuid-2.17.2-12.6.el6.x86_64
libxml2-2.7.6-4.el6_2.4.x86_64
mobile-broadband-provider-info-1.20100122-1.el6.noarch
ModemManager-0.4.0-3.git20100628.el6.x86_64
NetworkManager-glib-0.8.1-28.el6.x86_64
NetworkManager-0.8.1-28.el6.x86_64
nspr-4.9-1.el6.x86_64
nss-util-3.13.3-2.el6.x86_64
nss-3.13.3-5.el6.x86_64
openvpn-2.2.1-1.el6.x86_64
pango-1.28.1-6.el6.x86_64
polkit-0.96-2.el6_0.1.x86_64
ppp-2.4.5-5.el6.x86_64
shared-mime-info-0.70-4.el6.x86_64
udev-147-2.41.el6.x86_64
wpa_supplicant-0.7.3-3.el6.x86_64
Comment 1 Jirka Klimes 2012-04-12 04:08:16 EDT

*** This bug has been marked as a duplicate of bug 806486 ***

Note You need to log in before you can comment on or make changes to this bug.