Bug 809660 - SELinux is preventing /opt/google/chrome/chrome from using the 'ptrace' accesses on a process.
SELinux is preventing /opt/google/chrome/chrome from using the 'ptrace' acces...
Status: CLOSED DUPLICATE of bug 804202
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:f21e8307a17b61316a5946b84fb...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-03 20:31 EDT by Germán Ríos
Modified: 2012-04-04 04:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-04 04:21:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Germán Ríos 2012-04-03 20:31:29 EDT
libreport version: 2.0.10
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.0-8.fc17.x86_64
time:           Tue 03 Apr 2012 19:31:04 COT

description:
:SELinux is preventing /opt/google/chrome/chrome from using the 'ptrace' accesses on a process.
:
:*****  Plugin catchall_boolean (89.3 confidence) suggests  *******************
:
:If you want to allow sysadm to debug or ptrace all processes.
:Then you must tell SELinux about this by enabling the 'deny_ptrace'boolean.
:Do
:setsebool -P deny_ptrace 0
:
:*****  Plugin catchall (11.6 confidence) suggests  ***************************
:
:If you believe that chrome should be allowed ptrace access on processes labeled unconfined_t by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep WorkerPool/2149 /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
:                              023
:Target Context                unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
:                              023
:Target Objects                 [ process ]
:Source                        WorkerPool/2149
:Source Path                   /opt/google/chrome/chrome
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           google-chrome-unstable-19.0.1084.9-130290.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-106.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.0-8.fc17.x86_64 #1 SMP Thu
:                              Mar 29 18:18:26 UTC 2012 x86_64 x86_64
:Alert Count                   5
:First Seen                    Tue 03 Apr 2012 17:40:16 COT
:Last Seen                     Tue 03 Apr 2012 17:40:16 COT
:Local ID                      e61ea30d-db09-4a7d-b49f-05b5afb5deae
:
:Raw Audit Messages
:type=AVC msg=audit(1333492816.578:126): avc:  denied  { ptrace } for  pid=2284 comm="WorkerPool/2149" scontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tclass=process
:
:
:type=SYSCALL msg=audit(1333492816.578:126): arch=x86_64 syscall=ptrace success=no exit=EACCES a0=10 a1=8e5 a2=0 a3=0 items=0 ppid=2121 pid=2284 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=2 comm=WorkerPool/2149 exe=/opt/google/chrome/chrome subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 key=(null)
:
:Hash: WorkerPool/2149,unconfined_t,unconfined_t,process,ptrace
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Miroslav Grepl 2012-04-04 04:21:41 EDT

*** This bug has been marked as a duplicate of bug 804202 ***

Note You need to log in before you can comment on or make changes to this bug.