Bug 80968 - [via82cxx_audio?] Logout from gnome-session locks up consistently
[via82cxx_audio?] Logout from gnome-session locks up consistently
Status: CLOSED DUPLICATE of bug 76603
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks: 79579 79678 82777
  Show dependency treegraph
 
Reported: 2003-01-02 16:12 EST by Michal Jaegermann
Modified: 2013-07-02 22:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:50:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X configuration file (3.17 KB, text/plain)
2003-01-08 17:34 EST, Michal Jaegermann
no flags Details
whatever configurator had to say (1.50 KB, text/plain)
2003-01-08 17:35 EST, Michal Jaegermann
no flags Details
/var/log/dmesg (7.69 KB, text/plain)
2003-01-08 17:36 EST, Michal Jaegermann
no flags Details
XFree86 log file (37.58 KB, text/plain)
2003-01-08 17:37 EST, Michal Jaegermann
no flags Details
a capture from a gnome-session crashing a machine (113.35 KB, text/plain)
2003-01-17 18:58 EST, Michal Jaegermann
no flags Details

  None (edit)
Description Michal Jaegermann 2003-01-02 16:12:53 EST
Description of problem:

As in a summary above.  Picking up "Log out" from a menu locks everything.
A machine does not respond to a keyboard, mouse or on network.  Reset button
still works.  So far I have a 100% hit rate.  The only visible differences
are that sometimes I have an instant freeze and sometimes screens dims and
a somewhat lighter rectangle is drawn in the middle of a screen before things
go bye-bye.
Comment 1 Havoc Pennington 2003-01-02 16:52:20 EST

*** This bug has been marked as a duplicate of 79829 ***
Comment 2 Michal Jaegermann 2003-01-02 17:06:19 EST
Bug #79829 talks about "ages" to logout.  Every time I was hit with a bug
reported it took me a few minutes to check that I indeed cannot get to
my machine in some way and nothing was happening.  Note that an affected machine
drops dead on a network as well.  It is not even pingable.  Before an attempt
to logout networking is operational.
Comment 3 Havoc Pennington 2003-01-02 17:21:01 EST
If you're not even pingable, that's some kind of kernel (or possibly XFree86, or
hardware) problem.
Comment 4 Bill Nottingham 2003-01-02 17:57:59 EST
What sort of HW? (video, motherboard)
Comment 5 Michal Jaegermann 2003-01-02 19:00:27 EST
-[00]-+-00.0  VIA Technologies, Inc. VT8371 [KX133]
      +-01.0-[01]----00.0  Matrox Graphics, Inc. MGA G400 AGP
      +-07.0  VIA Technologies, Inc. VT82C686 [Apollo Super South]
      +-07.1  VIA Technologies, Inc. VT82C586B PIPC Bus Master IDE
      +-07.4  VIA Technologies, Inc. VT82C686 [Apollo Super ACPI]
      +-07.5  VIA Technologies, Inc. VT82C686 AC97 Audio Controller
      \-09.0-[02]--+-04.0  LSI Logic / Symbios Logic 53c895
                   \-05.0  Digital Equipment Corporation DECchip 21142/43


My "regular workhorse" machine (Athlon 750 MHz, currently 375 Megs of memory)
which I am using for quite a while now.
Comment 6 Michal Jaegermann 2003-01-02 22:07:55 EST
I checked that lockups happen at least with metacity and sawfish window
managers.  OTOH hitting Alt-Ctrl-Backspace restarts gdm without any troubles;
but that kind of logout does not allow, for example, to save session
properties and other details of that sort.
Comment 7 Mike A. Harris 2003-01-08 01:01:31 EST
sounds to me like a kernel issue, perhaps even DRM.  Please provide standard
X files, etc.
Comment 8 Michal Jaegermann 2003-01-08 17:34:08 EST
Created attachment 89222 [details]
X configuration file

Uncommenting 
	Option	"XkbOptions"	"ctrl:nocaps"
line is the only change from what was created by 'redhat-config-xfree86'
Comment 9 Michal Jaegermann 2003-01-08 17:35:59 EST
Created attachment 89223 [details]
whatever configurator had to say
Comment 10 Michal Jaegermann 2003-01-08 17:36:46 EST
Created attachment 89224 [details]
/var/log/dmesg
Comment 11 Michal Jaegermann 2003-01-08 17:37:23 EST
Created attachment 89225 [details]
XFree86 log file
Comment 12 Michal Jaegermann 2003-01-09 11:52:48 EST
I tried the same with "acpi=off" as this seems to be a major difference
with a kernel I am using for everyday operation on the same machine
(currently 2.4.18-19.7.x) and where everything works just fine.
Results were exactly the same, i.e. an instant lockup.
Comment 13 Michal Jaegermann 2003-01-09 17:58:24 EST
I should add that a similar action in a KDE session does not have any
nasty consequences.
Comment 14 Mike A. Harris 2003-01-15 03:10:15 EST
Ugh...  when attaching files, please set the Mimetype correctly.  Bugzilla wants
me to download all this stuff instead of viewing it inline because everything
is set to:  application/octet-stream  which implies a binary file attachment.

Very inconvenient.
Comment 15 Mike A. Harris 2003-01-15 03:15:08 EST
This bug is similar if not a dupe of bug #79678 however since you're using
Matrox hardware and the other bug and it's dupes are Radeon hardware, these
could be different problems.

Please check out the other bug report and try the suggestions there for
helping narrow the problem down.  It could end up being a DRI centric problem
rather than a driver centric one, so the data would be quite helpful.

Adding Arjan to CC list since it is probably DRM problem and thus kernel related.
Comment 16 Mike A. Harris 2003-01-15 03:17:05 EST
Also.. try disabling DRI to test the theory that it is a DRM problem.

On another note, your log file shows some minor driver bugs:

Symbol drmCtlUninstHandler from module /usr/X11R6/lib/modules/drivers/mga_drv.o
is unresolved!
Symbol drmCtlInstHandler from module /usr/X11R6/lib/modules/drivers/mga_drv.o is
unresolved!
Symbol drmGetInterruptFromBusID from module
/usr/X11R6/lib/modules/drivers/mga_drv.o is unresolved!

I'll try to fix that for the next build.
Comment 17 Mike A. Harris 2003-01-15 03:37:14 EST
Unresolved symbols issue fixed in 4.2.99.3-20021230.7

Comment 18 Mike A. Harris 2003-01-15 03:38:39 EST
Adding bug #79678 as a blocker, just so I can make sure these two are
attached somehow for now in case they are indeed related.
Comment 19 Michal Jaegermann 2003-01-15 13:48:25 EST
I am afraid that disabling DRI did not change the situation at all.  I have
now in log files

(==) MGA(0): Direct rendering disabled

and log out still locks up everything.  I eventually commented out from
Section "Module" all lines save

        Load  "freetype"
        Load  "type1"

with no discernible impact on the problem.

After every crash fsck finds, always, in my /tmp exactly three orphaned
nodes of a size 0.  That is the only thing I can tell so far.
Comment 20 Michal Jaegermann 2003-01-17 18:54:04 EST
I rigged a capture to another system via a serial line and modified
/usr/bin/gdm to run 'strace -f /usr/bin/gdm-binary "$@"' instead.
After a lockup as described captured output terminates with

Assertion failed! buffer != NULL,via82cxxx_audio.c,via_dsp_write,line=2498

Hence this bug seems to be related to #76603 although _starting_ gnome
is not causing such incidents any longer.

After commenting out sound in /etc/modules.conf it is possible to "log out"
from a gnome-session (although such operation takes over five minutes which
is quite a bit longer than reported in bug 79829) without killing the whole
machine in the process.

A full contents of a capture, leading to a crash, is attached.
Comment 21 Michal Jaegermann 2003-01-17 18:58:17 EST
Created attachment 89429 [details]
a capture from a gnome-session crashing a machine
Comment 22 Arjan van de Ven 2003-01-18 07:19:32 EST
via audio:
Jeff that's one for you
Comment 23 Sean Godsell 2003-01-18 11:10:43 EST
The problem is in either nautilus or libgnome (or libgnomeui).   A temp fix is
to kill nautilus, then nautilus will start up again automatically, and
everything should work again.   You probably noticed that if you start
openoffice you will also get a similar affect where it doesn't start until
around 5 minutes or if you kill nautilus.  Try this out for now   :-)
Comment 24 Michal Jaegermann 2003-01-18 12:32:35 EST
> A temp fix is to kill nautilus
I believe that this comment (#23) is pertinent to bug 79829, which hits
when you can logout at all, but here the main troubles are with the later
action. Anyway I did not notice openoffice to act out of character.
Comment 25 Klaasjan Brand 2003-02-23 12:17:54 EST
I've got the same problem here (logout causes hang, ctrl-alt-backspace
unresponsive, c-a-d still works) on my Intel815 mainboard with a Matrox G400
(16mb oem single-head). Maybe a video driver problem triggered by gnome logout?
Comment 26 Michal Jaegermann 2003-02-24 16:55:02 EST
With 8.0.94 beta (kernel-2.4.20-2.48) the bug is still there.
The difference for me, as opposed to an observation by Klaasjan Brand,
that my machine is totally dead after such lockup.  Nothing works on
a keyboard, network or a serial console with an exception of a power switch.

Really this does not look different from bug 76603.  The change is
that currently when I am just starting a gnome session then sound modules
are not loaded.  At least 'lsmod' does not show up anything.
I can play whatever sounds I desire while in a gnome-session.
If I will try to logout from gnome-session with a sound active in
/etc/modules.conf things go immediately into a never-never land.
No problems if sound does not come into a play (for a bad pun :-).
Comment 27 Jim Shanks 2003-03-02 00:57:18 EST
Having the same problem on a system that has been running 7.1, 7.2, and 7.3 for
almost two years.  VIA KX133 Chipset, 800MHz Athlon, Matrox G400 Dualhead,
VT82C686 onboard AC97 audio.  KDE works fine.  Gnome logout causes absolute
lockup.  Can't c-a-d, can't ping the system, power button doesn't work.  Have to
pull the plug.  New Rawhide kernel-2.4.20-2.54 has the same problem.
Comment 28 Michal Jaegermann 2003-03-07 20:46:39 EST
Unfortunately XFree86-4.3.0-2.1 test release does not change anything
in this problem.  Sound, without attempts to logout, works fine.
Comment 29 Jeff Garzik 2003-03-24 11:42:31 EST

*** This bug has been marked as a duplicate of 76603 ***
Comment 30 Red Hat Bugzilla 2006-02-21 13:50:52 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.