Bug 809722 - Error "Missing template deployables/show with {:handlers=>[:builder, :rjs, :haml, :rhtml, :erb, :rxml], :locale=>[:en, :en], :formats=>[:json, :js, "*/*"]} in view paths "/usr/share/aeolus-conductor/app/views" on conductor
Error "Missing template deployables/show with {:handlers=>[:builder, :rjs, :h...
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Jan Provaznik
wes hayutin
: Triaged
: 819907 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-04 03:48 EDT by Rehana
Modified: 2012-12-04 10:02 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Viewing an Application Blueprint created from a deleted image and then navigating to another page displayed a non-human readable error message. This bug fix updates application_controller.rb so that the error message is handled properly.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:02:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error_on_ui (213.36 KB, image/png)
2012-04-04 03:48 EDT, Rehana
no flags Details
Rails Log file (15.22 KB, application/octet-stream)
2012-04-04 03:49 EDT, Rehana
no flags Details

  None (edit)
Description Rehana 2012-04-04 03:48:30 EDT
Created attachment 575056 [details]
error_on_ui

Description of problem:
Got this error "Missing template deployables/show with {:handlers=>[:builder, :rjs, :haml, :rhtml, :erb, :rxml], :locale=>[:en, :en], :formats=>[:json, :js, "*/*"]} in view paths "/usr/share/aeolus-conductor/app/views"  on conductor after viewing the application blueprint details page which has no images 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.login to conductor
2.build/push image and create application blueprint
3.Delete the image
4.View the detail page of application blueprint created from above image
5. Now move to different page
  
Actual results:
Observed that the error message "Missing template deployables/show with {:handlers=>[:builder, :rjs, :haml, :rhtml, :erb, :rxml], :locale=>[:en, :en], :formats=>[:json, :js, "*/*"]} in view paths "/usr/share/aeolus-conductor/app/views"  on conductor 

PFA:rails.log, error_on_ui.png

Expected results:
Error Should be handled.

Additional info:

rpm -qa | grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-0.8.7-1.el6.noarch
aeolus-conductor-doc-0.8.7-1.el6.noarch
aeolus-conductor-daemons-0.8.7-1.el6.noarch
aeolus-configure-2.5.2-1.el6.noarch
aeolus-all-0.8.7-1.el6.noarch
rubygem-aeolus-cli-0.3.1-1.el6.noarch
Comment 1 Rehana 2012-04-04 03:49:58 EDT
Created attachment 575057 [details]
Rails Log file
Comment 2 Dave Johnson 2012-05-08 11:50:42 EDT
*** Bug 819907 has been marked as a duplicate of this bug. ***
Comment 3 Jan Provaznik 2012-05-09 07:23:55 EDT
patch is pushed in master, commit:e3616e860d98d2d7999affdd28d0dd63a9f796a0
Comment 5 Aziza Karol 2012-09-18 01:46:39 EDT
This error is not reproducible.

verified:
rpm -qa | grep aeolus
aeolus-conductor-0.13.7-1.el6cf.noarch
aeolus-all-0.13.7-1.el6cf.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
aeolus-conductor-doc-0.13.7-1.el6cf.noarch
aeolus-configure-2.8.6-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-daemons-0.13.7-1.el6cf.noarch
[root@hp-bl480c-01 ~]# hostname
hp-bl480c-01.rhts.eng.bos.redhat.com
Comment 7 errata-xmlrpc 2012-12-04 10:02:41 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.