This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 809781 - vpnc fails on RHEL5.3 (vpnc: relocation error: vpnc: symbol gcry_cipher_setkey)
vpnc fails on RHEL5.3 (vpnc: relocation error: vpnc: symbol gcry_cipher_setkey)
Status: CLOSED WONTFIX
Product: Fedora EPEL
Classification: Fedora
Component: vpnc (Show other bugs)
el5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Huzaifa S. Sidhpurwala
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-04 07:19 EDT by James Patterson
Modified: 2016-12-27 16:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-27 16:11:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Patterson 2012-04-04 07:19:23 EDT
Description of problem:
vpnc fails to run on RHEL5.3 with a missing symbol error.
I will attach the error message shortly.

As a workaround, rebuilding the package on RHEL5.3 works.

Since RHEL releases are forward binary compatible, would it be possible for the current version of the package to be built on an older version of RHEL5?

Thanks.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 James Patterson 2012-04-04 08:17:57 EDT
Some more info:

# cat /tmp/error 
vpnc: relocation error: vpnc: symbol gcry_cipher_setkey, version GCRYPT_1.2 not defined in file libgcrypt.so.11 with link time reference

We get the error when we try to convert the pcf file to cpnf with pcf2vpnc or when we are trying to connect to a vpn server using vpnc.


# lsb_release -a
LSB Version:       :core-3.1-amd64:core-3.1-ia32:core-3.1-noarch:graphics-3.1-amd64:graphics-3.1-ia32:graphics-3.1-noarch
Distributor ID:   RedHatEnterpriseClient
Description:       Red Hat Enterprise Linux Client release 5.3 (Tikanga)
Release:              5.3
Codename:        Tikanga
Comment 2 James Patterson 2013-05-14 09:06:11 EDT
I guess you're not interested in bug reports for vpnc. I won't report any again.

Please can you close this bug. Thanks.

Note You need to log in before you can comment on or make changes to this bug.