Bug 809787 - Reference to "deployable" should be changed to "Application blueprint"
Reference to "deployable" should be changed to "Application blueprint"
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity low
: beta2
: ---
Assigned To: Matt Wagner
wes hayutin
:
: 816039 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-04 07:37 EDT by Rehana
Modified: 2014-08-17 18:27 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
An upstream word "Deployable" was found in the Catalog Images section. This bug fix updates pools_controller.rb and changes the wording to "Application Blueprint".
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:02:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
deployable (232.47 KB, image/png)
2012-04-04 07:37 EDT, Rehana
no flags Details
deployable on 1.1 (80.41 KB, image/png)
2012-09-18 05:29 EDT, Rehana
no flags Details
deployable (84.40 KB, image/png)
2012-09-21 08:16 EDT, pushpesh sharma
no flags Details
Appln_blueprint (43.33 KB, image/png)
2012-09-25 03:11 EDT, Rehana
no flags Details

  None (edit)
Description Rehana 2012-04-04 07:37:12 EDT
Created attachment 575095 [details]
deployable

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Login to conductor
2.Go to "monitor"
3.Select any CRZ
4.Go to 'Catalog images' section (PFA: deployable.png)
  
Actual results:
The reference to deployable was found

Expected results:
Should be changed to "application blueprints"

Additional info:

rpm -qa | grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-0.8.7-1.el6.noarch
aeolus-conductor-doc-0.8.7-1.el6.noarch
aeolus-conductor-daemons-0.8.7-1.el6.noarch
aeolus-configure-2.5.2-1.el6.noarch
aeolus-all-0.8.7-1.el6.noarch
rubygem-aeolus-cli-0.3.1-1.el6.noarch
Comment 1 wes hayutin 2012-04-30 12:29:16 EDT
*** Bug 816039 has been marked as a duplicate of this bug. ***
Comment 3 Rehana 2012-09-18 05:29:00 EDT
Still the reference to "Deployable" is not changed to "Application blueprint"

PFA:deployable.png

rpm -qa | grep aeolus 
aeolus-conductor-doc-0.13.7-1.el6cf.noarch
aeolus-configure-2.8.6-1.el6cf.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
aeolus-conductor-0.13.7-1.el6cf.noarch
aeolus-all-0.13.7-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-daemons-0.13.7-1.el6cf.noarch
Comment 4 Rehana 2012-09-18 05:29:37 EDT
Created attachment 613922 [details]
deployable on 1.1
Comment 5 Matt Wagner 2012-09-19 15:54:34 EDT
Well this was a weird on.

Those table headers weren't in en.yml at all. They were just random lowercase things combined with underscores that we displayed faithfully.

Since this is after string freeze, I had to get a little creative with finding things to display. Will send a patch momentarily.
Comment 7 Tzu-Mainn Chen 2012-09-19 16:33:36 EDT
ACK and pushed to master and 1.1:

commit c39a698a55d8ea86d80cf0c036e6ba240c45d6f1
Author: Matt Wagner <matt.wagner@redhat.com>
Date:   Wed Sep 19 16:30:51 2012 -0400

    BZ 809787 - Fixes untranslated table header
    
    For some reason this table header was never updated to use
    strings from en.yml, or even uppercase strings.
    
    Because it's after string freeze, I had to be slightly creative
    in fitting things in, so I left a comment suggesting that the
    keys I used might need cleanup later.
    
    Fixes https://bugzilla.redhat.com/show_bug.cgi?id=809787
    but is equally as useful upstream.
    
    Signed-off-by: Tzu-Mainn Chen <tzumainn@redhat.com>
    (cherry picked from commit 5b295d28e935da8b46da5a68547bb8af23f43a42)
Comment 9 pushpesh sharma 2012-09-21 08:15:15 EDT
1.Login to conductor
2.Go to "monitor"
3.Select any CRZ
4.Go to 'Catalog images' section (PFA: deployable.png)

Problem is still there reference to 'deployable' found on above page,marking as assigned.

[root@dhcp201-113 ~]# rpm -qa|grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-all-0.13.8-1.el6cf.noarch
aeolus-conductor-0.13.8-1.el6cf.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
aeolus-configure-2.8.6-1.el6cf.noarch
aeolus-conductor-daemons-0.13.8-1.el6cf.noarch
aeolus-conductor-doc-0.13.8-1.el6cf.noarch
[root@dhcp201-113 ~]#
Comment 10 pushpesh sharma 2012-09-21 08:16:05 EDT
Created attachment 615412 [details]
deployable
Comment 11 Tzu-Mainn Chen 2012-09-21 08:31:37 EDT
aeolus-conductor-0.13.8-1.el6cf.noarch was built on 2012-09-14, so the fix wouldn't be in.  A recent conductor build should have the fix.
Comment 12 Rehana 2012-09-25 03:11:24 EDT
Created attachment 616881 [details]
Appln_blueprint

The above mentioned observation is fixed on 

rpm -qa | grep aeolus
aeolus-conductor-doc-0.13.14-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-all-0.13.14-1.el6cf.noarch
aeolus-conductor-0.13.14-1.el6cf.noarch
rubygem-aeolus-cli-0.7.2-1.el6cf.noarch
aeolus-configure-2.8.7-1.el6cf.noarch
aeolus-conductor-daemons-0.13.14-1.el6cf.noarch

moving to verified
Comment 14 errata-xmlrpc 2012-12-04 10:02:50 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.