Bug 809802 - RFE: Custom Feedback.xml
RFE: Custom Feedback.xml
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: CSProcessor (Show other bugs)
1.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Lee Newson
Joshua Wulf
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-04 08:31 EDT by Joshua Wulf
Modified: 2014-10-19 19:00 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.32.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-09 01:10:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Wulf 2012-04-04 08:31:44 EDT
The request is to add another parameter to Content Spec Metadata section:

Feedback= <TopicID>

This way we can create a Topic Type that handles Feedback boilerplate text. 

When assembling the Content Spec into a publican book, the Topic specified as the Feedback parameter (if one is specified) should be written to the publican assembly as Feedback.xml.
Comment 1 Stephen Gordon 2012-10-09 11:43:05 EDT
Just +1ing this request, I'm starting to think we might need it for RHEV. The problem I am facing with it currently is the &PRODUCT; value we list the guides under on the site is (intentionally) Red Hat Enterprise Virtualization, the &BZPRODUCT; though is Red Hat Enterprise Virtualization *Manager*.

Currently I notice when I assemble the installation guide using the CSP it falls back on the Feedback.xml from common content (good) which uses the &PRODUCT; value as the bugzilla component (bad) because it doesn't know about &BZPRODUCT;.
Comment 2 Stephen Gordon 2012-10-09 11:44:17 EDT
(In reply to comment #1)
> ...which uses the &PRODUCT; value as the bugzilla component (bad) because it 
> doesn't know about &BZPRODUCT;.

I meant the bugzilla *product* here, not component.
Comment 3 Lee Newson 2012-10-09 17:29:23 EDT
The CSP BZProduct Metadata field is used by default in the .ent file and defaults back to the Product metadata component when the BZProduct isn't specified.

As for this RFE I'll have to talk it over more with the team, however unless it's desperately needed it'll remain as a low priority.
Comment 4 Stephen Gordon 2012-10-09 19:37:38 EDT
(In reply to comment #3)
> The CSP BZProduct Metadata field is used by default in the .ent file and
> defaults back to the Product metadata component when the BZProduct isn't
> specified.
> 
> As for this RFE I'll have to talk it over more with the team, however unless
> it's desperately needed it'll remain as a low priority.

Yeah, ultimately I think our needs would be better addressed by the proposal I outlined in Bug # 864616. I think overriding Feedback.xml is a valid option that should be considered (both for this an other scenarios) but I would prefer to avoid it and use the Feedback.xml from the brand.
Comment 5 Lee Newson 2012-10-09 19:46:22 EDT
I agree, as that RFE has less translation overhead as well.
Comment 6 Lee Newson 2013-05-16 17:22:35 EDT
Added in 0.32.0, syntax is as follows:

Feedback = [<ID>]

or

Feedback = [<ID>, rev: <REV>]

and it goes in the metadata section of a content specification.
Comment 7 Lee Newson 2013-10-09 01:10:49 EDT
Moving this bug to CLOSED CURRENT_RELEASE to clean up old bugs that were QA'd by the PressGang team but not by the original reporter.

Note You need to log in before you can comment on or make changes to this bug.