Bug 809805 - Failed to clone vm from a snapshot which is not the first in chain
Failed to clone vm from a snapshot which is not the first in chain
Status: CLOSED NOTABUG
Product: oVirt
Classification: Community
Component: ovirt-engine-core (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Yair Zaslavsky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-04 08:34 EDT by Avihai Shoham
Modified: 2015-03-04 19:17 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-05 08:19:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm log (887.78 KB, application/octet-stream)
2012-04-04 08:34 EDT, Avihai Shoham
no flags Details

  None (edit)
Description Avihai Shoham 2012-04-04 08:34:47 EDT
Created attachment 575109 [details]
vdsm log

when i cloned a VM from a snapshot which it isn't the first in  chain the cloning action failed due to "Can not found any default active domain for one of the disks of template with id : 00000000-0000-0000-0000-000000000000"


Observed by Yzaslavs 


Steps to Reproduce:
1.Create 2 snapshot
2.Clone VM from the 2nd snapshot

Actual results:
Snapshot failed

Expected results:
Snapshot success
Comment 1 Yair Zaslavsky 2012-04-04 08:43:04 EDT
This has to do with wrong treatment in the code of multiple storage domains -
there is a check that compares the map passed by UI and the size of the list of images - it uses the code of AddVmCommand.buildAndCheckDestStorageDomains -
This method should be changed to use methods that will be overriden in child classes to return the correct images list (and not the images of the templates which are not relevant here).
Comment 2 Avihai Shoham 2012-04-05 08:19:54 EDT
environment miss-configuration

Note You need to log in before you can comment on or make changes to this bug.