This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 809821 - [UserPortal-gwtp] VM can not start after set its snapshot to "preview" mode
[UserPortal-gwtp] VM can not start after set its snapshot to "preview" mode
Status: CLOSED WORKSFORME
Product: oVirt
Classification: Community
Component: ovirt-engine-userportal (Show other bugs)
unspecified
Unspecified Unspecified
high Severity urgent
: ---
: ---
Assigned To: Tomas Jelinek
virt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-04 09:08 EDT by Avihai Shoham
Modified: 2012-05-09 07:47 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-09 07:47:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (89.80 KB, image/png)
2012-04-04 09:08 EDT, Avihai Shoham
no flags Details
NullPointerException description (151.26 KB, application/octet-stream)
2012-04-04 10:16 EDT, Avihai Shoham
no flags Details

  None (edit)
Description Avihai Shoham 2012-04-04 09:08:11 EDT
Created attachment 575123 [details]
screenshot

Description of problem:

when i set one of the snapshot to "preview mode" i saw  that round brackets were added to VM name

This happen only when using userportal , and it doesn't reproduced in webadmin.


How reproducible:


Steps to Reproduce:
1.login to userportal 
2.have a VM with snapshots
3. choose snapshot and set it to preview mode
  
see attached file
Comment 1 Avihai Shoham 2012-04-04 09:46:43 EDT
it occurs in the new userportal (userportal-gwtp)
Comment 2 Avihai Shoham 2012-04-04 10:16:10 EDT
Created attachment 575135 [details]
NullPointerException description
Comment 3 Avihai Shoham 2012-04-04 10:18:42 EDT
the problem with this bug , is that it will breed NullPointerException when a user will run  VM. see  attachment 575135 [details]
Comment 4 Avihai Shoham 2012-04-04 10:40:51 EDT
to fix this issue we need to resolve the round brackets which added to VM name.

Steps to Reproduce:
1.login to userportal 
2.have a VM with snapshots
3. choose snapshot and set it to preview mode (you will see that brackets were added to VM name)
4.RunOnce VM
Comment 5 Einav Cohen 2012-04-11 10:18:31 EDT
There is a possibility that there are two separate problems here, not sure if/how much they are related:

- The brackets should contain the VM description; in case the description of the VM is empty, you shouldn't see brackets at all. Here is seems that the description is empty, yet you are seeing the brackets; maybe the description is null and we are expecting a real string (i.e. empty string or non-empty string) and fail because of that; I assume that this happens only in "preview", when the relevant snapshot's configuration is being "loaded".

- When running the VM, there shouldn't be the exception - it seems more like an engine-core bug.

Tomas - please consult derez (that implemented the new snapshots view) with regards to this behavior.

[derez - you can take a look as well if you are seeing something that doesn't seem right]
Comment 6 Tomas Jelinek 2012-04-27 10:45:33 EDT
Currently it works for me - both the rounded brackets are not shown when there is no description and also the machine starts without any problem when the snapshot is in preview mode.

Could you please verify if it works also for you, so I can close this bug? I would say it has been fixed with some different patch.

Note You need to log in before you can comment on or make changes to this bug.